Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310079 - media-libs/mesa-7.8_rc1: intel_region_alloc: Assertion failed; Cannot log in with kdm.
Summary: media-libs/mesa-7.8_rc1: intel_region_alloc: Assertion failed; Cannot log in ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High blocker (vote)
Assignee: Gentoo X packagers
URL: http://bugs.freedesktop.org/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-18 13:11 UTC by Cyp
Modified: 2010-03-29 17:30 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Backport of the patch from git commit #da011fa (intel.patch,4.14 KB, patch)
2010-03-23 10:02 UTC, Guillaume Ayoub
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Cyp 2010-03-18 13:11:24 UTC
When trying to log in using kdm, media-libs/mesa-7.8_rc1 crashes with:
X: intel_regions.c:193: intel_region_alloc: Assertion `aligned_pitch == pitch * cpp' failed.

Works: media-libs/mesa-7.7-r1
Works: media-libs/mesa-7.7.1_rc1
Broken: media-libs/mesa-7.8_rc1

Using:
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) G33 GEM 20091221 2009Q4 
OpenGL version string: 1.4 Mesa 7.7.1-rc1
X.Org X Server 1.7.6
x11-drivers/xf86-video-intel-2.10.0-r1

Desperately recompiling random packages and upgrading the kernel, while wondering why there's no hint of an error message in /var/log/Xorg.0.log.old, does not fix the issue.
Desperately looking at the timestamps of all files in /var/log/, checking anything with a recent timestamp, finding the assertion in /var/log/kdm.log (which I've never heard of before), searching google with 'links', and downgrading mesa does fix the issue.

Other people with the same assertion:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/532656

Assertion added:
http://lists.freedesktop.org/archives/mesa-commit/2010-March/018230.html
Comment 1 Cyp 2010-03-18 13:34:04 UTC
The mesa commit da011faf48155a5c02ebc1fe1fa20a4f54b8c657 from yesterday, touching src/mesa/drivers/dri/intel/intel_regions.c which is the file with the assertion looks like it might fix the issue (haven't tested).

http://bugs.freedesktop.org/show_bug.cgi?id=26966#c9
Comment 2 Guillaume Ayoub 2010-03-19 14:02:38 UTC
(In reply to comment #1)
> The mesa commit da011faf48155a5c02ebc1fe1fa20a4f54b8c657 from yesterday,
> touching src/mesa/drivers/dri/intel/intel_regions.c which is the file with the
> assertion looks like it might fix the issue (haven't tested).
> 
> http://bugs.freedesktop.org/show_bug.cgi?id=26966#c9
> 

This commit applied to 7.8_rc1 fixes the bug. Patch is here (if you can’t wait for rc2):
http://cgit.freedesktop.org/mesa/mesa/patch/?id=da011faf48155a5c02ebc1fe1fa20a4f54b8c657
(note that intel_regions.c needs some trivial fixes to receive this patch).
Comment 3 Vasily 2010-03-22 09:44:14 UTC
Could anyone from x11 team mask mesa-7.8_rc1 due to multiple bugs in intel driver?
Comment 4 Kanstantsin Shautsou 2010-03-22 21:37:15 UTC
reproduced :E
Comment 5 Rémi Cardona gentoo-dev 2010-03-23 07:45:35 UTC
Please mask it locally, we want users to try it out. We'll try to backport patches very soon for intel users.

@x11 (especially Tomas), no more clean ups of mesa versions until further notice.

Thanks
Comment 6 Kanstantsin Shautsou 2010-03-23 09:31:33 UTC
You broke intel+kde, what else you want to test? 
Please mask it until backport patches.
Comment 7 Guillaume Ayoub 2010-03-23 10:02:57 UTC
Created attachment 224831 [details, diff]
Backport of the patch from git commit #da011fa

Here is a backport of the patch from git commit #da011fa.
Comment 8 Guillaume Ayoub 2010-03-23 16:44:20 UTC
The problem is *not* fixed in rc2 (added in the portage tree today), but the attached backported patch for rc1 works with rc2 too. Can the x11 team test and put the patch for rc2, please?

The bug seems to be resolved in a branch upstream (freedesktop bug #26966), unfortunately not merged in rc2.
Comment 9 Andreas Sturmlechner gentoo-dev 2010-03-24 09:44:43 UTC
(In reply to comment #8)
> The problem is *not* fixed in rc2 (added in the portage tree today), but the
> attached backported patch for rc1 works with rc2 too. Can the x11 team test and
> put the patch for rc2, please?
> 
> The bug seems to be resolved in a branch upstream (freedesktop bug #26966),
> unfortunately not merged in rc2.
> 

That's interesting. With mesa-7.8_rc2, I don't need the patch anymore (GMA4500 + KDE-4.4.1), but yesterday I switched to X Server 1.8 - so maybe this is a 1.7.x issue?
Comment 10 darkbasic 2010-03-24 10:34:28 UTC
Uhm... I have a gma x4500 but I never had crashes when starting kdm, only desktop effects which didn't work with mesa-7.8_rc1 (fixed with rc2). I use xorg-server 1.7.6 and xf86-video-intel-2.10.903 (.902 before).
Comment 11 Guillaume Ayoub 2010-03-24 11:28:29 UTC
I confirm that I have the bug even with rc2. I have xf86-video-intel-2.10.0 and xorg-server 1.7.6, with a GMA 4500 MHD.

I gave a look at the git repository, the commit corresponding to the patch is in the master branch but not in the 7.8 branch. Without this patch (with rc1 or rc2), I get "intel_region_alloc: Assertion failed" when I launch gnome-shell. No problem with the patch.
Comment 12 Kanstantsin Shautsou 2010-03-25 20:41:19 UTC
gma945  
mesa:
Installed versions:  9999[1](00:23:53 23.03.2010)(gallium motif nptl video_cards_intel xcb )
I have not working "Opengl Image Viewer" in digikam and small artefact lines in kde interface (they are appeared/disappeared randomly).
Comment 13 Guillaume Ayoub 2010-03-26 10:44:30 UTC
(In reply to comment #12)
> gma945  
> mesa:
> Installed versions:  9999[1](00:23:53 23.03.2010)(gallium motif nptl
> video_cards_intel xcb )
> I have not working "Opengl Image Viewer" in digikam and small artefact lines in
> kde interface (they are appeared/disappeared randomly).

mesa-9999 gets the source from the mesa git repository where this bug should be fixed (as it is fixed upstream in the master branch). So your problem is probably not related to this bug, feel free to open a new one if needed.

PS: I have some random artefact lines in Gnome too, maybe related to mesa…
Comment 14 Guillaume Ayoub 2010-03-26 10:50:42 UTC
Good news, the patch has been merged upstream in the 7.8 branch, 10 hours ago. The next release should close this bug.
Comment 15 Cyp 2010-03-28 06:37:45 UTC
The new release media-libs/mesa-7.8_rc2 does not work for me either. I get the same assertion.

I'm confused about how I can still get the same assertion, after a patch that completely removes the assert() line. I suspect the patch wasn't applied to _rc2 either.
Comment 16 Guillaume Ayoub 2010-03-28 22:57:59 UTC
(In reply to comment #15)
> The new release media-libs/mesa-7.8_rc2 does not work for me either. I get the
> same assertion.
> 
> I'm confused about how I can still get the same assertion, after a patch that
> completely removes the assert() line. I suspect the patch wasn't applied to
> _rc2 either.

As said in comment #11, the patch attached here is not applied to rc2 (but it can be manually applied to rc2). The rc2 ebuild in the portage tree does not have this patch.

After rc2, this patch has been applied in the 7.8 branch upstream, so the next release (rc3 or final) will be fixed.
Comment 17 Vasily 2010-03-29 09:31:02 UTC
(In reply to comment #5)
> Please mask it locally, we want users to try it out. We'll try to backport
> patches very soon for intel users.
> 
> @x11 (especially Tomas), no more clean ups of mesa versions until further
> notice.
> 
> Thanks

Sorry, but I don't understand what testing you want to perform - it just crashes for intel users, isn't it a reason to mask this package? I really, really don't understand x11-team policy - it's almost 2 weeks since broken mesa is in portage, and nothing was done :\
Comment 18 Guillaume Ayoub 2010-03-29 17:17:34 UTC
(In reply to comment #17)
> Sorry, but I don't understand what testing you want to perform - it just
> crashes for intel users, isn't it a reason to mask this package? I really,
> really don't understand x11-team policy - it's almost 2 weeks since broken mesa
> is in portage, and nothing was done :\

Mesa 7.8 final has been released and added in portage, this bug is now fixed. Can someone from the x11 team change the bug status?
Comment 19 Rémi Cardona gentoo-dev 2010-03-29 17:30:13 UTC
(In reply to comment #17)
> Sorry, but I don't understand what testing you want to perform - it just
> crashes for intel users, isn't it a reason to mask this package? I really,
> really don't understand x11-team policy - it's almost 2 weeks since broken mesa
> is in portage, and nothing was done :\

Mesa was not broken for _all_ Intel chips, and we wanted to get some testing for _other_ chips which Mesa supports. You're using ~arch, _some_ breakage is to be expected. We should have patched mesa, but we've all been busy with Real Life (tm), I hope you can understand this.

(In reply to comment #18)
> Mesa 7.8 final has been released and added in portage, this bug is now fixed.
> Can someone from the x11 team change the bug status?

Indeed, closing fixed.

Thanks