Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310063 - media-video/kdenlive-0.7.7.1 unable to remove clip
Summary: media-video/kdenlive-0.7.7.1 unable to remove clip
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-18 12:10 UTC by Ivan Volosyuk
Modified: 2010-12-30 19:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Volosyuk 2010-03-18 12:10:13 UTC
Adding clip to project works fine.
Adding clip to timeline works a bit strange - snap to track doesn't happen (worked on 0.7.6)
When trying to remove the track I get message:
"Error removing clip at 00:00:00:00 on track 0"
and clip remains.

Reproducible: Always

Steps to Reproduce:
1. open kdenlive (0.7.7.1)
2. Right click clips area - add a clip
3. trag the clip to the timeline
4. right click -> "Delete selected item" or Press <Del>

Actual Results:  
I get following message at status bar: "Error removing clip at 00:00:00:00 on track 0"

Expected Results:  
Clip disappear from timeline.

Related packages versions and use flags:
media-libs/x264-0.0.20100118  USE="threads -debug -pic" 0 kB
media-video/ffmpeg-0.5_p21602  USE="X alsa doc encode faac faad gsm hardcoded-tables jpeg2k mmx mmxext mp3 opencore-amr sdl ssse3 theora threads v4l v4l2 vdpau vorbis x264 xvid zlib -3dnow -3dnowext (-altivec) -bindist -cpudetection -custom-cflags -debug -dirac -ieee1394 -jack -network -oss -pic -schroedinger -speex -test" VIDEO_CARDS="nvidia" 0 kB
media-libs/mlt-0.5.0  USE="dv ffmpeg frei0r gtk kde melt mmx python qt4 quicktime sdl sse sse2 vorbis xine xml -compressed-lumas -debug -jack -libsamplerate -lua -ruby" 0 kB
media-video/kdenlive-0.7.7.1  USE="(-aqua) -debug (-kdeenablefinal) -semantic-desktop" LINGUAS="ru -ca -cs -da -de -el -es -fi -fr -gl -he -hr -hu -it -nl -pl -pt -pt_BR -sl -tr -uk -zh" 0 kB
Comment 1 Ivan Volosyuk 2010-03-18 15:08:14 UTC
Updating to kdelibs-4.4.1-r1 fixed the problem. It seems kdenlive require atleast kdelibs 4.4
What about changing dependencies?
Comment 2 Joe Roberts 2010-03-25 09:00:12 UTC
This worked for me without touching kdelibs:

(*) Unmasked x11-libs/qt-4.6.2 and merged it.  This also pulled in x11-libs/qt-assistant-4.6.2 and x11-libs/qt-multimedia-4.6.2.

(*) Re-installed media-video/kdenlive-0.7.7.1

(*) Left kdelibs at kde-base/kdelibs-4.3.5

Tracks snap to the track (didn't before) and can be removed.

This fix from: http://www.kdenlive.org/mantis/view.php?id=1479
Comment 3 Andreas K. Hüttel gentoo-dev 2010-03-28 18:08:28 UTC
> (*) Unmasked x11-libs/qt-4.6.2 and merged it.  This also pulled in
> x11-libs/qt-assistant-4.6.2 and x11-libs/qt-multimedia-4.6.2.

Do you still remember which useflags you changed since the previous qt installation?

This smells like a bad useflag dependency.


Comment 4 Jay 2010-06-23 20:23:10 UTC
>(*) Unmasked x11-libs/qt-4.6.2 and merged it.  This also pulled in
x11-libs/qt-assistant-4.6.2 and x11-libs/qt-multimedia-4.6.2.
>
>(*) Re-installed media-video/kdenlive-0.7.7.1
>
>(*) Left kdelibs at kde-base/kdelibs-4.3.5

i did this with ver 0.7.6.
Still doesn't work

i agree this may be a bad useflag
Comment 5 Jay 2010-07-07 09:32:09 UTC
After a regular install, if you uninstall kdenlive

then reinstall from source. It seems to work fine

steps:

emerge kdenlive
emerge -C  kdenlive
svn co https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive
mkdir build; cd build; cmake .. -DCMAKE_INSTALL_PREFIX=/usr; make
sudo make install 

this isnt a clean solution as deps are still loose. But it maybe this can help someone else debug
Comment 6 Andreas K. Hüttel gentoo-dev 2010-11-12 22:58:15 UTC
Does this still happen with 0.7.8, and current kde/qt combinations?
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-30 19:17:56 UTC
can't reproduce with 0.7.8, i was able to remove the track from timeline. reopen if it is still valid for you. thanks