Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 309051 - www-misc/shibboleth-2.3.ebuild (New Package)
Summary: www-misc/shibboleth-2.3.ebuild (New Package)
Status: RESOLVED LATER
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement with 1 vote (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://shibboleth.internet2.edu/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-11 20:00 UTC by daavelino
Modified: 2010-12-10 09:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
shibboleth-2.3.ebuild (New ebuild) (shibboleth-2.3.ebuild,1.71 KB, text/plain)
2010-03-11 20:04 UTC, daavelino
Details
shibboleth-2.3.ebuild (files/shibd.init file) (shibd.init,445 bytes, text/plain)
2010-03-11 20:06 UTC, daavelino
Details
shibboleth-2.3.ebuild (files/shibd.conf) (shibd.conf,113 bytes, text/plain)
2010-03-11 20:07 UTC, daavelino
Details
dev-libs/log4shib-1.0.4.ebuild (shibboleth-2.3 dependency) (log4shib-1.0.4.ebuild,797 bytes, text/plain)
2010-03-11 20:09 UTC, daavelino
Details
dev-libs/opensaml-2.3.ebuild (shibboleth-2.3.ebuild dependency) (opensaml-2.3.ebuild,1.24 KB, text/plain)
2010-03-11 20:13 UTC, daavelino
Details
xmltooling-1.3.3.ebuild (shibboleth-2.3 dependency) (xmltooling-1.3.3.ebuild,1.09 KB, text/plain)
2010-03-11 20:17 UTC, daavelino
Details
xmltooling-1.3.3.ebuild (correction) (xmltooling-1.3.3.ebuild,1.09 KB, text/plain)
2010-03-11 21:06 UTC, daavelino
Details
shibboleth-2.3.ebuild (correction) (shibboleth-2.3.ebuild,1.75 KB, text/plain)
2010-03-12 12:44 UTC, daavelino
Details
A little correction for files/shibd.init file (shibd.init,449 bytes, text/plain)
2010-05-11 12:09 UTC, daavelino
Details
Two little corrections as suggested by Gregory Hakon. (shibboleth-2.3.ebuild,1.75 KB, text/plain)
2010-09-02 14:07 UTC, daavelino
Details
Correction. (shibd.conf,148 bytes, text/plain)
2010-09-02 19:34 UTC, daavelino
Details
Correction. (shibd.init,570 bytes, text/plain)
2010-09-02 19:35 UTC, daavelino
Details
Correction. (shibboleth-2.3.ebuild,1.80 KB, text/plain)
2010-09-02 19:37 UTC, daavelino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daavelino 2010-03-11 20:00:03 UTC
Hi all!!

This is my proposal to include shibboleth-2.3 service provider 

(https://spaces.internet2.edu/display/SHIB2/Home) 

into Gentoo package structure.

Shibboleth allows users to securely send trusted information about themselves to remote resources. This information may then be used for authentication, authorization, content personalization, and enabling single sign-on across a broad range of services from many different providers.

I am also submitting the dependencies of this package for the sake of consistency. For that, I created three others ebuilds,

dev-libs/log4shib-1.0.4
dev-libs/opensaml-2.3
dev-libs/xmltooling-1.3.3

and I will submit them all.

Thanks in advance.
Comment 1 daavelino 2010-03-11 20:04:56 UTC
Created attachment 223199 [details]
shibboleth-2.3.ebuild (New ebuild)
Comment 2 daavelino 2010-03-11 20:06:14 UTC
Created attachment 223201 [details]
shibboleth-2.3.ebuild (files/shibd.init file)

This is the init.d/shibd script.
Comment 3 daavelino 2010-03-11 20:07:07 UTC
Created attachment 223203 [details]
shibboleth-2.3.ebuild (files/shibd.conf)

This is the conf.d/shibd file.
Comment 4 daavelino 2010-03-11 20:09:05 UTC
Created attachment 223205 [details]
dev-libs/log4shib-1.0.4.ebuild (shibboleth-2.3 dependency)

log4shib is a forked version of log4cpp that has been created for the Shibboleth project to ensure a conistent, working snapshot that builds reliably on the necessary platforms and it constitutes a dependency to install shibboleth service provider on Linux. 

It is a dependency of Shibboleth Service Provider (see www-misc/shibboleth-2.3.ebuild)
Comment 5 daavelino 2010-03-11 20:13:45 UTC
Created attachment 223207 [details]
dev-libs/opensaml-2.3.ebuild (shibboleth-2.3.ebuild dependency)

The OpenSAML 2 shared library can be built from source using any reasonably standard C++ compiler or installed from binary packages on supported platforms.

It depends on 

dev-libs/log4shib-1.0.4 or dev-libs/log4cpp-0.3.x
dev-libs/xerces-c-3.0.1
dev-libs/xmlsec=1.2.14
sys-libs/zlib-1.2.3
net-misc/curl-7.19.6
Comment 6 daavelino 2010-03-11 20:17:26 UTC
Created attachment 223209 [details]
xmltooling-1.3.3.ebuild (shibboleth-2.3 dependency)

Dependencies:

>=dev-libs/log4shib-1.0.4
>=dev-libs/log4cpp-0.3.4
>=dev-libs/xerces-c-3.0.1
>=dev-libs/xmlsec=1.2.14
Comment 7 daavelino 2010-03-11 20:43:09 UTC
shibboleth-2.3 installation process follows the order below:

emerge log4shib
USE="icu" emerge xerces-c
USE="-xalan" emerge xml-security-c
USE="log4shib xerces xmlsec" emerge xmltooling
USE="log4shib xerces xmlsec zlib" emerge opensaml
emerge shibboleth

My emerge --info follows:

Portage 2.1.6.13 (hardened/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31.4 i686)
=================================================================
System uname: Linux-2.6.31.4-i686-Intel-R-_Core-TM-2_Duo_CPU_E7400_@_2.80GHz-with-gentoo-1.12.13
Timestamp of tree: Wed, 10 Mar 2010 17:45:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.6.4
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org ftp://ftp.ecc.u-tokyo.ac.jp http://mirror.csclub.uwaterloo.ca/gentoo-distfiles"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTDIR_OVERLAY="/usr/local/portage-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa apache2 bash-completion berkdb bzip2 cli consolekit cpus cracklib crypt ctype cups curl curlwrappers cxx dbus dri expat ffmpeg gd gdbm gif gnome gpm hal hardened iconv java6 javascript jpeg ldap matroska modules mp3 mpeg mplayer mudflap mysql ncursees ncurses nls nptl nptlonly ogg opengl openmp pam pcre perl php pic png pppd python qt4 readline reflection session spl sse sse3 ssl sysfs syslog tcpd unicode urandom usb vorbis win32codecs x86 xorg xsl zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vga vesa intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-03-11 20:55:08 UTC
Please do not CC architecture teams on your own. Thanks.
Comment 9 daavelino 2010-03-11 21:06:11 UTC
Created attachment 223215 [details]
xmltooling-1.3.3.ebuild (correction)

Attached the wrong file, sorry. This is the right.
Comment 10 daavelino 2010-03-12 12:44:23 UTC
Created attachment 223269 [details]
shibboleth-2.3.ebuild (correction)

shibboleth-2.3 can't deal with xerces-c greater than 3.0 so this ebuild takes it into account.
Comment 11 Justin Lecher gentoo-dev 2010-03-21 19:14:23 UTC
Please file one bug per package.
Comment 12 daavelino 2010-05-11 12:09:17 UTC
Created attachment 231075 [details]
A little correction for files/shibd.init file

A little correction for files/shibd.init that enable it to pass parameters correctly.
Comment 13 daavelino 2010-09-02 14:07:13 UTC
Created attachment 245738 [details]
Two little corrections as suggested by Gregory Hakon.

It get correctly apache2.2 apxs and remove correctly shibboleth directories under --unmerge condictions.
Comment 14 daavelino 2010-09-02 19:34:17 UTC
Created attachment 245780 [details]
Correction.

Updates shibd.conf
Comment 15 daavelino 2010-09-02 19:35:40 UTC
Created attachment 245782 [details]
Correction.
Comment 16 daavelino 2010-09-02 19:37:21 UTC
Created attachment 245783 [details]
Correction.

Finds the correct apache apxs file (for apache-2.2) and creates the correct directory structure now.
Comment 17 daavelino 2010-09-08 13:04:26 UTC
This briefly describes the procedure to install shibboleth-2.3 using the ebuilds put here.

ACCEPT_KEYWORDS="~x86" emerge log4shib
ACCEPT_KEYWORDS="~x86" USE="icu" emerge =xerces-c-3.0.1
ACCEPT_KEYWORDS="~x86" USE="-xalan" emerge xml-security-c
ACCEPT_KEYWORDS="~x86" USE="log4shib xerces xmlsec" emerge xmltooling
ACCEPT_KEYWORDS="~x86" USE="log4shib xerces xmlsec zlib" emerge opensaml
ACCEPT_KEYWORDS="~x86" USE="icu" emerge shibboleth

I put it here because shibboleth-2.3 (until now) can't deal with xerces-c greater than 3.0.1 and, if you don't force it to be in this version, the shibboleth will notice it and reinstall it in this version but all previous dependences will be broken.
Comment 18 Gregory 2010-12-10 09:49:52 UTC
(In reply to comment #6)
> Created an attachment (id=223209) [details]
> xmltooling-1.3.3.ebuild (shibboleth-2.3 dependency)
> 
> Dependencies:
> 
> >=dev-libs/log4shib-1.0.4
> >=dev-libs/log4cpp-0.3.4
> >=dev-libs/xerces-c-3.0.1
> >=dev-libs/xmlsec=1.2.14

It seems to met that dependencies are >=dev-libs/xmlsec-1.2.14 and not >=dev-libs/xmlsec=1.2.14

Problem with the =1.2.14

Error(s) in metadata for 'dev-libs/opensaml-2.3':
  DEPEND: log4shib? ( >=dev-libs/log4shib-1.0.4 ) log4cpp? ( >=dev-libs/log4cpp-0.3.4 ) xerces? ( >=dev-libs/xerces-c-3.0.1 ) xmlsec? ( >=dev-libs/xmlsec=1.2.14 ) zlib? ( >=sys-libs/zlib-1.2.3 )
    Invalid atom (>=dev-libs/xmlsec=1.2.14), token 15
  RDEPEND: log4shib? ( >=dev-libs/log4shib-1.0.4 ) log4cpp? ( >=dev-libs/log4cpp-0.3.4 ) xerces? ( >=dev-libs/xerces-c-3.0.1 ) xmlsec? ( >=dev-libs/xmlsec=1.2.14 ) zlib? ( >=sys-libs/zlib-1.2.3 )
    Invalid atom (>=dev-libs/xmlsec=1.2.14), token 15