Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 308993 - evolution-data-server-2.28.3.1 will not unpack
Summary: evolution-data-server-2.28.3.1 will not unpack
Status: RESOLVED DUPLICATE of bug 309001
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-11 15:25 UTC by Mark
Modified: 2010-03-12 14:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2010-03-11 15:25:39 UTC
Trying to emerge evolution-data-server-2.28.3.1 keep getting this error unpacking source.  I deleted the entry from portage distfiles several times, but keeps failing.  No other packages emerge with this failure.

Reproducible: Always

Steps to Reproduce:
1. Emerge evolution-data-server-2.28.3.1
2. 
3.

Actual Results:  
Get the error

Expected Results:  
Successful emerege

*** emerge --verbose --oneshot gnome-extra/evolution-data-server ***
024270 >>> Verifying ebuild manifests
024272 >>> Emerging (1 of 1) gnome-extra/evolution-data-server-2.28.3.1
024273 >>> Downloading 'http://distfiles.gentoo.org/distfiles/evolution-data-server-2.28.3.1.tar.bz2'
024290  * evolution-data-server-2.28.3.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...[ ok ]
024291  * checking ebuild checksums ;-) ...                                     [ ok ]
024292  * checking auxfile checksums ;-) ...                                    [ ok ]
024293  * checking miscfile checksums ;-) ...                                   [ ok ]
024294  * CPV:  gnome-extra/evolution-data-server-2.28.3.1
024295  * REPO: gentoo
024296  * USE:  elibc_glibc kernel_linux ssl userland_GNU x86
024297 >>> Unpacking source...
024298 >>> Unpacking evolution-data-server-2.28.3.1.tar.bz2 to /var/tmp/portage/gnome-extra/evolution-data-server-2.28.3.1/work
024299  * ERROR: gnome-extra/evolution-data-server-2.28.3.1 failed:
024300  *   failure unpacking evolution-data-server-2.28.3.1.tar.bz2
024301  * 
024302  * Call stack:
024303  *               ebuild.sh, line   54:  Called src_unpack
024304  *             environment, line 3643:  Called gnome2_src_unpack
024305  *             environment, line 2786:  Called unpack 'evolution-data-server-2.28.3.1.tar.bz2'
024306  *               ebuild.sh, line  391:  Called _unpack_tar 'bzip2'
024307  *               ebuild.sh, line  366:  Called assert 'failure unpacking evolution-data-server-2.28.3.1.tar.bz2'
024308  *   isolated-functions.sh, line   14:  Called die
024309  * The specific snippet of code:
024310  *   [[ $x -eq 0 ]] || die "$@"
024311  * 




emerge --info =gnome-extra/evolution-data-server-2.28.3.1
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.4.2, glibc-2.11-r1, 2.6.32-gentoo-r1 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.32-gentoo-r1-i686-Dual-Core_AMD_Opteron-tm-_Processor_1218-with-gentoo-2.0.1
Timestamp of tree: Thu, 11 Mar 2010 15:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p2
dev-java/java-config: 2.1.10
dev-lang/python:     2.5.4-r3, 2.6.4, 3.1.1-r1
dev-python/pycrypto: 2.1.0
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.1.1-r3, 4.2.2, 4.4.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache collision-protect distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LC_ALL="en_US.utf-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa audiofile avahi avi berkdb bluetooth branding bzip2 cairo cdparanoia cdr cdrom chroot cli cracklib crypt cups cxx dbus divx4linux dri dts dv dvd dvdr dvdread eds emboss encode evo fam ffmpeg firefox flac fortran freetype gdbm gif gimpprint gnome gpm gstreamer gtk gtk2 gtkhtml hal iconv java javascript jpeg lcms libnotify lm_sensors lzo mad mbox mikmod mime mmap mmx mmxext mng modules mp3 mp4 mpeg mpi mudflap mysql nas ncurses net network nis nls nptl nptlonly nsplugin nvidia ogg opengl openmp oss pcre pdf perl php png posix ppds pppd python qt3support qt4 quicktime readline reflection rtc samba sdl session sndfile snmp sockets socks5 spell spl ssl startup-notification svg swat sysfs szip tcltk tcpd theora thunar tidy tiff truetype type1-fonts unicode usb userlocales vidix vorbis win32codecs wxwindows x264 x86 xfs xgetdefault xml xmlrpc xorg xsl xulrunner xv xvid xvmc zlib" ALSA_CARDS="ice1712" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


emerge -pqv =gnome-extra/evolution-data-server-2.28.3.1
[ebuild     U ] gnome-extra/evolution-data-server-2.28.3.1 [2.28.2] USE="ssl -debug -doc -gnome-keyring -ipv6 -kerberos -krb4 -ldap"
Comment 1 Doktor Notor 2010-03-12 11:04:40 UTC
Duplicate of 309001. emerge --sync, the tar version in question is already masked.
Comment 2 Gilles Dartiguelongue gentoo-dev 2010-03-12 14:47:05 UTC

*** This bug has been marked as a duplicate of bug 309001 ***