Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 30857 - running enemy territory (et) makes X restart
Summary: running enemy territory (et) makes X restart
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2003-10-10 12:49 UTC by [name redacted]
Modified: 2003-10-13 05:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

xf86config file (XF86Config,14.62 KB, text/plain)
2003-10-10 22:12 UTC, [name redacted]

Note You need to log in before you can comment on or make changes to this bug.
Description [name redacted] 2003-10-10 12:49:01 UTC
$ et >& /home/scrooch/logfile


ET 2.56 linux-i386 Sep 10 2003
----- FS_Startup -----
Current search path:
/opt/enemy-territory/etmain/pak1.pk3 (10 files)
/opt/enemy-territory/etmain/pak0.pk3 (3725 files)
/opt/enemy-territory/etmain/mp_bin.pk3 (4 files)

3739 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
----- Client Initialization Complete -----
----- R_Init -----
...loading Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
Failed to detect XF86DGA Mouse
XFree86-VidModeExtension Activated at 800x600
Using 4/4/4 Color bits, 16 depth, 0 stencil display.
Initializing OpenGL extensions
...using GL_S3_s3tc
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...ignoring GL_NV_fog_distance
XF86 Gamma extension initialized

GL_VERSION: 1.4.0 NVIDIA 44.96
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters
GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add
GL_ARB_texture_env_combine GL_ARB_texture_env_dot3
GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix
GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_S3_s3tc
GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax
GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array
GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays
GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters
GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color
GL_EXT_shared_texture_palette GL_EXT_stencil_wrap
GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine
GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod
GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array
GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square
GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent
GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite
GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4
GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2
GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NVX_ycrcb
GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod 

PIXELFORMAT: color(16-bits) Z(16-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: single glDrawElements
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----

------- sound initialization -------
----- Sound Info -----
sound system is muted
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
22050 speed
0x4f92a000 dma buffer
No background file.
Sound memory manager started
Sys_LoadDll(/home/scrooch/.etwolf/etmain/ failed:
"/home/scrooch/.etwolf/etmain/ cannot open shared object file: No
such file or directory"
Sys_LoadDll(/opt/enemy-territory/etmain/ ok
Sys_LoadDll(ui) found **vmMain** at  0x51188bfc  
Sys_LoadDll(ui) succeeded!
Found high quality video and slow CPU
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: localhost
Alias: mymachine
Started tty console (use +set ttycon 0 to disable)
execing preset_fast.cfg
r_subdivisions will be changed upon restarting.
r_depthbits will be changed upon restarting.
r_detailtextures will be changed upon restarting.
RE_Shutdown( 1 )
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 135
  Minor opcode of failed request: 10
  Serial number of failed request: 284
Hunk_Clear: reset the hunk ok
----- Initializing Renderer ----
----- R_Init -----
...loading Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XFree86-VidModeExtension Activated at 800x600
Shutdown tty console
Received signal 1, exiting...

I'm running gentoo stable, pentium3 as march= and gtk2 gnome -qt -kde as use flags.

Reproducible: Always
Steps to Reproduce:
1. et

Actual Results:  
It loads some, switches from resolution, black screen with (X) mouse cursor,
black screen, nvidia logo pops up + gdm

Expected Results:  
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2003-10-10 14:38:22 UTC
Post your X config, please.
Comment 2 [name redacted] 2003-10-10 22:12:04 UTC
Created attachment 19083 [details]
xf86config file

I tried 16 / 24 colors, diffferent resolutions.
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2003-10-11 08:43:51 UTC
List your hardware and also post "emerge info" for me to look at.

Also, have you tried deleting your ~/.etwolf directory and re-running the
game?  Could you also try installing the game from the original binary using
the loki installer and see if you have the same problem?

Comment 4 [name redacted] 2003-10-11 10:33:25 UTC
Well, emm the machine which I used I don't have at hand anymore for a while.
The game did run a couple of months ago on first attempt, but the system
never had been updated since. I did a clean install last week, and then the
game didnt run anymore.

System specs are p3 cuppermine 733mhz, geforce1 with 64mb(256, asus6600),
640mbram, 80gb hd & via motherboard.

I did not try to delete my .etwolf dir. But I did try to run the game as
different users (among them root), with the same results.
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2003-10-12 11:29:08 UTC
I'm going to close this bug since you don't even have the machine anymore.
 If you get the machine back and still have a problem, reopen the bug.
Comment 6 [name redacted] 2003-10-13 05:48:23 UTC
OKay, fair.