Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 308523 - x11-base/xorg-server 1.7.5.901 freezes when using window decorations in fluxbox
Summary: x11-base/xorg-server 1.7.5.901 freezes when using window decorations in fluxbox
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 308533 (view as bug list)
Depends on: 296514
Blocks: 308521
  Show dependency tree
 
Reported: 2010-03-08 21:26 UTC by capn.fish.zaurus
Modified: 2010-03-15 21:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description capn.fish.zaurus 2010-03-08 21:26:46 UTC
After updating to x11-base/xorg-server 1.7.5.901, X freezes when I try to do anything involving the window decoration under Fluxbox (moving, resizing, closing, etc.).

Downgrading to 1.7.5 fixes the issue.

Closing windows works fine using keyboard shortcuts and/or menus.

I don't know if it's WM-dependent.

I didn't try alt-clicking to try move windows.

Things work fine so long as no moving/resizing/etc, goes on.

Reproducible: Always

Steps to Reproduce:
1. Upgrade to xorg-server 1.7.5.901 from 1.7.5
2. Start up Fluxbox
3. Try to do anything utilizing the window decoration (minimize, close, move, etc.)

Actual Results:  
X freezes completely

Expected Results:  
Window moves/minimizes/etc.

Portage 2.1.8.2 (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11-r1, 2.6.33-gentoo i686)
=================================================================
System uname: Linux-2.6.33-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 08 Mar 2010 19:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p2
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -msse4.1"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -msse4.1"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl acpi alsa avahi berkdb bidi bzip2 cairo cdda cddb cdio cli cracklib crypt cups curl cxx dbus dhclient divx dri dts dvd dvdcss dvdr encode flac gdbm gif gnutls gpm gps gtk hal hardened iconv id3tag imap imlib imlib2 jpeg lame laptop libnotify mad matroska mdnsresponder-compat mjpeg mmx modules mp3 mp4 mpeg mudflap ncurses nptl nptlonly ogg oggvorbis opengl openmp pam pcre pdf perl png ppds pppd python qt3support readline reflection sdl sdl-image sdl-mixer sdl-sound sdlaudio session skins spell spl sqlite sse sse2 ssl ssse3 stream svg sysfs tclck tcpd theora threads threadsafe tiff truetype unicode usb v4l v4l2 vcd video vlm vorbis wifi x264 x86 xinerama xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" QEMU_SOFTMMU_TARGETS="arm i386" QEMU_USER_TARGETS="arm i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-03-08 22:33:03 UTC
This is apparently a regression from the fix to bug 296514.

https://bugs.freedesktop.org/show_bug.cgi?id=25400#c18
http://lists.x.org/archives/xorg-devel/2010-March/006056.html
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-03-08 22:37:14 UTC
*** Bug 308533 has been marked as a duplicate of this bug. ***
Comment 3 Jim Ramsay (lack) (RETIRED) gentoo-dev 2010-03-10 14:46:10 UTC
xorg-server-1.7.5.901 is masked for now (See bug 296514)
Comment 4 Lars Lindley 2010-03-11 23:18:43 UTC
upstream commit: f2eacb4646beb25d055de22868f93e6b24f229b6 seems to revert the change causing this regression. 
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-03-15 13:56:28 UTC
can you try again with 1.7.5.902?
Comment 6 Rémi Cardona gentoo-dev 2010-03-15 21:24:43 UTC
Should be fixed with 1.7.5.902. Please don't hesitate to reopen this bug if you can still reproduce with that version or later ones.

Thanks