Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 308241 - app-office/openoffice-3.2.0 crashes with assertion in librdf
Summary: app-office/openoffice-3.2.0 crashes with assertion in librdf
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2010-03-07 14:53 UTC by Graham Murray
Modified: 2010-03-07 21:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Graham Murray 2010-03-07 14:53:44 UTC
Every time I type in openoffice writer, it crashes with the following message on the launching terminal. This is quite a recent problem, it used to work and I have not re-emerged openoffice since it was working.

graham@newton ~ $ rdf_storage.c:684: (librdf_free_storage) assertion failed: object pointer of type librdf_storage is NULL.
rdf_model.c:395: (librdf_free_model) assertion failed: object pointer of type librdf_model is NULL.

I have tried re-emerging dev-libs/redland, as this is the package which owns librdf, but still get the same failure. 

emerge --info =app-office/openoffice-3.2.0
Portage 2.2_rc65 (default/linux/x86/10.0/desktop, gcc-4.4.3, glibc-2.11-r1, 2.6.33-05411-g64096c1 i686)
                         System Settings
System uname: Linux-2.6.33-05411-g64096c1-i686-Intel-R-_Core-TM-2_CPU_6700_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 06 Mar 2010 17:45:02 +0000
app-shells/bash:     4.1_p2
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-python/pycrypto: 2.1.0
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.6.3-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20-r1
sys-devel/gcc:       4.3.4, 4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.32
CFLAGS="-O2 -march=native -mtune=native -pipe -ggdb"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -mtune=native -pipe -ggdb"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests buildsyspkg distlocks fixpackages installsources news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="en_GB en fr_FR fr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/perl-experimental /var/lib/layman/sunrise /var/lib/layman/x11 /var/lib/layman/sping /var/lib/layman/x11 /usr/local/portage"
USE="X a52 aac aalib acl acpi aim alsa apache2 audiofile avi bash-completion berkdb bluetooth bonobo branding browserplugin bzip2 bzlib cairo caps cdda cddb cdparanoia cdr cjk cli consolekit cracklib crypt cups curl cvs cxx dbus directfb doc dri dts dv dvd dvdr dvdread eds emacs emboss encode esd ethereal evo examples exif expat fam fbcon ffmpeg fftw flac fontconfig foomaticdb fortran ftp gcj gd gdbm geoip gif glut gmp gnome gnome-keyring gnutls gphoto2 gpm graphviz gstreamer gtk gtk2 gtkhtml guile hal htmlhandbook iconv icq icu idn imagemagick imlib ipv6 jabber jack java javascript jbig jce jpeg jpeg2k junit kde kdehiddenvisibility ladspa latex lcms ldap leim libgda libnotify libsamplerate libwww lm_sensors logrotate lua mad matroska mbox mikmod milter mime mmap mmx mng modplug modules mono mozilla mp3 mp4 mpeg mpi mplayer msn mudflap musepack mysql ncurses nls nptl nptlonly nsplugin odbc offensive ogg oggvorbis openal opengl openmp oscar oss pam pcntl pcre pdf perl plasma png policykit postgres ppds pppd profile pulseaudio python qt3support qt4 quicktime raw readline recode reflection ruby sasl sdl semantic-desktop session sharedmem sndfile snmp soap sockets sox speex spell spl sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification subversion svg sysfs sysvipc tcl tcltk tcpd theora threads thunar tiff tk truetype uicktime unicode usb v4l v4l2 vim-syntax vorbis wavpack win32codecs wmf wxwindows x264 x86 xattr xcb xcomposite xface xft xine xml xml2 xorg xulrunner xv xvid yahoo zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en fr_FR fr" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa fbdev vga v4l" 

                        Package Settings

app-office/openoffice-3.2.0 was built with the following:
USE="bash-completion cups dbus eds gnome gstreamer gtk java ldap mono nsplugin opengl pam (-aqua) -binfilter -debug -kde (-kdeenablefinal) -odk" LINGUAS="en en_GB fr -af -ar -as_IN -be_BY -bg -bn -br -brx -bs -ca -cs -cy -da -de -dgo -dz -el -en_US -en_ZA -eo -es -et -eu -fa -fi -ga -gl -gu -he -hi_IN -hr -hu -id -it -ja -ka -kk -km -kn_IN -ko -kok -ks -ku -lt -mai -mk -ml_IN -mn -mni -mr_IN -nb -ne -nl -nn -nr -ns -oc -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sa_IN -sat -sd (-sh) -sk -sl -sr -ss -st -sv -sw_TZ -ta -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -uz -ve -vi -xh -zh_CN -zh_TW -zu"                                                                                                                     
CFLAGS="-march=native -mtune=native -pipe -ggdb -DGL_GLEXT_PROTOTYPES"
CXXFLAGS="-march=native -mtune=native -pipe -ggdb -DGL_GLEXT_PROTOTYPES"
Comment 1 Graham Murray 2010-03-07 21:51:38 UTC
After re-emerging this evening and upgrading to the latest git kernel, libdrm, mesa and radeon driver it works normally again. So I assume it was just a temporary breakage caused by using live builds.