Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 308117 - dev-vcs/mercurial-1.4.1 hgwebdir.cgi fails to execute
Summary: dev-vcs/mercurial-1.4.1 hgwebdir.cgi fails to execute
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Krzysztof Pawlik (RETIRED)
URL: http://mercurial.selenic.com/bts/issu...
Whiteboard:
Keywords:
: 308119 308121 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-06 21:26 UTC by Göktürk Yüksek
Modified: 2010-04-18 00:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Runtime log file for hgwebdir. (hgwebdir.log,710 bytes, text/plain)
2010-03-06 21:28 UTC, Göktürk Yüksek
Details
Fix (mercurial-1.4.1-hgwebdir-script_name-fix.patch,749 bytes, patch)
2010-03-06 21:31 UTC, Göktürk Yüksek
Details | Diff
Ebuild patch (mercurial-1.4.1.ebuild.patch,380 bytes, patch)
2010-03-06 21:32 UTC, Göktürk Yüksek
Details | Diff
emerge --info (emerge_info.txt,3.65 KB, patch)
2010-03-06 21:34 UTC, Göktürk Yüksek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Göktürk Yüksek archtester gentoo-dev 2010-03-06 21:26:56 UTC
I was following the tutorial here[0] to publish my hg repositories located on my Gentoo Box. After I set up hgweb.config, I executed hgwebdir.cgi it failed to execute. Please see hgwebdir.log file attached to this bug.

After I searched on the web for a while, I realized that this is a known bug with mercurial. Pleasee see the link here[1]

So I patched the package and the ebuild file. Please see patches for the package and the ebuild attached to this. Tested with 'ebuild test' and worked fine for me.

[0] http://mercurial.selenic.com/wiki/PublishingRepositories#multiple
[1] http://mercurial.selenic.com/bts/issue1778

Reproducible: Always

Steps to Reproduce:
Comment 1 Göktürk Yüksek archtester gentoo-dev 2010-03-06 21:28:59 UTC
Created attachment 222357 [details]
Runtime log file for hgwebdir.
Comment 2 Göktürk Yüksek archtester gentoo-dev 2010-03-06 21:31:59 UTC
Created attachment 222361 [details, diff]
Fix
Comment 3 Göktürk Yüksek archtester gentoo-dev 2010-03-06 21:32:49 UTC
Created attachment 222363 [details, diff]
Ebuild patch
Comment 4 Göktürk Yüksek archtester gentoo-dev 2010-03-06 21:34:13 UTC
Created attachment 222365 [details, diff]
emerge --info
Comment 5 Rafał Mużyło 2010-03-06 22:36:20 UTC
*** Bug 308119 has been marked as a duplicate of this bug. ***
Comment 6 Rafał Mużyło 2010-03-06 22:36:33 UTC
*** Bug 308121 has been marked as a duplicate of this bug. ***
Comment 7 Krzysztof Pawlik (RETIRED) gentoo-dev 2010-04-11 11:36:01 UTC
Dirkjan: is this a bug that should be taken upstream? 1.5.1 has the same code.
Comment 8 Dirkjan Ochtman gentoo-dev 2010-04-11 11:46:20 UTC
Krzysztof: there's already an upstream bug, issue1778. And I still stand by my comments there, namely that this is a bug in the environment the CGI is being executed in.

M. Gokturk Yuksek: how exactly are you setting this up? Is the web server apache? Can you paste any apache config data you have?
Comment 9 Göktürk Yüksek archtester gentoo-dev 2010-04-17 18:55:46 UTC
(In reply to comment #8)
> Krzysztof: there's already an upstream bug, issue1778. And I still stand by my
> comments there, namely that this is a bug in the environment the CGI is being
> executed in.
> 
> M. Gokturk Yuksek: how exactly are you setting this up? Is the web server
> apache? Can you paste any apache config data you have?
> 

It's been a long time since i set this up, but as far as a i remember i followed the instructions in this link[0].

My installation is system-wide so i used the generic hgwebdir script. 

I'm using virtual hosts in apache. Here is a portion of the config file:
DocumentRoot "/var/www/<my_domain>/cgi-bin/hgwebdir"
Options ExecCGI
<Files hgwebdir.cgi>
	SetHandler cgi-script
</Files>
ScriptAlias /cgi-bin/ "/var/www/<my_domain>/cgi-bin/"
DirectoryIndex hgwebdir.cgi
AddHandler cgi-script cgi pl

[0] http://mercurial.selenic.com/wiki/PublishingRepositories#multiple
Comment 10 Krzysztof Pawlik (RETIRED) gentoo-dev 2010-04-18 00:20:25 UTC
This doesn't look like something that should be in this Bugzilla, please add relevant information to upstream bug.