Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 307805 - media-gfx/inkscape-0.47 can't find XML-Parser
Summary: media-gfx/inkscape-0.47 can't find XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-04 19:45 UTC by Marcin Kryczek
Modified: 2013-12-19 15:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Kryczek 2010-03-04 19:45:12 UTC
installation fails at configure stage with error:
checking for perl... /usr/bin/perl                                                                                                                   
checking for perl >= 5.8.1... 5.10.1                                                                                                                 
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool               

i've got XML-Parser installed:
emerge -pv XML-Parser
[...]
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-perl/XML-Parser-2.36-r1  0 kB


my emerge --info:
Portage 2.2_rc64 (default/linux/x86/10.0/desktop, gcc-4.3.3, glibc-2.11-r1, 2.6.31.5 i686)
=================================================================                         
System uname: Linux-2.6.31.5-i686-Mobile_AMD_Sempron-tm-_Processor_3200+-with-gentoo-2.0.1
Timestamp of tree: Wed, 03 Mar 2010 18:00:21 +0000                                        
distcc 3.1 i686-pc-linux-gnu [disabled]                                                   
app-shells/bash:     4.1_p2                                                               
dev-java/java-config: 2.1.10                                                              
dev-lang/python:     2.5.4-r2, 2.6.4-r1, 3.1.1-r1                                         
dev-util/cmake:      2.8.0-r2                                                             
sys-apps/baselayout: 2.0.1                                                                
sys-apps/openrc:     0.6.0-r1                                                             
sys-apps/sandbox:    2.2                                                                  
sys-devel/autoconf:  2.13, 2.65                                                           
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1                                             
sys-devel/binutils:  2.20-r1                                                              
sys-devel/gcc:       4.3.3-r2, 4.4.3                                                      
sys-devel/gcc-config: 1.4.1                                                               
sys-devel/libtool:   2.2.6b                                                               
virtual/os-headers:  2.6.32                                                               
ACCEPT_KEYWORDS="x86 ~x86"                                                                
ACCEPT_LICENSE="*"                                                                        
CBUILD="i686-pc-linux-gnu"                                                                
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"                                  
CHOST="i686-pc-linux-gnu"                                                                 
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"                                
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"                                                                                                                         
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"                                                                                           
DISTDIR="/home/portage/distfiles"                                                                                                                    
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms spinner strict unmerge-logs unmerge-orphans userfetch"                                                                                                                                     
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                                                                         
LANG="en_US"                                                                                                                                         
LDFLAGS="-Wl,-O1"                                                                                                                                    
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portage/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac accessibility acpi aiglx alsa amr apache2 bash-completion bluetooth branding bzip2 cairo canvas cdr cli consolekit cracklib crypt cups curl cxx dbus divx divx4linux dlloader dri dts dvd dvdr dvdread eds emboss encode evo exscalibar extraicons extramodules fam fbcon ffmpeg firefox fla flac gd gif gimp glitz glut gmedia gpgme gpm gstreamer gtk gtk2 hal hpijs iconv imlib2 javascript jikes jpeg jpeg2k kde kde4 kdexdeltas laptop lcms ldap libnotify live loop-aes mad madwifi mailwrapper memlimit mikmod mmx mmxext mng modules moznocompose moznoirc moznomail mp3 mp4 mpeg mudflap musepack musicbrainz mysql ncurses nls nocardbus nptl nptlonly nsplugin nvidia ogg opencore-amr opengl openmp pam pcre pda pdf perl pmu png ppds pppd python qt3support qt4 quicktime rdesktop readline realmedia reflection samba sasl sdl semantic-desktop serial session spl sql sqlite sqlite3 sse sse2 ssl startup-notification svg sysfs tcpd theora thunar tiff truetype unicode usb userlocales vcd videos vidix vim vim-with-x vorbis win32codecs wmf wmp x264 x86 xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="kodak" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rafał Mużyło 2010-03-04 22:03:50 UTC
Did you upgrade perl recently and failed to use perl-cleaner ?
Comment 2 Marcin Kryczek 2010-03-05 08:38:33 UTC
yes - you are absolutely right. sorry for bothering you
Comment 3 Jeroen Roovers gentoo-dev 2013-12-19 15:30:02 UTC

*** This bug has been marked as a duplicate of bug 41124 ***