Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 307409 - sys-apps/portage-2.2* deploop deptree dump hides some useflags
Summary: sys-apps/portage-2.2* deploop deptree dump hides some useflags
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 307597
  Show dependency tree
 
Reported: 2010-03-02 02:08 UTC by Nathan Phillip Brink (binki) (RETIRED)
Modified: 2010-03-08 10:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/tmp/emerge-deploop-nouseflags.txt (emerge-deploop-nouseflags.txt,12.03 KB, text/plain)
2010-03-02 02:12 UTC, Nathan Phillip Brink (binki) (RETIRED)
Details
/tmp/emerge--info.txt (emerge--info.txt,8.25 KB, text/plain)
2010-03-02 02:14 UTC, Nathan Phillip Brink (binki) (RETIRED)
Details
force verbose USE display (force_verbose.patch,540 bytes, patch)
2010-03-08 08:56 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-03-02 02:08:41 UTC
I'll attach a log that shows the full output out of which I am grabbing excerpts for below:

I passed -vp1 to emerge:

[nomerge      ] net-print/cups-1.3.11-r1 [1.3.10-r2] USE="lib32%* -X* -dbus* -java* -php* -xinetd*"
[ebuild  N    ]  app-text/poppler-0.12.3-r3  USE="abiword cairo cjk jpeg jpeg2k lcms lib32 png utils xpdf-headers -debug -doc -exceptions -qt4"
[ebuild   R   ]   x11-libs/gtk+-2.16.6  USE="lib32%* -doc*"
[ebuild     U ]    net-print/cups-1.3.11-r1 [1.3.10-r2] USE="lib32%* -X* -dbus* -java* -php* -xinetd*"

See that the package which is being newly merged has all of its useflags shown. In the case of deploop solving, however, one would be benefited by seeing all of the useflags that are enabled even on packages that are being reinstalled. This is because deploop solving involves temporarily disabling useflags, etc.

In the above example, gtk+ has a cups useflag which is enabled and could be temporarily disabled by the user to break the deploop. Yet to find that information, I consulted eix ;-)
Comment 1 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-03-02 02:12:12 UTC
Created attachment 221725 [details]
/tmp/emerge-deploop-nouseflags.txt
Comment 2 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-03-02 02:13:16 UTC
oh, sorry, I forgot to mention that I'm using tommy[d]'s portage-multilib branch, version 2.2_rc63-r1.
Comment 3 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-03-02 02:14:10 UTC
Created attachment 221727 [details]
/tmp/emerge--info.txt
Comment 4 Samuli Suominen gentoo-dev 2010-03-02 02:24:06 UTC

*** This bug has been marked as a duplicate of bug 175808 ***
Comment 5 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2010-03-02 05:15:47 UTC
bug 175808 doesn't seem to address the issue this bug is filed against. I thought I made it clear that I'm requesting that portage be more verbose to better enable users to break out of deploops. I'd imagine that a fix to this bug would be trivial compared to the other bug.

Or maybe I'm missing some flag/argument I may pass to portage that makes it more verbose somehow?
Comment 6 Zac Medico gentoo-dev 2010-03-08 08:56:53 UTC
Created attachment 222639 [details, diff]
force verbose USE display

Save as /tmp/force_verbose.patch and apply as follows:

  patch /usr/lib/portage/pym/_emerge/depgraph.py /tmp/force_verbose.patch
Comment 7 Zac Medico gentoo-dev 2010-03-08 10:34:22 UTC
This is fixed in 2.1.8.2 and 2.2_rc66.