Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 306807 - [Tracker] packages should depend on || (media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick])
Summary: [Tracker] packages should depend on || (media-gfx/imagemagick media-gfx/graph...
Status: RESOLVED DUPLICATE of bug 314431
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords: Tracker
Depends on:
Blocks:
 
Reported: 2010-02-25 12:10 UTC by Wojciech Porczyk
Modified: 2010-04-10 09:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Affected package list (graphicsmagickdep.txt,2.93 KB, text/plain)
2010-02-25 12:17 UTC, Wojciech Porczyk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Porczyk 2010-02-25 12:10:14 UTC
There are packages in portage that can/should depend (or rdepend) on either imagemagick or graphicsmagick, not only on imagemagick.

  Packages that depend on imagemagick only:
  (not sure if all of them can actually depend on graphicsmagic)

app-admin/recursos
app-editors/kile
app-emacs/thumbs
app-emulation/playonlinux
app-misc/bins
app-misc/booh
app-misc/matew
app-misc/tracker
app-mobilephone/obex-data-server
app-office/eqe
app-office/karbon
app-office/kchart
app-office/koffice-data
app-office/koffice-libs
app-office/kplato
app-office/kpresenter
app-office/krita
app-office/kspread
app-office/kword
app-office/lyx
app-office/multitalk
app-office/texmacs
app-text/calibre
app-text/cuneiform
app-text/pdf2html
app-text/pdf2oo
dev-embedded/ponyprog
dev-lang/gdl
dev-php5/magickwand
dev-php5/pecl-imagick
dev-db/postgis
dev-python/pythonmagick
dev-ruby/gruff
dev-ruby/mini_magick
dev-ruby/rmagick
dev-tex/html2latex
dev-tex/latex2rtf
dev-tex/tex4ht
games-board/cgoban
games-strategy/wesnoth
gnome-extra/libgsf
kde-base/kopete
kde-misc/kim4
mail-filter/spamassassin-fuzzyocr
Comment 1 Wojciech Porczyk 2010-02-25 12:17:48 UTC
Created attachment 221119 [details]
Affected package list

The description is cut in the middle. The correct package list is attached.
Comment 2 Samuli Suominen gentoo-dev 2010-02-25 18:16:36 UTC
One bug per one package so they can be assigned to correct maintainers.
Comment 3 Hans de Graaff gentoo-dev 2010-02-28 08:19:11 UTC
Please remove dev-ruby/rmagick from that list, it no longer supports graphicsmagick.
Comment 4 Ulrich Müller gentoo-dev 2010-04-10 08:50:13 UTC
Reopening to use this bug as a tracker. There are many packages affected, so probably a virtual/imagemagick would be appropriate.
Comment 5 Andreas K. Hüttel gentoo-dev 2010-04-10 09:04:10 UTC
One tracker is enough. :)

*** This bug has been marked as a duplicate of bug 314431 ***
Comment 6 Ulrich Müller gentoo-dev 2010-04-10 09:08:07 UTC
(In reply to comment #5)
> One tracker is enough. :)

Right, I had missed this. There are too many bugs. ;-)
Sorry for the bug spam.