Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 306581 - x11-misc/gsimplecal-2.0 - a GTK+ calendar designed for tint2
Summary: x11-misc/gsimplecal-2.0 - a GTK+ calendar designed for tint2
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL: https://github.com/dmedvinsky/gsimplecal
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2010-02-23 22:32 UTC by Nathan Zachary (RETIRED)
Modified: 2018-01-21 10:02 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for gsimplecal-15 (gsimplecal-15.ebuild,558 bytes, text/plain)
2010-02-23 22:32 UTC, Nathan Zachary (RETIRED)
Details
gsimplecal-25.ebuild (gsimplecal-25.ebuild,539 bytes, text/plain)
2010-03-22 10:37 UTC, nm (RETIRED)
Details
gsimplecal-25.ebuild (gsimplecal-25.ebuild,739 bytes, text/plain)
2010-03-22 10:59 UTC, nm (RETIRED)
Details
gsimplecal-25.ebuild (gsimplecal-25.ebuild,757 bytes, text/plain)
2010-03-22 11:19 UTC, nm (RETIRED)
Details
gsimplecal-33 ebuild (gsimplecal-33.ebuild,624 bytes, text/plain)
2010-04-26 16:51 UTC, Alexander Kozyrev
Details
gsimplecal-33 ebuild (gsimplecal-33.ebuild,655 bytes, text/plain)
2010-04-27 09:51 UTC, Alexander Kozyrev
Details
gsimplecal-33.ebuild (gsimplecal-33.ebuild,580 bytes, text/plain)
2010-04-27 17:12 UTC, nm (RETIRED)
Details
New ebuild (gsimplecal-0.5.ebuild,600 bytes, text/plain)
2010-08-24 19:52 UTC, Ovchinnikov Mikhail
Details
gsimplecal-0.8.ebuild (gsimplecal-0.8.ebuild,609 bytes, text/plain)
2011-05-25 01:03 UTC, Ștefan Talpalaru
Details
gsimplecal-1.6.ebuild (gsimplecal-1.6.ebuild,596 bytes, text/plain)
2013-08-27 15:52 UTC, Denis Klens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Zachary (RETIRED) gentoo-dev 2010-02-23 22:32:10 UTC
This is a new ebuild that I wrote (thanks to ABCD and others in #gentoo-dev-help) for gsimplecal.  The homepage states that it is a "very simple GUI calendar application, written in C using GTK2."  It was originally made to work with the new features of tint2 and openbox, but can be used as a standalone application as well.

Reproducible: Always




I tested it locally, and didn't seem to get any further sandbox errors after switching to dobin instead of emake.
Comment 1 Nathan Zachary (RETIRED) gentoo-dev 2010-02-23 22:32:32 UTC
Created attachment 220893 [details]
ebuild for gsimplecal-15
Comment 2 Justin Lecher (RETIRED) gentoo-dev 2010-02-24 07:41:15 UTC
Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Thanks,
On behalf of the Gentoo Sunrise Team,
Justin.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq

Comment 3 nm (RETIRED) gentoo-dev 2010-03-22 10:15:30 UTC
I dunno why you stuck wxGTK in there. It doesn't need it *at all*. It just needs gtk+ and libunique, plus dev-util/pkgconfig as a build-time dep.
Comment 4 nm (RETIRED) gentoo-dev 2010-03-22 10:37:02 UTC
Created attachment 224637 [details]
gsimplecal-25.ebuild

Here's an ebuild that really works.

However, the problem is that the Makefile doesn't respect the user's CXXFLAGS, LDFLAGS, and it doesn't properly go about finding the system cpp compiler. i.e. inheriting toolchain-funcs and using $(tc-getCC) and all that jazz.

So the next step is writing a proper src_compile() function that does all that.
Comment 5 nm (RETIRED) gentoo-dev 2010-03-22 10:59:46 UTC
Created attachment 224643 [details]
gsimplecal-25.ebuild

. . . like this one. This ebuild is the one to use.

This does the magic stuff thanks to sed and the toolchain-funcs eclass.

Upstream really needs to fix their build system.
Comment 6 nm (RETIRED) gentoo-dev 2010-03-22 11:05:50 UTC
Comment on attachment 224643 [details]
gsimplecal-25.ebuild

Actually, there are some problems with the g++ stuff. Fixed ebuild will go up later.
Comment 7 nm (RETIRED) gentoo-dev 2010-03-22 11:19:05 UTC
Created attachment 224649 [details]
gsimplecal-25.ebuild

The one with the g++ fixes, so that it can be properly cross-compiled and/or properly distCCed. Thanks to leio on IRC for identifying the g++ invocation issues.
Comment 8 Alexander Kozyrev 2010-04-26 16:51:07 UTC
Created attachment 229265 [details]
gsimplecal-33 ebuild
Comment 9 Alexander Kozyrev 2010-04-27 09:51:40 UTC
Created attachment 229369 [details]
gsimplecal-33 ebuild

configuration actions moved out from src_compile() into src_configure()
src_install() installs man page as well
Comment 10 nm (RETIRED) gentoo-dev 2010-04-27 17:12:20 UTC
Created attachment 229415 [details]
gsimplecal-33.ebuild

A better ebuild. This one makes use of some default functions, and removes unnecessary code. For example, no need to redundantly specify "die" when it's already built-in to Portage.
Comment 11 Ovchinnikov Mikhail 2010-08-24 19:52:18 UTC
Created attachment 244439 [details]
New ebuild

Gsimplecal has grown to version 0.5, hence new ebuild.
Comment 12 Ștefan Talpalaru 2011-05-25 01:03:20 UTC
Created attachment 274551 [details]
gsimplecal-0.8.ebuild

version bump
Comment 13 Denis Klens 2013-08-27 15:52:20 UTC
Created attachment 357174 [details]
gsimplecal-1.6.ebuild

new ebuild version
Comment 14 Francesco Turco 2014-04-27 11:58:30 UTC
Homepage has moved to https://github.com/dmedvinsky/gsimplecal. Also, latest version is 2.0, released on 2013-11-11.
Comment 15 José Romildo Malaquias 2015-06-18 15:11:37 UTC
The latest version is 2.1, released on 2014-12-09.
Comment 16 nm (RETIRED) gentoo-dev 2018-01-21 01:31:28 UTC
this has been maintainer-wanted for ages, with no one picking it up. upstream hasn't updated the package in a few years. should this bug be closed?