Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 30598 - libperl-5.8.1 upgrade from 5.8.0 creates a hard crash
Summary: libperl-5.8.1 upgrade from 5.8.0 creates a hard crash
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Perl team
Depends on:
Reported: 2003-10-07 12:33 UTC by Brian Friday
Modified: 2003-12-19 16:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Brian Friday 2003-10-07 12:33:05 UTC
upon a emerge of libperl-5.8.1 the source gets unpacked and the
create-libperl-soname.patch gets applied with an "ok". 

Then the computer crashes with no visible errors anywhere. Everything freezes up
and the only thing in the emerge log is: 

1065554173:  >>> emerge (1 of 8) sys-devel/libperl-5.8.1 to /
1065554173:  === (1 of 8) Cleaning
1065554177:  === (1 of 8) Compiling/Merging

This was done while compiling with and without distcc and with ccache enabled.
I'm running ~x86 with the following installed:


Reproducible: Always
Steps to Reproduce:
1. emerge (-u optional) libperl
2. libperl is unpacked and patched 

Actual Results:  
computer crashes completely no 3 finger salute, no console prompt nothing just
goes dead

Expected Results:  
installed and built libperl-5.8.1 with perl-5.8.1 being followed up
Comment 1 Bryan Liles 2003-11-03 07:02:20 UTC
This also happens on my system.   I am running ~x86 on a P4.
Comment 2 Bryan Liles 2003-11-03 07:05:37 UTC
Also, I want to note that I am using gcc 3.2.3-r2.
Comment 3 Paul Slinski 2003-11-14 21:06:42 UTC
This happens here as well. Portage unpacks the source, patches it (we're up to 5.8.2 here now) and the system hardlocks.

This is gcc 3.3.2 building libperl 5.8.2

This happened with 5.8.1 and I thought maybe my hard drive was failing so I bought a new one and rebuilt the system. I'll be darned if it didn't start happening again.

Could this be an issue with hyperthreading? I am using a P4 3 GHz with HT turned on. I've even tried moving /var/portage/tmp to another drive but still no luck. I'll turn HT off and report back.

Further details: ac-sources 2.4.22-ac4, portage 2.0.49-r15

I would like to communicate with anyone who happened to figure this one out.
Comment 4 Brian Friday 2003-11-14 21:12:19 UTC
I can second the 5.8.2 lockups, I've rebuilt my system but haven't felt like upgrading perl because of this so I'm not sure if there is a resolution.
Comment 5 Paul Slinski 2003-11-14 21:24:04 UTC

Hyperthreading locks the system. Turning it off allows me to be able to build without a hitch.

Prob turn it off via kernel or bios and build away. Please let me know if it works for you.

Comment 6 Brian Friday 2003-11-14 22:28:34 UTC
Hyper threading is not a issue on my system or at least I'd be very suprised if it was. I'm running a Dell Inspiron 8200 with a P4-M w/out HyperThreading. As I understand it the cpu's physically have the jumpers for HT disabled.
Comment 7 Brian Friday 2003-12-10 10:27:31 UTC
Having given this a little more thought while I'm still not sure why this is happening. I was not using to install modules not in portage. Rather I was using the typical cpan install command "perl -MCPAN -e shell". Specifically I installed the modules needed for request tracker.

On the two other machines which I had perl and did upgrade the perl (both 5.8.0 to 5.8.1 and 5.8.1 to 5.8.2) neither machine had modules installed via the "perl -MCPAN -e shell" method.

Realized that my CFLAG setting might be useful so here they are (after some pentium4 cflag usage I have stuck with this in my new install on this machine): CFLAGS="-march=i686 -O3 -pipe". 
Comment 8 Robert Coie (RETIRED) gentoo-dev 2003-12-19 16:16:00 UTC
I sympathize with those of you having problems, but I don't see anything that we
can do on this end.