Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305889 - sys-libs/ncurses-5.7-r3: Building with --disable-leaks not possible (fix included)
Summary: sys-libs/ncurses-5.7-r3: Building with --disable-leaks not possible (fix incl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-19 15:22 UTC by Nikolas Garofil
Modified: 2010-03-07 01:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolas Garofil 2010-02-19 15:22:07 UTC
Ncurses builds with --with-leaks or --without-leaks depending on the whether the debug use-flag has been set, but these options are not recognized by the configure script, it should be --disable-leaks instead. When you change "$(use_with !debug leaks)" to "$(if use debug ; then echo --disable-leaks ; fi)" on line 101 of ncurses-5.7-r3.ebuild then this problem is solved. You can NOT just use "$(use_enable !debug leaks)" because --enable-leaks has the same effect as --disable-leaks .

PS: If you fix this, can you place my name or e-mail address in the changelog, I'm looking for a job at the moment and i would like some proof that i'm active in the open source world, thanks ;)

Reproducible: Always

Steps to Reproduce:
Comment 1 SpanKY gentoo-dev 2010-03-06 23:12:36 UTC
then we should fix ncurses so that we can use use_enable.  i think this should do it:
http://sources.gentoo.org/sys-libs/ncurses/ncurses-5.7-r3.ebuild?r1=1.9&r2=1.10

btw, simpler workaround would be $(use debug && echo --disable-leaks)
Comment 2 SpanKY gentoo-dev 2010-03-06 23:12:51 UTC
Thomas: simple fix for you:
    sed -i '/with_no_leaks=yes/s:=.*:=$enableval:' aclocal.m4

this way --enable-leaks and --disable-leaks both work instead of --enable-leaks having the same meaning as --disable-leaks
Comment 3 Thomas Dickey 2010-03-07 01:09:12 UTC
thanks (added to to-do list)