Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305225 - x11-libs/gtksourceview-2.8.2 needs dev-perl/XML-Parser but cannot detect
Summary: x11-libs/gtksourceview-2.8.2 needs dev-perl/XML-Parser but cannot detect
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-15 11:46 UTC by Yury Vorobyov
Modified: 2010-02-15 12:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,5.15 KB, text/plain)
2010-02-15 12:17 UTC, Yury Vorobyov
Details
gtksourceview build log (gtksourceview-build.log,6.94 KB, text/plain)
2010-02-15 12:18 UTC, Yury Vorobyov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Vorobyov 2010-02-15 11:46:20 UTC
dev-perl/XML-Parser not detected by gtksourceview-2.8.2 build process, but already installed. Build dies at econf.

Reproducible: Didn't try

Steps to Reproduce:
1.Try to install gtksourceview
2.View build log / View that dev-perl/XML-Parser already installed
3.Reinstall dev-perl/XML-Parser, it solves situation




dev-perl/XML-Parser detection / dependency
Comment 1 Yury Vorobyov 2010-02-15 12:17:58 UTC
Created attachment 219759 [details]
emerge --info
Comment 2 Yury Vorobyov 2010-02-15 12:18:34 UTC
Created attachment 219761 [details]
gtksourceview build log
Comment 3 Yury Vorobyov 2010-02-15 12:19:47 UTC
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-libs/gtksourceview-2.8.2/work/gtksourceview-2.8.2/config.log
 [31;01m*[0m ERROR: x11-libs/gtksourceview-2.8.2 failed:
 [31;01m*[0m   econf failed
 [31;01m*[0m 
 [31;01m*[0m Call stack:
 [31;01m*[0m     ebuild.sh, line   54:  Called src_configure
 [31;01m*[0m   environment, line 1525:  Called gnome2_src_configure
 [31;01m*[0m   environment, line 1277:  Called econf '--disable-gtk-doc'
 [31;01m*[0m     ebuild.sh, line  544:  Called die
 [31;01m*[0m The specific snippet of code:
 [31;01m*[0m   			die "econf failed"
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the output of 'emerge --info =x11-libs/gtksourceview-2.8.2',
 [31;01m*[0m the complete build log and the output of 'emerge -pqv =x11-libs/gtksourceview-2.8.2'.
 [31;01m*[0m The complete build log is located at '/usr/log/x11-libs:gtksourceview-2.8.2:20100215-111929.log'.
 [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/x11-libs/gtksourceview-2.8.2/temp/environment'.
 [31;01m*[0m S: '/var/tmp/portage/x11-libs/gtksourceview-2.8.2/work/gtksourceview-2.8.2'
Comment 4 Gilles Dartiguelongue gentoo-dev 2010-02-15 12:57:33 UTC

*** This bug has been marked as a duplicate of bug 41124 ***