Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305199 - Cant compile dev-util/geany-0.18.1
Summary: Cant compile dev-util/geany-0.18.1
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-15 08:11 UTC by muhsin
Modified: 2010-02-15 08:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Make.conf (make.conf,1.56 KB, text/plain)
2010-02-15 08:12 UTC, muhsin
Details
config.log (config.log,27.84 KB, text/plain)
2010-02-15 08:13 UTC, muhsin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muhsin 2010-02-15 08:11:41 UTC
checking for perl >= 5.8.1... 5.10.1                                                                                                    
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool                                          

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-util/geany-0.18.1/work/geany-0.18.1/config.log
 * ERROR: dev-util/geany-0.18.1 failed:                                
 *   econf failed                                                      
 *                                                                     
 * Call stack:                                                         
 *     ebuild.sh, line  54:  Called src_configure                      
 *   environment, line 298:  Called econf '--disable-dependency-tracking' '--enable-vte'
 *     ebuild.sh, line 544:  Called die                                                 
 * The specific snippet of code:                                                        
 *                      die "econf failed"                           

Reproducible: Always

Steps to Reproduce:
1.emerge -avuDN world
2.
3.

Actual Results:  
Ebuild failed to compile

Expected Results:  
Should compile and install new update
Comment 1 muhsin 2010-02-15 08:12:58 UTC
Created attachment 219737 [details]
Make.conf
Comment 2 muhsin 2010-02-15 08:13:29 UTC
Created attachment 219739 [details]
config.log
Comment 3 Samuli Suominen gentoo-dev 2010-02-15 08:16:25 UTC
Closing as duplicate of ancient bug.

Basically you haven't done perl-cleaner after perl upgrade. 

I suggest "perl-cleaner --reallyall" and "emerge -1 XML-Parser"

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 4 muhsin 2010-02-15 08:21:12 UTC
(In reply to comment #3)
> Closing as duplicate of ancient bug.
> 
> Basically you haven't done perl-cleaner after perl upgrade. 
> 
> I suggest "perl-cleaner --reallyall" and "emerge -1 XML-Parser"
> 
> *** This bug has been marked as a duplicate of bug 41124 ***
> 

Thanks..