Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305099 - net-im/pidgin-2.6.5 fails with: checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
Summary: net-im/pidgin-2.6.5 fails with: checking for XML::Parser... configure: error:...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-14 18:22 UTC by Willard Dawson
Modified: 2013-12-19 15:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Config log (config.log,50.67 KB, text/plain)
2010-02-14 18:23 UTC, Willard Dawson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Willard Dawson 2010-02-14 18:22:20 UTC
revdep-rebuild required re-emerge of net-im/pidgin-2.6.5

The configuration checks failed with the error:

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

However, dev-perl/XML-Parser is installed already.

wdawsonlt ~ # eix -I dev-perl/XML-Parser
[I] dev-perl/XML-Parser
     Available versions:  2.36 (~)2.36-r1
     Installed versions:  2.36-r1(22:33:56 01/14/10)
     Homepage:            http://search.cpan.org/dist/XML-Parser/
     Description:         A Perl extension interface to James Clark's XML parser, expat



Reproducible: Always




# emerge --info
Portage 2.1.7.17 (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11-r1, 2.6.32-gentoo-r5 i686)
=================================================================                         
System uname: Linux-2.6.32-gentoo-r5-i686-Intel-R-_Pentium-R-_M_processor_2.00GHz-with-gentoo-2.0.1                                                                                   
Timestamp of tree: Sun, 14 Feb 2010 02:00:01 +0000                                         
app-shells/bash:     4.1_p2                                                                
dev-java/java-config: 2.1.10                                                               
dev-lang/python:     2.5.4-r4, 2.6.4-r1, 3.1.1-r1                                          
dev-python/pycrypto: 2.1.0                                                                 
dev-util/cmake:      2.8.0-r2                                                              
sys-apps/baselayout: 2.0.1                                                                 
sys-apps/openrc:     0.6.0-r1                                                              
sys-apps/sandbox:    2.2                                                                   
sys-devel/autoconf:  2.13, 2.65                                                            
sys-devel/automake:  1.5-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1                  
sys-devel/binutils:  2.20                                                                  
sys-devel/gcc:       4.3.4, 4.4.3                                                          
sys-devel/gcc-config: 1.4.1                                                                
sys-devel/libtool:   2.2.6b                                                                
virtual/os-headers:  2.6.32                                                                
ACCEPT_KEYWORDS="x86 ~x86"                                                                 
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 Nessus-EULA sun-bcla-java-vm"                        
CBUILD="i686-pc-linux-gnu"                                                                 
CFLAGS="-march=i686 -O2 -pipe -ggdb"                                                       
CHOST="i686-pc-linux-gnu"                                                                  
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"                                 
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"  
CXXFLAGS="-march=i686 -O2 -pipe -ggdb"                                                     
DISTDIR="/usr/portage/distfiles"                                                           
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                       
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                               
LDFLAGS="-Wl,-O1"                                                                          
MAKEOPTS=""                                                                                
PKGDIR="/usr/portage/packages"                                                             
PORTAGE_CONFIGROOT="/"                                                                     
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                   
PORTAGE_TMPDIR="/var/tmp"                                                                  
PORTDIR="/usr/portage"                                                                     
PORTDIR_OVERLAY="/usr/local/portage"                                                       
SYNC="rsync://rsync.gentoo.org/gentoo-portage"                                             
USE="3dnow 3dnowext X a52 aac acl acpi aiglx alsa apache2 apm arts ati audiofile avahi avi bash-completion berkdb bitmap-fonts bzip2 cairo caps cardbus cdio cdr cli consolekit cracklib crypt ctype cups cxx dba dbtool dbus digitalradio diskio djvu dri dts dvd dvdread eds emboss encode esd ethereal exif expat fastbuild ffmpeg fftw fglrx foomaticdb force-cgi-redirect fortran ftp fuse gamin gd gdbm gif glib glitz glut gmp gpm gstreamer gtk gtk2 gtkhtml guile hal iconv idn imlib ipv6 ithreads jack java jpeg kde kerberos kqemu lcms ldap libclamav libg++ libwww lirc live lm_sensors lua mad madwifi matroska mdnsresponder-compat memlimit mhash mikmod mmx mmxext mng modules mono motif mozilla mp3 mpeg mudflap mysql ncurses netboot netjack networking nforce2 nls nptl nptlonly nsplugin nvidia ocaml ogg oggvorbis opengl openmp oss pam pango pch pcmcia pcre pdf pdflib pear perl php pmu png policykit portaudio posix pppd pulseaudio python qt qt3support qtmt quicktime readline reflection ruby samba sasl sdl semantic-desktop session simplexml slang sndfile snmp soap sockets spell spl sql sqlite sse sse2 ssl svg sysfs tcl tcltk tcpd theora threads threadsafe tiff tk tokenizer truetype truetype-fonts type1-fonts udev unicode utempter vorbis wddx webkit wifi win32codecs x86 xanim xinerama xml xmlrpc xorg xscreensaver xsl xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="hp2600n" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Willard Dawson 2010-02-14 18:23:10 UTC
Created attachment 219671 [details]
Config log
Comment 2 Märt Bakhoff 2010-02-14 18:28:16 UTC
Same when building media-gfx/inkscape-0.47, noticed right after upgrading perl-5.8.8-r8 to perl-5.10.1
Comment 3 Tom Gillespie 2010-02-14 19:31:12 UTC
run emerge XML-Parser, that should fix your problem
Comment 4 William Throwe 2010-02-14 19:34:12 UTC
Have you run 'perl-cleaner all'?  You probably still have perl 5.8.8 copies of all your modules.

It looks like the ebuild should print something about this, but I didn't see it when I updated, and it looks like others aren't seeing it either.
Comment 5 Willard Dawson 2010-02-14 19:59:32 UTC
(In reply to comment #3)
> run emerge XML-Parser, that should fix your problem
> 

I did, and it did.  Thanks.
Comment 6 Willard Dawson 2010-02-14 20:06:39 UTC
(In reply to comment #4)
> Have you run 'perl-cleaner all'?  You probably still have perl 5.8.8 copies of
> all your modules.
> 
> It looks like the ebuild should print something about this, but I didn't see it
> when I updated, and it looks like others aren't seeing it either.
> 

No, not lately.  Running it now, belatedly.  Thanks.
Comment 7 Jeroen Roovers gentoo-dev 2013-12-19 15:14:10 UTC

*** This bug has been marked as a duplicate of bug 41124 ***