Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 304177 - media-sound/amarok-2.2.2.90, media-sound/phonon-4.3.80-r1, kde-base/phonon-kde 4.4.1: Amarok fails to output sound when auto-started
Summary: media-sound/amarok-2.2.2.90, media-sound/phonon-4.3.80-r1, kde-base/phonon-kd...
Status: RESOLVED DUPLICATE of bug 314185
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-09 20:21 UTC by Claes
Modified: 2010-06-09 13:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claes 2010-02-09 20:21:41 UTC
Amarok autostarts with my KDE.
When music "begins" playing, the application behaves just as i should, except I hear no sound. Closing amarok and starting it again solves the issue until next reboot.

Reproducible: Always

Actual Results:  
No sound

Expected Results:  
Sound

I had this on my previous x86 install, but have just recently done a new amd64 install, and find to my surprise that the issue show up here too.
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-02-19 13:10:49 UTC
This could be caused by a delay in starting KDE sound subsystem.
Does this still happen with amarok-2.2.2.90, that will be put in the tree in a few hours, and the latest phonon / KDE?
Comment 2 Claes 2010-03-09 06:28:10 UTC
I have upgraded to amarok-2.2.2.90, phonon-4.3.80-r1 and phonon-kde 4.4.1, the problem remains.
Comment 3 Claes 2010-03-25 13:26:27 UTC
Something I should have noticed from the beginning, is that after login, I get a notification that "Your soundcard xxx doesn't work, falling back to ."
That's very likely related.
Comment 4 Alex Barker 2010-04-12 18:23:57 UTC
(In reply to comment #3)
> Something I should have noticed from the beginning, is that after login, I get
> a notification that "Your soundcard xxx doesn't work, falling back to ."
> That's very likely related.
> 

Humor me, what dbus version ?
Comment 5 Claes 2010-04-12 18:55:48 UTC
Currently: package sys-apps/dbus-1.2.24
Actually, since the upgrade to 2.24 that I did yesterday, I get a "Your sound card has been removed" message from KDE everytime the computer starts. This on two different computers.
Comment 6 Alex Barker 2010-04-14 00:26:02 UTC
(In reply to comment #5)
> Currently: package sys-apps/dbus-1.2.24
> Actually, since the upgrade to 2.24 that I did yesterday, I get a "Your sound
> card has been removed" message from KDE everytime the computer starts. This on
> two different computers.
> 

Sounds like it maybe related to bug: #314185
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-06-09 13:12:41 UTC
I'm closing this as a dupe of bug 314185.
If anyone decides it's not a dupe and reopens it, please change the description as this is not an amarok issue.

*** This bug has been marked as a duplicate of bug 314185 ***