Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 303857 - sys-auth/polkit-0.96 should depend on dev-perl/XML-Parser
Summary: sys-auth/polkit-0.96 should depend on dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-07 13:42 UTC by Andrey Grozin
Modified: 2013-12-19 15:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Grozin gentoo-dev 2010-02-07 13:42:32 UTC
checking for perl >= 5.8.1... 5.8.8
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-auth/polkit-0.96/work/polkit-0.96/config.log
 * ERROR: sys-auth/polkit-0.96 failed:
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   48:  Called src_configure
 *   environment, line 2410:  Called econf '--disable-introspection' '--disable-ansi' '--disable-examples' '--enable-fast-install' '--enable-libtool-lock' '--enable-man-pages' '--disable-dependency-tracking' '--with-os-type=gentoo' '--localstatedir=/var' '--libexecdir=${exec_prefix}/libexec/polkit-1' '--with-authfw=pam' '--with-pam-module-dir=/lib/security' '--disable-verbose-mode' '--enable-gtk-doc' '--enable-nls'
 *     ebuild.sh, line  538:  Called die
 * The specific snippet of code:
 *                      die "econf failed"

Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2010-02-07 13:50:52 UTC
Closing as INVALID since intltool deps on XML-Parser:

<snip>
DEPEND=">=dev-lang/perl-5.8.1
        dev-perl/XML-Parser" 
RDEPEND="${DEPEND}"          
</snip>

and polkit deps on intltool:

<snip>
DEPEND="${RDEPEND}                                       
        >=dev-util/intltool-0.36          
</snip>

Your system is broken. Run "revdep-rebuild" and/or "emerge -1 expat XML-Parser intltool".
Comment 2 Andrey Dudarev 2010-10-08 20:51:20 UTC
It's still error when I tried to emerge sys-auth/polkit-0.96-r2 . 
After emerge dev-perl/XML-Parser-2.40 it's ok.
Comment 3 Jeroen Roovers gentoo-dev 2013-12-19 15:30:54 UTC

*** This bug has been marked as a duplicate of bug 41124 ***