Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 303591 - media-libs/fontconfig: default settings for 2 symbols fonts leads to incorrect display in app-text/poppler based apps
Summary: media-libs/fontconfig: default settings for 2 symbols fonts leads to incorrec...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All All
: High minor with 1 vote (vote)
Assignee: Gentoo Fonts Team
URL: http://forums.gentoo.org/viewtopic-t-...
Whiteboard:
Keywords:
: 360735 (view as bug list)
Depends on: 247657
Blocks:
  Show dependency tree
 
Reported: 2010-02-05 16:17 UTC by Rafał Mużyło
Modified: 2011-03-30 02:36 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
test pdf (test-bullets-red.pdf,6.45 KB, application/pdf)
2010-02-05 18:42 UTC, Rafał Mużyło
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał Mużyło 2010-02-05 16:17:43 UTC
All the info is in that thread.

As I said there, those two fonts need to be prepended, instead of
appended for test test pdf to be correctly displayed.
(OK, for that pdf, only Dingbats are needed, but it's better to do it
for both fonts at the same time)
Comment 1 Rafał Mużyło 2010-02-05 16:18:54 UTC
This simply follows the advice given on http://freedesktop.org/wiki/Software/poppler.
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2010-02-05 18:12:09 UTC
Could you attach test pdf here? Probably this change should be done in line with gnu-gs-fonts-std fonts deprecation (or whatever will happen with them).
Comment 3 Rafał Mużyło 2010-02-05 18:42:20 UTC
Created attachment 218557 [details]
test pdf

It's a bit hard to tell if that bug is related, however
it seems unlikely, as it was not a matter of missing fonts,
but wrong matching order.
While I didn't have urw-fonts, original reported did
and both of us could reproduce the bug.

As I said in the thread, default fontconfig setting for those two is 
append, while poppler needs prepend, otherwise vera gets selected.
Comment 4 Paul Bredbury 2010-02-28 10:23:43 UTC
The fix is simple and easy - just apply 30-urw-aliases.patch from
http://repos.archlinux.org/wsvn/packages/fontconfig/trunk/
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2010-03-16 04:44:37 UTC
nice patch.  i bet it would look even nicer upstream.
Comment 6 Ryan Hill (RETIRED) gentoo-dev 2010-03-16 04:52:51 UTC
also related: bug #282151
Comment 7 Paul Bredbury 2010-03-16 12:18:54 UTC
(In reply to comment #5)
> i bet it would look even nicer upstream.

That would be far too sensible for an open-source project. They'd rather just put a notice on their wiki, then forget about it (??!). See:

http://bugs.freedesktop.org/show_bug.cgi?id=18002

If you're gonna improve the fontconfig rules, I suggest mine:

http://forums.gentoo.org/viewtopic-t-723341-postdays-0-postorder-asc-start-257.html
Comment 8 Rafał Mużyło 2010-03-16 15:07:04 UTC
I think that meant *fontconfig* upstream,
as your patch suggests a possible typo in default rules.
Cause right above the new rule, is the old one that differs
only with a space in the font name.
Comment 9 Paul Bredbury 2010-03-16 16:47:58 UTC
(In reply to comment #8)
> I think that meant *fontconfig* upstream

Yes, this is a *fontconfig* issue. It is not poppler's job to choose the font - it is fontconfig's job. This is why the correct, easily-checkable and easy-to-apply fix is to change fontconfig's config files ;)

> possible typo in default rules.

Not AFAIK. There are different ways of specifying the "same" font, especially e.g. the TrueType vs Postscript variants.
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2010-03-16 22:26:28 UTC
(In reply to comment #9)
> Yes, this is a *fontconfig* issue. It is not poppler's job to choose the font -
> it is fontconfig's job. This is why the correct, easily-checkable and
> easy-to-apply fix is to change fontconfig's config files ;)

which is why this should go upstream to fontconfig...
Comment 11 Paul Bredbury 2010-03-22 19:48:08 UTC
The patch is already upstream, where they are sitting on it and pondering whitespace:
https://bugs.freedesktop.org/show_bug.cgi?id=19128
Comment 12 Ryan Hill (RETIRED) gentoo-dev 2010-03-23 07:16:10 UTC
thanks for tracking that down.  i'll add the patch next chance i get.
Comment 13 Ryan Hill (RETIRED) gentoo-dev 2010-04-11 01:56:32 UTC
fixed in 2.8.0-r1.
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2011-03-30 02:36:02 UTC
*** Bug 360735 has been marked as a duplicate of this bug. ***