Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 302537 - HAL auto-configuration will not work with binary drivers like NVIDIA or ATI. Please update the X Config HOWTO and the ATI and NVIDIA Guides/FAQS
Summary: HAL auto-configuration will not work with binary drivers like NVIDIA or ATI. ...
Alias: None
Product: [OLD] Docs on
Classification: Unclassified
Component: Other documents (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Docs Team
Depends on:
Blocks: 302541
  Show dependency tree
Reported: 2010-01-27 21:46 UTC by Carter Young
Modified: 2010-02-10 12:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Carter Young 2010-01-27 21:46:26 UTC
Please see the [gentoo-user] mailing list thread at:, which states that when using third party propietery drivers like the one mentioned in the guide above, that the driver WILL NOT work as intended unless x11-base/xorg-server is emerged with USE flags which must include -hal.  This makes configuration a lot easir in the XOrg guide

Reproducible: Always

Steps to Reproduce:
1. Set VIDEO_CARDS="nvidia" and INPUT_DEVICES="evdev" in /etc/make.conf, following the X Config Howto
2. USE="hal" emerge xorg server
3. type startx without /etc/X11/xorg.conf
4. Xorg errors out that X cannot run in framebuffer mode, and disables the xdm runscript
5. As a side note, when hal is enabled, with /etc/X11/xorg.conf the value of XSESSION is ignored and when startx is called the session defaults to TWM and echo "${XSESSION}" returns a blank line

Actual Results:  
See Step #4.

Expected Results:  
NVIDIA should work with HAL enabled.  I will report this to the Gentoo X.Org shepards and possibly upstream to X.Org themselves.

Portage (default/linux/amd64/10.0/no-multilib, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 x86_64)
System uname: Linux-2.6.31-gentoo-r6-x86_64-AMD_Athlon-tm-_64_Processor_3800+-with-gentoo-1.12.13
Timestamp of tree: Mon, 25 Jan 2010 01:45:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.6.4
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
CFLAGS="-O2 -pipe -march=opteron"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=opteron"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X a52 aac aalib acl acpi amd64 audiofile bash-completion bash_completion berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups curl cxx dbus dga doc dri dts dv dvd dvdr dvdread encode esd examples fam fbcondecor ffmpeg firefox flac fortran gd gdbm git gnome gnutls gphoto2 gpm gtk hal iconv idn ieee1394 ipv6 jack jadetex java joystick jpeg jpeg2k lcms libcaca mmx mmxext modules mudflap ncurses nls nptl nptlonly nsplugin odbc openal openmp pam pcre perl png portaudio ppds pppd python readline reflection samba scanner session slp sndfile speex spl sse sse2 ssl svg sysfs tcl tcpd theora tidy tiff tk unicode usb wmf xine xinerama xml xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 1 nm (RETIRED) gentoo-dev 2010-01-28 06:01:56 UTC
HAL autoconfig has always worked with the nVidia driver here, for an ancient GeForce2 Go, an old 7600GT, and a more recent GeForce 8200. All versions of xorg-server from 1.2.x to the latest have worked with it, so it's some other problem. X works just fine with USE="hal".
Comment 2 Carter Young 2010-01-28 06:13:43 UTC
May I ask if you are using nvidia-drivers?  If so, can I see your congiguration so I can copy it?  I'd like to get this working properly.
Comment 3 Carter Young 2010-01-28 06:14:30 UTC
May I ask if you are using nvidia-drivers?  If so, can I see your configuration so I can copy it?  I'd like to get this working properly.
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2010-02-10 07:38:38 UTC
Reopening in light of

Actually I guess auto-configuration should work but there is a bug which precludes this to happen (see link I gave in that bug).
Comment 5 nm (RETIRED) gentoo-dev 2010-02-10 12:23:37 UTC
Still closed. The doc already says what to do if you need a minimal xorg.conf, and the nVidia guide has the proper steps, too.

This is a user issue, not a documentation problem. Closing again.