Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 302501 - Please stabilize =dev-libs/log4cxx-0.10.0
Summary: Please stabilize =dev-libs/log4cxx-0.10.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: C++ Team [disbanded]
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 254920 256762
Blocks: 302468
  Show dependency tree
 
Reported: 2010-01-27 19:32 UTC by Samuli Suominen
Modified: 2010-02-25 09:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2010-01-27 19:32:57 UTC
It fixes building with GCC 4.4.x, so need to get it stable, but see the dependant bugs first, should get them sorted in a same stablebump
Comment 1 Samuli Suominen gentoo-dev 2010-02-24 12:50:30 UTC
x86, please do, current stable doesn't compile
Comment 2 Christian Faulhammer (RETIRED) gentoo-dev 2010-02-25 08:50:25 UTC
It fails test here on x86.  Can you reproduce?
Comment 3 Samuli Suominen gentoo-dev 2010-02-25 09:07:19 UTC
(In reply to comment #2)
> It fails test here on x86.  Can you reproduce?
> 

Yes. Is that a regression? Also, nothing deps on log4cxx except package.use.masked USE "log" in app-misc/strigi, so you can opt
out on this and we can kill the current non-compiling stable.
Comment 4 Christian Faulhammer (RETIRED) gentoo-dev 2010-02-25 09:43:43 UTC
Let's do that.
Comment 5 Samuli Suominen gentoo-dev 2010-02-25 09:53:52 UTC
(In reply to comment #4)
> Let's do that.
> 

+  25 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+  -log4cxx-0.9.7-r4.ebuild, -files/log4cxx-0.9.7-gcc41.patch,
+  -files/log4cxx-0.9.7-gentoo.diff, -files/log4cxx-0.9.7-tchar.patch,
+  -files/log4cxx-0.9.7-use-SQLWCHAR.diff, log4cxx-0.10.0.ebuild:
+  Remove old wrt #302501. Remove unused USE flag "doc".