Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 30242 - mplayer-1.0_pre1-r1 forcing installation of divx4linux while --disable-divx4linux is available
Summary: mplayer-1.0_pre1-r1 forcing installation of divx4linux while --disable-divx4l...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 45018 (view as bug list)
Depends on: 18964
Blocks:
  Show dependency tree
 
Reported: 2003-10-03 05:21 UTC by Lars Grunewaldt
Modified: 2004-05-26 22:16 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mplayer-1.0_pre1-r1-adv.ebuild (mplayer-1.0_pre1-r1.ebuild,10.75 KB, text/plain)
2003-10-03 05:53 UTC, Lars Grunewaldt
Details
mplayer-1.0_pre1-r1-adv.patch (patch,806 bytes, patch)
2003-10-03 05:55 UTC, Lars Grunewaldt
Details | Diff
patch to add divx4linux & xvid USE flags (mplayer-1.0_pre4-r1.ebuild.patch,1.79 KB, patch)
2004-05-02 10:56 UTC, Duncan Coutts (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Grunewaldt 2003-10-03 05:21:38 UTC
I just removed the dependency for divx4linux from x86 and moved it to divx4linux
as a use flag, than added the proper configure flag.

I'll attached the advanced makefile and a patch.

Reproducible: Always
Steps to Reproduce:
1. ACCEPT_KEYWORDS="~x86" USE="dvd encode" emerge -p mplayer
Actual Results:  
wants to install divx4linux.

Expected Results:  
I don't want to have divx4linux, and mplayer works without it (and has  a
compile flag regarding this matter)

Portage 2.0.49-r3 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r4,
2.6.0-test4-echoaudio)
=================================================================
System uname: 2.6.0-test4-echoaudio i686 AMD Athlon(TM) XP 2600+
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O3 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
/usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="sandbox ccache autoaddcvs"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 oss apm avi crypt cups encode foomaticdb gif jpeg libg++ libwww mad
mikmod mmx mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv
zlib gtkhtml alsa gdbm berkdb slang readline arts bonobo svga tcltk java guile
sdl gpm tcpd pam ssl perl python esd imlib oggvorbis qt motif opengl cdr scanner
X gtk
gnome -kde"
Comment 1 Lars Grunewaldt 2003-10-03 05:53:59 UTC
Created attachment 18660 [details]
mplayer-1.0_pre1-r1-adv.ebuild

advanced patch file
Comment 2 Lars Grunewaldt 2003-10-03 05:55:44 UTC
Created attachment 18661 [details, diff]
mplayer-1.0_pre1-r1-adv.patch
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2003-10-05 04:54:33 UTC
waiting for answer in bug #18964
Comment 4 Gregorio Guidi (RETIRED) gentoo-dev 2004-05-01 08:50:33 UTC
Now that divx4linux and xvid are officially in use.desc, I think
they could be implemented as the patch in this bug suggests...
Comment 5 Duncan Coutts (RETIRED) gentoo-dev 2004-05-02 10:56:10 UTC
Created attachment 30535 [details, diff]
patch to add divx4linux & xvid USE flags

I wasn't quite sure what to do about ppc & amd64. I removed those bits as they
should now specify USE="xvid" to get xvid rather than getting it by default.
Comment 6 Patrick Kursawe (RETIRED) gentoo-dev 2004-05-11 10:27:22 UTC
*** Bug 45018 has been marked as a duplicate of this bug. ***
Comment 7 Duncan Coutts (RETIRED) gentoo-dev 2004-05-26 09:07:41 UTC
Any chance of this getting fixed in a not-too-distant release?
Is there anything wrong with the patches people have suggested?

It's annoying that mplayer still wants to install binary-only proprietaryware and stuff like libcompat.
Comment 8 Brian Harring (RETIRED) gentoo-dev 2004-05-26 19:10:04 UTC
in-cvs shortly.
Comment 9 Brian Harring (RETIRED) gentoo-dev 2004-05-26 22:16:51 UTC
in-cvs, reopen if you encounter issues.