Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 301349 - new ebuild: media-sound/deadbeef
Summary: new ebuild: media-sound/deadbeef
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 22 votes (vote)
Assignee: Default Assignee for New Packages
URL: http://deadbeef.sourceforge.net/
Whiteboard:
Keywords:
: 304029 452086 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-18 09:43 UTC by Jared B.
Modified: 2019-04-11 18:06 UTC (History)
21 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-sound/deadbeef-0.3.2.ebuild (deadbeef-0.3.2.ebuild,1.27 KB, text/plain)
2010-01-18 09:44 UTC, Jared B.
Details
NSF MIME definition (x-nsf.xml,455 bytes, text/plain)
2010-01-18 09:45 UTC, Jared B.
Details
SPC MIME definition (x-spc.xml,388 bytes, text/plain)
2010-01-18 09:45 UTC, Jared B.
Details
media-sound/deadbeef-0.3.3 (deadbeef-0.3.3.ebuild,1.27 KB, text/plain)
2010-03-06 12:08 UTC, Jared B.
Details
media-sound/deadbeef-0.3.3.ebuild (deadbeef-0.3.3.ebuild,1.34 KB, text/plain)
2010-03-26 14:20 UTC, Pavel Procopiuc
Details
Corrected ebuild with libnotify support (deadbeef-0.3.3.ebuild,1.34 KB, text/plain)
2010-03-26 21:41 UTC, A.C.Heron
Details
media-sound/deadbeef-0.4_beta1.ebuild (deadbeef-0.4_beta1.ebuild,1.69 KB, text/plain)
2010-04-22 08:44 UTC, Pavel Procopiuc
Details
media-sound/deadbeef-0.4.0.ebuild (deadbeef-0.4.0.ebuild,1.68 KB, text/plain)
2010-05-10 09:06 UTC, Pavel Procopiuc
Details
deadbeef-0.4.1.ebuild (deadbeef-0.4.1.ebuild,1.90 KB, text/plain)
2010-06-06 15:10 UTC, Guillaume Castagnino
Details
working ebuild from funtoo's portage. (deadbeef-0.4.2.ebuild,2.24 KB, text/plain)
2010-10-17 13:24 UTC, Piotr Karbowski
Details
deadbeef-0.4.3_rc1-r1.ebuild (deadbeef-0.4.3_rc1-r1.ebuild,2.82 KB, text/plain)
2010-10-29 00:40 UTC, Sebastian Pipping
Details
bump (deadbeef-0.4.4.ebuild,2.24 KB, text/plain)
2010-11-16 10:45 UTC, Piotr Karbowski
Details
media-sound/deadbeef-0.4.4-r1.ebuild (deadbeef-0.4.4-r1.ebuild,2.74 KB, text/plain)
2010-12-09 08:21 UTC, Jared B.
Details
shorten license (shorten,839 bytes, text/plain)
2010-12-09 08:21 UTC, Jared B.
Details
media-sound/deadbeef-9999.ebuild (deadbeef-9999.ebuild,2.84 KB, text/plain)
2010-12-14 06:00 UTC, Jared B.
Details
media-sound/deadbeef-9999.ebuild (deadbeef-9999.ebuild,2.86 KB, text/plain)
2010-12-23 01:58 UTC, Jared B.
Details
deadbeef-0.5.0_rc2.ebuild (deadbeef-0.5.0_rc2.ebuild,2.43 KB, text/plain)
2011-05-15 18:46 UTC, Guillaume Castagnino
Details
deadbeef git ebuild tag version (deadbeef-0.5.0.ebuild,2.92 KB, text/plain)
2011-05-16 16:57 UTC, lamusic
Details
ebuild with ffap flag (deadbeef-0.5.0-r1_with_ffap.ebuild,2.38 KB, text/plain)
2011-05-16 19:19 UTC, mailrupile
Details
metadata with ffap flag (metadata_with_ffap.xml,1.22 KB, text/xml)
2011-05-16 19:20 UTC, mailrupile
Details
deadbeef-0.5.1.ebuild (deadbeef-0.5.1.ebuild,2.51 KB, application/octet-stream)
2011-05-22 20:21 UTC, Guillaume Castagnino
Details
build.log: emerge failed on compile state without intltool (build.log,13.90 KB, text/plain)
2011-05-23 03:28 UTC, cyberbat
Details
deadbeef-0.5.1.ebuild (deadbeef-0.5.1.ebuild,2.53 KB, text/plain)
2011-05-23 05:57 UTC, Guillaume Castagnino
Details
deadbeef-0.5.1-r1.ebuild doc installation fixed (deadbeef-0.5.1-r1.ebuild,2.69 KB, application/octet-stream)
2011-05-24 10:10 UTC, Yevgeny Filatov
Details
deadbeef-0.5.1-r1.ebuild, small fixes. latest. (deadbeef-0.5.1-r1.ebuild,2.73 KB, application/octet-stream)
2011-05-24 14:20 UTC, Piotr Karbowski
Details
deadbeef-0.5.1-r3.ebuild (deadbeef-0.5.1-r3.ebuild,2.73 KB, text/plain)
2011-09-16 09:46 UTC, Guillaume Castagnino
Details
ebuild and patch with virtual/ffmpeg depend (deadbeef-0.5.1-r3-libav.tar.xz,2.73 KB, application/octet-stream)
2011-12-14 10:31 UTC, cyberbat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jared B. 2010-01-18 09:43:44 UTC
This is an ebuild for the DeaDBeeF audio player.  It should be pretty solid, but please let me know if there are any issues with the ebuild.  I also included MIME support for NSF and SPC files so they can be associated with deadbeef.

Assuming no errors (or that any found are satisfactorily resolved), I request that this be added to portage.  Thanks.

Reproducible: Always

Steps to Reproduce:
Comment 1 Jared B. 2010-01-18 09:44:36 UTC
Created attachment 216783 [details]
media-sound/deadbeef-0.3.2.ebuild
Comment 2 Jared B. 2010-01-18 09:45:26 UTC
Created attachment 216785 [details]
NSF MIME definition
Comment 3 Jared B. 2010-01-18 09:45:43 UTC
Created attachment 216787 [details]
SPC MIME definition
Comment 4 Justin Lecher (RETIRED) gentoo-dev 2010-02-08 22:43:34 UTC
*** Bug 304029 has been marked as a duplicate of this bug. ***
Comment 5 Jared B. 2010-03-06 12:08:30 UTC
Created attachment 222259 [details]
media-sound/deadbeef-0.3.3

revision bump for latest version.  No ebuild changes.
Comment 6 Pavel Procopiuc 2010-03-26 14:20:57 UTC
Created attachment 225329 [details]
media-sound/deadbeef-0.3.3.ebuild

Ebuild with support for libnotify via use flag
Comment 7 A.C.Heron 2010-03-26 21:41:49 UTC
Created attachment 225379 [details]
Corrected ebuild with libnotify support

You forgot parentheses after "libnotify?".
Comment 8 Pavel Procopiuc 2010-04-22 08:44:01 UTC
Created attachment 228713 [details]
media-sound/deadbeef-0.4_beta1.ebuild
Comment 9 Pavel Procopiuc 2010-05-10 09:06:30 UTC
Created attachment 230929 [details]
media-sound/deadbeef-0.4.0.ebuild
Comment 10 Guillaume Castagnino 2010-06-06 15:10:37 UTC
Created attachment 234315 [details]
deadbeef-0.4.1.ebuild

Here is an updated proposal (including version bump)

In the previous ebuild, I noticed some problems after reviewing the configure.ac script :
- notifications are not issued through libnotify, but through dbus. There is absolutely no libnotify dependancy. There is legacy in the gtkui code, but it's no more used (seems to be abandonned in the 0.4 branch).
- There is a cascading dependancy : artwork needs curl-vfs. The current ebuild does not manage it
- fix some dependancies that should not be or that could be optionnal
Comment 11 Jose 2010-09-12 12:38:47 UTC
It'd be nice if the last.fm plugin was compiled in. I miss updates on my last.fm feed since I made deadbeef my main player.
Comment 12 Alexander Tsoy 2010-09-12 14:30:53 UTC
Try to enable lastfm use flag ;)
Comment 13 Opportunist 2010-10-17 13:19:35 UTC
release 0.4.2 available!

lots of changes :)
Comment 14 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2010-10-17 13:24:12 UTC
Created attachment 251005 [details]
working ebuild from funtoo's portage.
Comment 15 Sebastian Pipping gentoo-dev 2010-10-29 00:40:17 UTC
Created attachment 252455 [details]
deadbeef-0.4.3_rc1-r1.ebuild

I have improved the 0.4.3_rc1 ebuild from the xwing overlay further:
- remove default-enable from all use flags, except +hotkeys and +supereq
- sort RDEPEND and $my_config by use flag
- rename use flag "mad" to "mp3" (as mad is the only mp3 decoder in deadbeef)
- rename use flag "artwork" to "cover" (as that's the proper global flag to use)
- extend call to econf:
  - added --disable-dependency-tracking
  - add $(use_enable mms)
  - add $(use_enable midi wildmidi)
  - add --disable-gtk3

But I have bad new, too:
- all licenses used in deadbeef need to be known. "|| ( GPL-2 LGPL-2.1 )" is not true
- deadbeaf bundles tons of dependencies, so far I have found:
  - plugins/aac: aac? ( media-libs/faad2 )
  - plugins/adplug: adplug? ( media-libs/adplug )
  - plugins/ao
  - plugins/dca: dts? ( media-libs/libdca )
  - plugins/dump
  - plugins/gme
  - plugins/musepack: musepack? ( media-sound/musepack-tools )
  - plugins/shn: shorten? ( media-sound/shorten )
  - plugins/sid? ( media-libs/libsidplay )
  - plugins/supereq
  - plugins/tta
  - plugins/vorbis: vorbis? ( media-libs/libvorbis )
  - plugins/vtx
  - plugins/wildmidi: midi? ( media-sound/wildmidi )

If you want deadbeaf in Gentoo faster, please help me sort these issues out!

PS: I have added the attached ebuild to overlay "betagarden".
Comment 16 Opportunist 2010-11-02 07:17:22 UTC
release 0.4.3 available!

this is mainly a bugfix release.
Comment 17 Opportunist 2010-11-16 09:46:19 UTC
release 0.4.4 is out

2010/11/14

get it!

This is a really small (but important) bugfix release.

Summary of changes since 0.4.3:
fixed race condition in streamer interaction with output plugins
atexit and sigterm handlers are not used anymore to prevent playlist corruption when X session is being killed
artwork plugin doesn't have direct libcurl dependency anymore
merged new translations from LXDE branch
Comment 18 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2010-11-16 10:45:55 UTC
Created attachment 254481 [details]
bump
Comment 19 Yevgeny Filatov 2010-12-05 06:34:57 UTC
(In reply to comment #18)
> Created an attachment (id=254481) [details]
> bump
> 

In deadbeef-0.4.4.ebuild missed "\" after "$(use_enable dts dca) " ?
Comment 20 Jared B. 2010-12-05 20:19:59 UTC
(In reply to comment #19)
> In deadbeef-0.4.4.ebuild missed "\" after "$(use_enable dts dca) " ?

It is indeed missing, but it doesn't matter in this case because it's a quoted variable.  In fact, the backslashes can (and probably should) be removed from all of the lines in each my_config declaration, though it doesn't make any difference in how the ebuild works.
Comment 21 Jared B. 2010-12-09 08:21:16 UTC
Created attachment 256715 [details]
media-sound/deadbeef-0.4.4-r1.ebuild

Updated the 0.4.4 build:
* Incorporates most of the changes made by Sebastian in his 0.4.3-rc1 ebuild
* Added midi, nls, rpath, and threads USE flags and appropriate support
* Updated USE flags for consistency (mac, libnotify, maybe others) and alphabetized list
* Removed on-by-default from everything but GTK; is there a real need for anything else?
* Updated/added missing dependencies (mostly for curl, hotkeys, and midi) 
* Updated configure options for new and changed USE flags and lastfm/curl
* Added missing licenses - should be complete, but shorten license is not included in portage.  I'm attaching it to this ebuild for reference (pulled from media-sound/shorten package).

The dependency list and make options are now sorted by the deadbeef README and ./configure --help output, respectively.  Since these change fairly regularly between releases, I figured this was the easiest way to keep the ebuild up-to-date.

Anything else still need to be done?
Comment 22 Jared B. 2010-12-09 08:21:51 UTC
Created attachment 256717 [details]
shorten license
Comment 23 Jared B. 2010-12-14 06:00:10 UTC
Created attachment 257087 [details]
media-sound/deadbeef-9999.ebuild

Here's a live ebuild for anyone interested.  It will pull a current dev snampshot, using git.  Otherwise, it's equivalent to my 0.4.4-r1 ebuild.
Comment 24 Jared B. 2010-12-23 01:58:13 UTC
Created attachment 257815 [details]
media-sound/deadbeef-9999.ebuild

The previous live ebuild I posted pulled from the master branch.  Given that this is the same branch official releases are pulled from, it wasn't terribly useful for a "live" ebuild.  This revision should correctly pull from the devel branch.
Comment 25 Jose 2011-01-01 08:04:56 UTC
Does anybody know why I get no album covers displayed after updating to 4.4? Any idea where to start looking?
Thanks
Comment 26 Jared B. 2011-01-01 22:24:12 UTC
(In reply to comment #25)
> Does anybody know why I get no album covers displayed after updating to 4.4?

Did you enable the cover USE flag?  curl is also required, but should be forced on by cover.
Comment 27 Guillaume Castagnino 2011-05-15 18:46:41 UTC
Created attachment 273303 [details]
deadbeef-0.5.0_rc2.ebuild

I have update the ebuild to 0.5.0_rc2 in my overlay.
It has updated USE flags, some (those with problematic license among others) have disapeared. Some new (encode for example)

I converted it to EAPI4 too, to simplify the USE dependancies management
Comment 28 cyberbat 2011-05-16 09:44:42 UTC
What about stable version 0.5.0? I've tried ebuild from xwing overlay, but it fails compiling on convgui.c.
Comment 29 Guillaume Castagnino 2011-05-16 09:50:52 UTC
(In reply to comment #28)
> What about stable version 0.5.0? I've tried ebuild from xwing overlay, but it
> fails compiling on convgui.c.

Yes sadly.
In fact, that was fine with 0.5.0_rc2, but 0.5.0 issued a couple of hour after that fails : the tarball miss one subdir inside converter plugin.

If you want to compile it now, you have to disable "encode" USE flag.
I do not yet have had the time to report it to the upstream.
Comment 30 cyberbat 2011-05-16 10:06:07 UTC
(In reply to comment #29)
> 
> If you want to compile it now, you have to disable "encode" USE flag.
> I do not yet have had the time to report it to the upstream.

I really need encoding functionality of this tool. May be I can help you in any way to speed up process of fixing this bug?
Comment 31 Guillaume Castagnino 2011-05-16 13:57:56 UTC
upstream has fixed (silently) the tarball. You have to redownload it from sourceforge.
If you use xwing overlay, I have bumped and redigest the ebuild to force the fetch : 0.5.0-r1 should build fine with use encode
Comment 32 lamusic 2011-05-16 16:56:45 UTC
I have make it, i don't know if the USE and all other is very good, but it build and run. I have based my ebuild on 9999 version, i'm using git and 0.5.0 tag for it.
Comment 33 lamusic 2011-05-16 16:57:48 UTC
Created attachment 273463 [details]
deadbeef git ebuild tag version

It's using git-2 API of portage.
Comment 34 cyberbat 2011-05-16 19:07:31 UTC
(In reply to comment #31)
> If you use xwing overlay, I have bumped and redigest the ebuild to force the
> fetch : 0.5.0-r1 should build fine with use encode

Thanks! Compiled and started. But now it has cosmetic error: it can't find its icon. I got this message in konsole:
(deadbeef:26589): Gtk-WARNING **: Error loading icon from file '/deadbeef.png':

So I have no icon in tray and when I minimize it to tray, I can't restore it.
Comment 35 mailrupile 2011-05-16 19:16:24 UTC
There is no useflag "ffap" (for playing .APE) in x-wing's ebuilds\manifests\metadata
Comment 36 mailrupile 2011-05-16 19:19:51 UTC
Created attachment 273481 [details]
ebuild with ffap flag
Comment 37 mailrupile 2011-05-16 19:20:32 UTC
Created attachment 273483 [details]
metadata with ffap flag
Comment 38 Guillaume Castagnino 2011-05-16 19:26:19 UTC
(In reply to comment #35)
> There is no useflag "ffap" (for playing .APE) in x-wing's
> ebuilds\manifests\metadata

"ffap" is controlled by the global APE use flag called "mac". There is absolutely no change here comparing to previous releases attached to this bug... No need of some "ffap" use flag.



cyberbat > no icon problem here.
Icon is present in all possible ways :
# qlist deadbeef | grep icons
/usr/share/icons/hicolor/16x16/apps/deadbeef.png
/usr/share/icons/hicolor/128x128/apps/deadbeef.png
/usr/share/icons/hicolor/22x22/apps/deadbeef.png
/usr/share/icons/hicolor/192x192/apps/deadbeef.png
/usr/share/icons/hicolor/36x36/apps/deadbeef.png
/usr/share/icons/hicolor/24x24/apps/deadbeef.png
/usr/share/icons/hicolor/96x96/apps/deadbeef.png
/usr/share/icons/hicolor/72x72/apps/deadbeef.png
/usr/share/icons/hicolor/256x256/apps/deadbeef.png
/usr/share/icons/hicolor/scalable/apps/deadbeef.svg
/usr/share/icons/hicolor/64x64/apps/deadbeef.png
/usr/share/icons/hicolor/48x48/apps/deadbeef.png
/usr/share/icons/hicolor/32x32/apps/deadbeef.png

Have you tried some other gtk theme ?
Comment 39 cyberbat 2011-05-16 19:34:48 UTC
(In reply to comment #38)

> 
> cyberbat > no icon problem here.
> Icon is present in all possible ways :
> # qlist deadbeef | grep icons
> /usr/share/icons/hicolor/16x16/apps/deadbeef.png
> /usr/share/icons/hicolor/128x128/apps/deadbeef.png
> /usr/share/icons/hicolor/22x22/apps/deadbeef.png
> /usr/share/icons/hicolor/192x192/apps/deadbeef.png
> /usr/share/icons/hicolor/36x36/apps/deadbeef.png
> /usr/share/icons/hicolor/24x24/apps/deadbeef.png
> /usr/share/icons/hicolor/96x96/apps/deadbeef.png
> /usr/share/icons/hicolor/72x72/apps/deadbeef.png
> /usr/share/icons/hicolor/256x256/apps/deadbeef.png
> /usr/share/icons/hicolor/scalable/apps/deadbeef.svg
> /usr/share/icons/hicolor/64x64/apps/deadbeef.png
> /usr/share/icons/hicolor/48x48/apps/deadbeef.png
> /usr/share/icons/hicolor/32x32/apps/deadbeef.png
> 
> Have you tried some other gtk theme ?

# qlist deadbeef | grep icons
gives me same output. But I've forgot to say that I use KDE 4.6 with oxygen-gtk. I have try setting another gtk themes, but got the same icon problem.
Comment 40 Nick Novikov 2011-05-18 06:32:30 UTC
BTW, use flag "lastfm" should be replaced with global flag "scrobbler".
Comment 41 cyberbat 2011-05-22 19:24:01 UTC
media-sound/deadbeef-0.5.0-r1 from xwing failed compiling without dev-util/intltool because it requires it for building (DEPEND).
Comment 42 Viktor Yu. Kovalskii 2011-05-22 19:29:02 UTC
And why not use the ebuild from damex-overlay?

https://github.com/damex/damex-overlay
Comment 43 Guillaume Castagnino 2011-05-22 20:21:33 UTC
Created attachment 274317 [details]
deadbeef-0.5.1.ebuild

Ebuild bumped, fixed the missing intl dep when USE nls, add new option to depend either on imlib2 or on libjpeg/linpng for cover
Comment 44 cyberbat 2011-05-23 03:28:39 UTC
Created attachment 274355 [details]
build.log: emerge failed on compile state without intltool

Configure failed without intltool in the same way as in my previous comment (USE=nls).
virtual/libintl RDEPEND sys-devel/gettext
but deadbeef should DEPEND dev-util/intltool
Comment 45 cyberbat 2011-05-23 03:43:40 UTC
(In reply to comment #34)
> Thanks! Compiled and started. But now it has cosmetic error: it can't find its
> icon. I got this message in konsole:
> (deadbeef:26589): Gtk-WARNING **: Error loading icon from file '/deadbeef.png':
> 
> So I have no icon in tray and when I minimize it to tray, I can't restore it.

This issue was fixed in 0.5.1.
Comment 46 Guillaume Castagnino 2011-05-23 05:57:55 UTC
Created attachment 274361 [details]
deadbeef-0.5.1.ebuild

Added intltool dep
Comment 47 Jared B. 2011-05-23 18:53:41 UTC
(In reply to comment #45)
> (In reply to comment #34)
> > Thanks! Compiled and started. But now it has cosmetic error: it can't find its
> > icon. I got this message in konsole:
> > (deadbeef:26589): Gtk-WARNING **: Error loading icon from file '/deadbeef.png':
> > 
> > So I have no icon in tray and when I minimize it to tray, I can't restore it.
> 
> This issue was fixed in 0.5.1.

I still have this problem with 0.5.1, also with KDE and oxygen-gtk, but my error message sates:

(deadbeef:25919): Gtk-WARNING **: Error loading icon from file '/usr/deadbeef.png':
        Failed to open file '/usr/deadbeef.png': No such file or directory

No idea why it's trying to load the icon directly from /usr...
Comment 48 Guillaume Castagnino 2011-05-23 19:21:09 UTC
No problem here. using kde and oxygen-gtk too.

Have you tried cleaning your kdecache directory (/var/tmp/kdecache-$USER), then restarting your kde session ?
Comment 49 Yevgeny Filatov 2011-05-24 10:10:26 UTC
Created attachment 274465 [details]
deadbeef-0.5.1-r1.ebuild doc installation fixed

1. corrected doc files location
   "/usr/share/doc/deadbeef" -> "/usr/share/doc/${PF}".
   Fixed by "--docdir=/usr/share/doc/${PF}" configure option

2. doc files must not be compressed because it used in menu "help".
   Fixed by setting PORTAGE_COMPRESS="" in src_install()
Comment 50 Jared B. 2011-05-24 13:56:44 UTC
(In reply to comment #48)
> No problem here. using kde and oxygen-gtk too.
> 
> Have you tried cleaning your kdecache directory (/var/tmp/kdecache-$USER), then
> restarting your kde session ?

I just did.  No effect.  Being a GTK app, though, so I wouldn't think clearing my KDE cache would have any effect on where deadbeef itself looks for an icon.  Also, this is a fresh Gentoo install, with 0.5.1 being the only version of deadbeef installed on this box, so there shouldn't be any saved settings or cache issues there either.
Comment 51 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2011-05-24 14:20:50 UTC
Created attachment 274497 [details]
deadbeef-0.5.1-r1.ebuild, small fixes. latest.

Following Yevgeny Filatov work, new ebuild.

ChangeLog:
 * remove src_compile as portage will execute make on its own, no need to copy it.
 * proper way to not compress docs is PORTAGE_DOCOMPRESS_SKIP array.
Comment 52 mailrupile 2011-05-28 12:49:29 UTC
add "ffap" use flag to ebuild
Comment 53 Guillaume Castagnino 2011-05-28 17:00:21 UTC
(In reply to comment #52)
> add "ffap" use flag to ebuild

ffap (monkey audio support) is already managed by the more widely used "mac" USE flag
Comment 54 cyberbat 2011-07-19 05:49:25 UTC
deadbeef should DEPEND on pkgconfig, at least when USE=gtk. If there is not pkgconfig in the system (it's usual situation because no packages RDEPEND on it), deadbeef even with USE=gtk builds without GTK gui plugin, cause it's configure script uses pkgconfig to determine whether gtk is installed.
Comment 55 redneb 2011-09-16 06:22:21 UTC
I had the same problem with the icon, namely there was none. Following the suggestion from [1] I manually ran gtk-update-icon-cache & update-desktop-database and now everything is fine. Aren't ebuilds supposed to refresh the icon cache automatically?

[1] http://sourceforge.net/tracker/?func=detail&aid=3195817&group_id=272657&atid=1159087
Comment 56 Guillaume Castagnino 2011-09-16 09:46:58 UTC
Created attachment 286649 [details]
deadbeef-0.5.1-r3.ebuild

Simply inherit the gnom2 eclass do this.
Here is an updated ebuild
Comment 57 cyberbat 2011-12-14 08:54:26 UTC
deadbeef should depend on virtual/ffmpeg not media-video/ffmpeg. See #358919
Comment 58 cyberbat 2011-12-14 10:31:41 UTC
Created attachment 295791 [details]
ebuild and patch with virtual/ffmpeg depend

Ebuild and patch from gentoo-zh overlay to make deadbeef depend on virtual/ffmpeg and compile with libav.
Comment 59 Opportunist 2012-03-24 12:06:53 UTC
DeaDBeeF 0.5.2 is out

a lot of cool changes!

http://deadbeef.sourceforge.net/posts/deadbeef_0.5.2_is_out.html
Comment 60 Opportunist 2012-06-12 12:44:43 UTC
deadbeef 0.5.5 available :)

http://deadbeef.sourceforge.net/posts/deadbeef_0.5.5_is_out.html
Comment 61 Viktor Yu. Kovalskii 2012-06-30 06:36:19 UTC
I'm afraid but deadbeef can't be placed in tree.

Author;s quote from mail-list:

> deadbeef source tree contains forks of 16 different libraries, and won't even
> compile against upstream versions.
..
> i've been contacted by maintainers from Gentoo, Debian and Fedora (at
> least) regarding this problem, and there's no way to solve it.
> everyone wants me to link to upstream/distro versions, but that won't happen.

http://sourceforge.net/mailarchive/message.php?msg_id=27544837
Comment 62 Opportunist 2012-10-23 09:43:00 UTC
DeaDBeeF 0.5.6 is out!

wavpack: fixed reload_metadata not clearing old data
sndfile: fixed big/little endian byte swap buffer overrun
gme: fixed loopcount bugs
alsa: fixed race condition bug leading to freezes
alac: added new ALAC plugin with proper gapless playback support and other goods
aac: lots of bugfixes and improvements, as usual, including half/double duration bugfix, and custom metadata fields support, and audiobook chapters
cue and m3u parsers can now skip utf8 BOM
automatically fill new/edited column title from the selected column type
removed the frame widget around playlist to make scroll bar more accessible in maximized windows
restored old GDK drawing in GTK2 plugin, because cairo produces weird shit on older GTK2 versions -- that means, tabs and playlist now look correct again with gtk2.20 and below
gtk3 compiling is now enabled by default, if gtk3 sdk is installed
--enable/disable-gtkui configure option is removed, now there are only --enable/disable-gtk2 and --enable/disable-gtk3
added Menu key support
always auto-name playlist by folder name when empty, even if the playlist title is non-default
insert/delete key support in track properties (Ruslan Khusnullin)
fixed Enter and Esc keys in track properties
fixed playlist column auto-resizing in maximized window
added user-agent configuration for last.fm, vfs_curl, etc
added cp936 charset detection support. it breaks cp1251 detection, so it's done as an option -- look in the preferences (Joey Zheng)
show blank instead of "?" when a metadata field is absent
fixed local album cover files search order, it's alphabetical now
alsa: added a hack/work-around to prevent releasing sound device when a user switches between tracks
m3u: improved handling of relative file pathes
converter: fixed handling "/" in filenames; fixed tag-writing to files which have special characters
fixed resuming last session in shuffle albums mode
fixed several libmms freeze/hang/crash bugs
vorbis: update waveformat dynamically, so now it's possible to listen the radios which switch between mono and stereo dynamically
mp3: fixed samplerate shown in the track properties
added work-around for unsupported channel masks to wavpack and sndfile plugins
fixed notification cover-art loading for tracks with empty album
Comment 63 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-14 22:44:30 UTC
*** Bug 452086 has been marked as a duplicate of this bug. ***
Comment 64 Serge Gavrilov 2013-11-25 16:33:00 UTC
DeaDBeeF 0.6.0 is out
Comment 65 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2015-05-02 10:34:00 UTC
It has been quite a while. How about actually adding deadbeef to portage? This is not something that adding would result in destruction of the whole world or anything, harmless ebuild with a great software.
Comment 66 vlaomao 2015-09-01 07:10:29 UTC
WTF? Why still not added?
Comment 67 Nikoli 2015-09-01 09:33:10 UTC
Did you notice that bug is assigned to maintainer-wanted@gentoo.org ?

If someone will agree to maintain or proxy maintain this package and will provide good ebuilds, then it most likely will be added quickly ;)
https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers
Comment 68 selurvedu 2015-09-01 14:56:45 UTC
(In reply to Nikoli from comment #67)
> Did you notice that bug is assigned to maintainer-wanted@gentoo.org ?
> 
> If someone will agree to maintain or proxy maintain this package and will
> provide good ebuilds, then it most likely will be added quickly ;)
> https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers

Okay, but how about this? https://bugs.gentoo.org/show_bug.cgi?id=301349#c61
Comment 69 Alex Efros 2017-08-31 23:08:47 UTC
I've just built and successfully run 0.7.2 simple by renaming deadbeef-0.5.1-r3.ebuild.
Comment 70 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-05-24 22:16:10 UTC
Can never be added to the main tree, asked upstrram recently, they still bundle lots of libs and link it statically.