Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 300484 - dev-lang/python-2.6.4 fails to crosscompile for arm
Summary: dev-lang/python-2.6.4 fails to crosscompile for arm
Status: VERIFIED DUPLICATE of bug 269111
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: ARM Linux
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-10 21:08 UTC by Oleh Kravchenko
Modified: 2010-10-27 13:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
armemerge --info (emerge.info,3.43 KB, text/plain)
2010-01-10 21:09 UTC, Oleh Kravchenko
Details
build.log (build.log,173.55 KB, text/plain)
2010-01-11 18:19 UTC, Oleh Kravchenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleh Kravchenko 2010-01-10 21:08:18 UTC
Error when cross compiling python for arm

changing mode of build/scripts-2.6/pydoc from 644 to 755
changing mode of build/scripts-2.6/idle from 644 to 755
changing mode of build/scripts-2.6/2to3 from 644 to 755
changing mode of build/scripts-2.6/smtpd.py from 644 to 755
make: *** [sharedmods] Error 1


Reproducible: Always
Comment 1 Oleh Kravchenko 2010-01-10 21:09:21 UTC
Created attachment 216032 [details]
armemerge --info
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-01-11 17:44:04 UTC
Attach whole build log and reopen this bug.
Comment 3 Oleh Kravchenko 2010-01-11 18:19:26 UTC
Created attachment 216099 [details]
build.log
Comment 4 Oleh Kravchenko 2010-01-11 18:19:50 UTC
(In reply to comment #2)
> Attach whole build log and reopen this bug.
> 

Attached build.log
Comment 5 Wormo (RETIRED) gentoo-dev 2010-02-13 08:13:45 UTC
This is the same problem as in bug #269111, where the extensions need to build against cross-toolchain headers not system headers.
Comment 6 Dirkjan Ochtman gentoo-dev 2010-10-27 12:17:09 UTC

*** This bug has been marked as a duplicate of bug 269111 ***