Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 299485 - ehci-driver cannot handle devices with different speed for certain kernel-configurations (error: reset low/full speed USB device using ehci_hcd and address N)
Summary: ehci-driver cannot handle devices with different speed for certain kernel-con...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Whiteboard: linux-2.6.31,linux-2.6.32
Depends on:
Reported: 2010-01-03 15:16 UTC by koenigrollo
Modified: 2010-09-25 00:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

dmesg (dmesg,29.66 KB, text/plain)
2010-01-03 15:18 UTC, koenigrollo
config kernel (config_kernel,43.94 KB, text/plain)
2010-01-03 15:18 UTC, koenigrollo
messages-log extract (messages_extract,3.14 KB, text/plain)
2010-01-03 15:19 UTC, koenigrollo
dmesg of Knoppix (dmesg_knoppix,15.28 KB, text/plain)
2010-01-19 00:03 UTC, koenigrollo
xorg-log of Knoppix (Xorg.0.log.knoppix,15.65 KB, text/plain)
2010-01-19 00:04 UTC, koenigrollo
xorg-conf of Gentoo-64-bit with /dev/input/by-* as device for the USB-mouse (xorg.conf_withDevInputBy,2.08 KB, text/plain)
2010-01-19 00:05 UTC, koenigrollo
xorg-log of Gentoo-64-bit with /dev/input/by-* as device for the USB-mouse (Xorg.0.log_withDevInputBy,27.15 KB, text/plain)
2010-01-19 00:06 UTC, koenigrollo
Knoppix kernel config (config_kernel_knoppix,97.70 KB, text/plain)
2010-03-22 00:41 UTC, koenigrollo

Note You need to log in before you can comment on or make changes to this bug.
Description koenigrollo 2010-01-03 15:16:33 UTC
I did a fresh installation on my new desktop PC (AMD64). As input devices I have a USB-keyboard and a USB-mouse but at the X-start (KDE) only the keyboard works. 

Maybe of note, first I thought that it is a X-issue. Mouse and keyboard are detected by HAL and use the evdev-driver. HAL configures the USB-mouse as mouse and as keyboard but on other machines, where I have no problems, it's the same. 

From the messages-log:
reset full speed USB device using ehci_hcd and address N
This line repeats 3 times per second.

If I plug off the keyboard then the mouse works. When I plug in the keyboard again, the mouse still works but the keyboard not.
From the messages-log:
reset low speed USB device using ehci_hcd and address N
This line repeats every 6 seconds.

That means that I cannot use simultaneously both input devices on the same USB hub. But my motherboard have a second hub for the front panel. If I split the devices, one on the rear hub and the other on the front hub, I can use both simultaneously. 

In the internet I found the same error message most for USB storage devices like bug #177266 . But whose solutions don't work in my case. I also play around with the timer frequency (CONFIG_HZ) and preemption as mentioned
here but without success. I also test different kernels: 2.6.30-r8,  2.6.31-r6 and 2.6.32-r1.

I guess that it's either a ehci-driver issue for AMD64 or a misconfiguration of my kernel. I can exclude a hardware issue because mouse and keyboard on the same USB controller works fine with Windows 7 (64-bit) and Knoppix 6.2 (32-bit).
On my laptop with Gentoo (32-bit, 2.6.31-r6) I have also no problem to use mouse and keyboard simultaneously.

Reproducible: Always

Portage (default/linux/amd64/10.0/no-multilib, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.31-gentoo-r6 x86_64)
System uname: Linux-2.6.31-gentoo-r6-x86_64-Intel-R-_Core-TM-_i5_CPU_750_@_2.67GHz-with-gentoo-1.12.13             
Timestamp of tree: Sun, 03 Jan 2010 02:30:24 +0000                                                                 
app-shells/bash:     4.0_p35                                                                                       
dev-java/java-config: 2.1.9-r2                                                                                     
dev-lang/python:     2.6.4                                                                                         
dev-util/cmake:      2.6.4-r3                                                                                      
sys-apps/baselayout: 1.12.13                                                                                       
sys-apps/sandbox:    1.6-r2                                                                                        
sys-devel/autoconf:  2.13, 2.63-r1                                                                                 
sys-devel/automake:  1.9.6-r2, 1.10.2                                                                              
sys-devel/binutils:  2.18-r3                                                                                       
sys-devel/gcc-config: 1.4.1                                                                                        
sys-devel/libtool:   2.2.6b                                                                                        
virtual/os-headers:  2.6.27-r2                                                                                     
CFLAGS="-O2 -march=core2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -pipe"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aac alsa amd64 bash-completion berkdb bzip2 cli cracklib crypt cups curl cxx dbus dri encode flac fortran gdbm gpm hal iconv imagemagick ipv6 jpeg jpeg2k kde mmx mng modules mp3 mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre perl pppd python qt3 qt3support qt4 readline reflection sdl session speex spl sse sse2 ssl sysfs tcpd theora truetype unicode vcd vorbis x264 xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx radeonhd vesa"
Comment 1 koenigrollo 2010-01-03 15:18:09 UTC
Created attachment 215023 [details]
Comment 2 koenigrollo 2010-01-03 15:18:59 UTC
Created attachment 215025 [details]
config kernel
Comment 3 koenigrollo 2010-01-03 15:19:25 UTC
Created attachment 215027 [details]
messages-log extract
Comment 4 Mike Pagano gentoo-dev 2010-01-04 01:28:06 UTC
Can you try booting with kernel parameter: noapic or irqpoll.

Is your bios up to date?

Comment 5 koenigrollo 2010-01-04 23:31:10 UTC
Actually a bios update cannot be the solution because with Knoppix 6.2 everything works. Nevertheless, before I wrote this bug report, I updated the bios to the latest version.

Currently I switch to a 32-bit system. The old 64-bit system was saved by partimage. I used the old kernel configuration for the new system. But also with this system I observe the same USB-issue.
I guess my kernel configuration is wrong.

No improvement with kernel parameter noapic. Finally I tried noapic, acpi=off and irqpoll together but also with the same result.

Just a note, I'm away for 2 weeks. 
Comment 6 George Kadianakis (RETIRED) gentoo-dev 2010-01-11 18:35:09 UTC
Could you play around in /dev/ [1] and try to figure out if your mouse creates a keyboard device node as well?

By the way, if I understand correctly, you haven't managed using your keyboard and your mouse simultaneously in a 64-bit architecture. If that is so, can you post us the dmesg of a 32-bit Knoppix?

[1]: Try /dev/input/by-*
Comment 7 koenigrollo 2010-01-19 00:02:58 UTC
Just to clarify, I cannot use keyboard and mouse simultaneously on the same USB-controller with both Gentoo-32-bit and Gentoo-64-bit but with Knoppix everything is fine.

Do you mean with "Try /dev/input/by-*" that I should test that as device in the xorg.conf?
Comment 8 koenigrollo 2010-01-19 00:03:47 UTC
Created attachment 216857 [details]
dmesg of Knoppix
Comment 9 koenigrollo 2010-01-19 00:04:42 UTC
Created attachment 216858 [details]
xorg-log of Knoppix
Comment 10 koenigrollo 2010-01-19 00:05:51 UTC
Created attachment 216859 [details]
xorg-conf of Gentoo-64-bit with /dev/input/by-* as device for the USB-mouse
Comment 11 koenigrollo 2010-01-19 00:06:40 UTC
Created attachment 216861 [details]
xorg-log of Gentoo-64-bit with /dev/input/by-* as device for the USB-mouse
Comment 12 Mike Pagano gentoo-dev 2010-02-18 01:35:08 UTC
When you boot into knoppix, is ther a /proc/config.gz file?

Can you attach it here please uncompressed.
Comment 13 koenigrollo 2010-03-22 00:41:42 UTC
Created attachment 224611 [details]
Knoppix kernel config

For knoppix no /proc/config.gz is available but there is a .config in /usr/src/linux-headers.
Comment 14 Mike Pagano gentoo-dev 2010-04-25 12:36:54 UTC
Please enable CONFIG_USB_EHCI_TT_NEWSCHED on your gentoo kernel and let me know how it goes.

Comment 15 koenigrollo 2010-09-25 00:51:44 UTC
CONFIG_USB_EHCI_TT_NEWSCHED solves the problem.
Bug can be closed.