Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 299300 - mail-filter/spamassassin maybe considering 2010 e-mails spammy.
Summary: mail-filter/spamassassin maybe considering 2010 e-mails spammy.
Status: RESOLVED DUPLICATE of bug 299256
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://it.slashdot.org/story/10/01/02...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-02 03:28 UTC by Philippe Chaintreuil
Modified: 2010-01-02 03:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Chaintreuil 2010-01-02 03:28:40 UTC
I guess someone hard-coded 2010 and beyond as spammy.

See this Slashdot entry for details: http://it.slashdot.org/story/10/01/02/0027207/SpamAssassin-2010-Bug

The "fix" (a punt for a decade really) is to change it to 2020 by changing /usr/share/spamassassin/72_active.cf:

1) search 'FH_DATE_PAST_20XX'
2) change '/20[1-9][0-9]/' to '/20[2-9][0-9]/'

We may wish to make a patch and get it out fast.



Reproducible: Always




SA bug report: https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6269
Another page: https://secure.grepular.com/blog/index.php/2010/01/01/spamassassin-2010-bug/

I set this as "MAJOR" because it adds 3.4 to the spammy scores, which is pretty darn high.
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-01-02 03:31:17 UTC
The fix is to sa-update or use 3.2.1-r2 :)

*** This bug has been marked as a duplicate of bug 299256 ***