Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 299200 - app-office/openoffice-bin-3.1.1 base can not conect to mail-client/evolution-2.26.3 adressbook
Summary: app-office/openoffice-bin-3.1.1 base can not conect to mail-client/evolution-...
Status: RESOLVED DUPLICATE of bug 361695
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-01 13:36 UTC by Kai Wüstermann
Modified: 2011-07-27 12:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Wüstermann 2010-01-01 13:36:20 UTC
If I want to create a new Address Database in OpenOffice-bin-3.1.1 using the "Adressdatenquelle-Assistent" there is no way to connect to the Evolution addressbook. 

I just compilied app-office/openoffice-3.1.1 there you can choose the Evolution Adressbook. But you get in trouble with templates. (http://bugs.gentoo.org/show_bug.cgi?id=283687).

So I changed back to app-office/openoffice-bin-3.1.1. Now I can see the datbase by pressing F4 in OpenOffice writer. If I click on tables (Tabellen) I get an error message:

"Die Verbindung zur Datenquelle "Adressen" konnte nicht hergestellt werden.
Die Verbindung zur externen Datenquelle konnte nicht hergestellt werden. Es wurde kein SDBC-Treiber für die angegebene URL gefunden."

At the botton "Zusätze" I can see 3 more Error messages:
"Die Verbindung zur Datenquelle "Adressen" konnte nicht hergestellt werden."

"SQL-Status: HY000
Die Verbindung zur externen Datenquelle konnte nicht hergestellt werden. Es wurde kein SDBC-Treiber für die angegebene URL gefunden."

"A connection for the following URL was requested: sdbc:address:evolution:local"

Reproducible: Always

Steps to Reproduce:
see above



Evolution-Data-Server is working.

There is a library for evolution: /usr/lib/openoffice/basis3.1/program
Comment 1 C W Rose 2010-02-16 17:30:01 UTC
I can confirm this one; I've just spent an afternoon
re-installing openoffice-bin and trying to get the
evolution connection to work again.

Does anyone know what the openoffice-bin build flags
are, vs. the full package?

Will
Comment 2 Kai Wüstermann 2010-02-17 12:32:44 UTC
(In reply to comment #1)

> Does anyone know what the openoffice-bin build flags
> are, vs. the full package?

eix openoffice
* app-office/openoffice
     Available versions:  3.1.1 {aqua bash-completion binfilter cups dbus debug eds elibc_FreeBSD gnome gstreamer gtk java kde kdeenablefinal ldap linguas_af linguas_ar linguas_as_IN ......

[I] app-office/openoffice-bin
     Available versions:  3.1.1!s ~3.2.0!s {gnome java kde linguas_af linguas_ar linguas_as linguas_as_IN .....
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2011-07-27 12:09:35 UTC
This aint easy to fix. Duping this against the rework as with rpms there is nothing we can do to fix it.

*** This bug has been marked as a duplicate of bug 361695 ***