Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 298753 - net-analyzer/rrdtool - src_configure() hangs at: configure:19935: checking if msync with MS_ASYNC updates the files mtime
Summary: net-analyzer/rrdtool - src_configure() hangs at: configure:19935: checking if...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 369613 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-28 18:34 UTC by svrmarty
Modified: 2020-04-25 11:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,94.99 KB, text/plain)
2009-12-28 18:35 UTC, svrmarty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description svrmarty 2009-12-28 18:34:45 UTC
when i try to re-emerge rrdtool-1.3.8, configure waits forever

configure:19930: result: Resolve Portability Issues
configure:19935: checking if msync with MS_ASYNC updates the files mtime
configure:20020: i686-pc-linux-gnu-gcc -o conftest -march=pentium-m -O3 -pipe -fomit-frame-pointer -funroll-loops -D_GNU_SOURCE -fno-strict-aliasing -Wall -std=c99 -pedantic -Wundef -Wshadow -Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wold-style-definition -W  -fPIC -DPIC  -Wl,-O1 conftest.c -lm  >&5
conftest.c: In function 'main':
conftest.c:118: warning: ignoring return value of 'write', declared with attribute warn_unused_result
configure:20024: $? = 0
configure:20030: ./conftest


Portage 2.1.6.13 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.32 i686)
=================================================================
System uname: Linux-2.6.32-i686-Intel-R-_Pentium-R-_M_processor_1.73GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 25 Dec 2009 15:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 1.3.7-r1, 2.1.9-r2
dev-lang/python:     2.5.4-r3, 2.6.4
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.3
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O3 -pipe -fomit-frame-pointer -funroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb /var/www/localhost/htdocs//mythweb/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O3 -pipe -fomit-frame-pointer -funroll-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache cvs distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/gentoo-x86"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amr apache2 asf async audit authdaemond berkdb bzip2 calendar cdda cddb cgi cli consolekit cracklib crciprec crypt ctype curl cxx dbus de_tvtoday dga directfb diskio divx dri dts dv dvb dvd eds encode esd exif fam ffmpeg firefox flac flash font-server fortran ftp gd gdbm ggi gif gmedia gmp gnome gnutls gpm graphviz gtk h323 hal hash httpd iconv id3 id3tag idn imagemagick imap imlib innodb jack java jikes jpeg ldap libass libcaca libnotify live lm_sensors logrotate lua lzo mad maildir matroska mcal mfd-rewrites mhash mikmod milter ming mjpeg mmx mng modplug modules motif mp3 mpeg mudflap musepack mysql mythtv nagios-dns nagios-ntp nagios-ping nagios-ssh nas ncurses network nls nptl nptlonly nsplugin nvidia ogg opengl openmp oss pam pcre perl php png postgres pppd pvr pwdb python pyzord quicktime readline realmedia reflection remoteosd rtsp samba sample sasl sdl sdl-image sendmail session sharedmem simplexml slang smux snmp soap sockets speex spl sqlite sse sse2 ssl stream svg svga sysfs tcltk tcpd theora tiff tools truetype unicode upnp usb v4l v4l2 vcd vidix virus-scan vlm vorbis win32codecs wmp x264 x86 xcomposite xext xinerama xml xml2 xmlreader xmlrpc xmlwriter xorg xrandr xsl xv xvid xvmc yp zip zlib zvbi" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="i810 fbdev v4l vesa vga intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 svrmarty 2009-12-28 18:35:32 UTC
Created attachment 214468 [details]
config.log
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2010-01-13 19:48:23 UTC
Can you consistently reproduce the issue? If yes, then could you please try with ccache disabled?
Comment 3 Peter Volkov (RETIRED) gentoo-dev 2010-05-24 12:48:14 UTC
svrmarty, please, answer Comment #2.
Comment 4 Richard Musil 2010-08-02 18:30:29 UTC
I can confirm the bug on my setup (below). The build hangs on message:

checking if msync with MS_ASYNC updates the files mtime...

I have tried to switch off ccache and confcache => no change.

My setup has also:
tmpfs on /var/tmp/portage type tmpfs (rw,size=2G,mode=01777)

----------------
Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34 x86_64)
=================================================================
System uname: Linux-2.6.34-x86_64-Intel-R-_Core-TM-_i3_CPU_530_@_2.93GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 02 Aug 2010 04:15:03 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://gentoo.mirror.web4u.cz/ "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acpi amd64 apache2 berkdb bzip2 cli cracklib crypt cxx fam gdbm gpm iconv iproute2 lm_sensors mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl python readline reflection session snmp spl sse sse2 ssl sysfs tcpd unicode vim-syntax zlib" ALSA_CARDS="hda-intel" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 5 Richard Musil 2010-08-02 18:37:07 UTC
I can answer myself.

It seems that putting 'MAKEOPTS="-j1"' into make.conf solves this issue.
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2011-06-01 15:20:27 UTC
(In reply to comment #5)
> I can answer myself.
> 
> It seems that putting 'MAKEOPTS="-j1"' into make.conf solves this issue.

MAKEOPTS should not affect configure at all. I guess you were seeing a race condition of some sort before and simply didn't see it the last time.
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2011-06-01 15:20:37 UTC
*** Bug 369613 has been marked as a duplicate of this bug. ***
Comment 8 Larry the Git Cow gentoo-dev 2020-04-25 11:29:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=89c056bd2ad8e39d447611d328946f811d6ccd9f

commit 89c056bd2ad8e39d447611d328946f811d6ccd9f
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2020-04-25 11:28:55 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2020-04-25 11:29:33 +0000

    net-analyzer/rrdtool: Skip msync test that relies on host behaviour
    
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Closes: https://bugs.gentoo.org/298753
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 net-analyzer/rrdtool/rrdtool-1.7.2.ebuild | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)