Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 297361 - media-plugins/vdr-cdda: fails to build with glibc-2.10
Summary: media-plugins/vdr-cdda: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-12-17 23:16 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-12-23 21:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (vdr-cdda-0.1.0-r1:20091217-212445.log,11.54 KB, text/plain)
2009-12-17 23:20 UTC, Diego Elio Pettenò (RETIRED)
Details
adding patch to ebuild (vdr-cdda-0.1.0-r1.diff,331 bytes, patch)
2009-12-22 20:55 UTC, Kacper Kowalik (Xarthisius) (RETIRED)
Details | Diff
fixing gcc 4.4 issue (vdr-cdda-0.1.0-gcc-4.4.patch,530 bytes, patch)
2009-12-22 20:56 UTC, Kacper Kowalik (Xarthisius) (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-12-17 23:16:50 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-12-17 23:20:00 UTC
Created attachment 213360 [details]
Build log
Comment 2 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2009-12-22 20:55:39 UTC
Created attachment 213807 [details, diff]
adding patch to ebuild
Comment 3 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2009-12-22 20:56:06 UTC
Created attachment 213808 [details, diff]
fixing gcc 4.4 issue
Comment 4 Joerg Bornkessel gentoo-dev 2009-12-23 21:13:14 UTC
fixed in the tree; 

Kapcer, thanks for the patch