Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 297193 - sci-biology/ncbi-tools++: fails with forced --as-needed and disrespecting as-needed in LDFLAGS
Summary: sci-biology/ncbi-tools++: fails with forced --as-needed and disrespecting as-...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Andrey Kislyuk (RETIRED)
Depends on:
Blocks: as-needed
  Show dependency tree
Reported: 2009-12-16 17:56 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2011-05-04 19:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

Build log (ncbi-tools++-2009.05.15-r1:20091216-140440.log,303.29 KB, text/plain)
2009-12-16 17:56 UTC, Diego Elio Pettenò (RETIRED)
adding patch to ebuild (ncbi-tools++-2009.05.15-r1.diff,353 bytes, patch)
2010-02-05 21:47 UTC, Kacper Kowalik (Xarthisius) (RETIRED)
Details | Diff
fixing as-needed issues (ncbi-tools++-2009.05.15-as-needed.patch,5.19 KB, patch)
2010-02-05 21:48 UTC, Kacper Kowalik (Xarthisius) (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-12-16 17:56:04 UTC
I'm reporting this bug because the package in summary fails to build when forcing --as-needed on through spec files (check out for details).

Please note that this bug _might_ apply to -Wl,--as-needed in LDFLAGS as well; in both cases it should be fixed. Also, if this is due to the package in question not respecting user-defined LDFLAGS, you should get to fix that too.

Check the attached build log.

Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-12-16 17:56:24 UTC
Created attachment 213217 [details]
Build log
Comment 2 Andrey Kislyuk (RETIRED) gentoo-dev 2009-12-29 03:35:21 UTC
I would appreciate help on this, since I don't know how to go about fixing this in this package.
Comment 3 Justin Lecher (RETIRED) gentoo-dev 2009-12-29 12:20:02 UTC
That really a nasty build system. has to additionally linked against -lxncbi.

I don't know if that is everything, but will be a starting point. But I cannot find the the linking lines in the makefiles.
Comment 4 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-02-05 21:47:21 UTC
Created attachment 218585 [details, diff]
adding patch to ebuild
Comment 5 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-02-05 21:48:16 UTC
Created attachment 218587 [details, diff]
fixing as-needed issues
Comment 6 Justin Lecher (RETIRED) gentoo-dev 2010-06-26 11:05:17 UTC
+*ncbi-tools++-2009.05.15-r6 (26 Jun 2010)
+  26 Jun 2010; Justin Lecher <>
+  -ncbi-tools++-2009.05.15-r5.ebuild, +ncbi-tools++-2009.05.15-r6.ebuild,
+  +files/ncbi-tools++-2009.05.15-asneeded.patch:
+  Fixed as-needed problem
Comment 7 Justin Lecher (RETIRED) gentoo-dev 2010-09-27 07:13:28 UTC
Still not solved:

ccache /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++  -c  -Wall -Wno-format-y2k  -pthread -O2 -pipe -march=core2 -frecord-gcc-switches -mssse3 -mcx16 -mmmx -g -Wmissing-include-dirs -Wenum-compare -fPIC  -DNDEBUG -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -D_MT -D_REENTRANT -D_THREAD_SAFE -I/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/inc -I/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/include     /var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/src/util/test/test_compress.cpp -o test_compress.o 
/usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++  -pthread -Wl,-O1 -Wl,-O1,--hash-style=gnu,--sort-common -O -Wl,-E  test_compress.o   -Wl,-rpath,/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/image//usr/lib64/ncbi-tools++ -Wl,-rpath-link,/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib -L/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib -lxutil -lxcompress -lxncbi -lz  -lbz2  -llzo2  -lrt -lm  -lpthread -o test_compress 
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib/ undefined reference to `ncbi::CByteSourceReader::Seekg(std::fpos<__mbstate_t>)'
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib/ undefined reference to `ncbi::CByteSourceReader::SubSource(unsigned long, ncbi::CRef<ncbi::CSubSourceCollector, ncbi::CObjectCounterLocker>)'
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib/ undefined reference to `ncbi::CByteSourceReader::CByteSourceReader()'
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib/ undefined reference to `ncbi::CByteSourceReader::Pushback(char const*, unsigned long)'
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib/ undefined reference to `ncbi::CByteSourceReader::EndOfData() const'
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib/ undefined reference to `typeinfo for ncbi::CByteSourceReader'
/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/lib/ undefined reference to `ncbi::CByteSourceReader::~CByteSourceReader()'
collect2: ld returned 1 exit status
make[7]: *** [test_compress] Error 1
make[7]: Leaving directory `/var/tmp/portage/sci-biology/ncbi-tools++-2010.06.15/work/ncbi_cxx--Jun_15_2010/GCC444-ReleaseMTDLL64/build/util/test'
Comment 8 Justin Lecher (RETIRED) gentoo-dev 2011-05-04 19:06:32 UTC
+*ncbi-tools++-2010.06.15-r1 (04 May 2011)
+  04 May 2011; Justin Lecher <>
+  -ncbi-tools++-2009.05.15-r6.ebuild, ncbi-tools++-2010.06.15.ebuild,
+  +ncbi-tools++-2010.06.15-r1.ebuild,
+  +files/ncbi-tools++-2010.06.15-asneeded.patch,
+  +files/ncbi-tools++-2010.06.15-asneeded-ng.patch:
+  Fix for asneeded, #297193; removed old, #312921