Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296586 - xkeyboard-config-1.7 "econf failed"
Summary: xkeyboard-config-1.7 "econf failed"
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-12 06:02 UTC by Jeff
Modified: 2009-12-13 01:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/x11-misc/xkeyboard-config-1.7/work/xkeyboard-config-1.7/config.log (config.log,15.04 KB, text/plain)
2009-12-12 06:05 UTC, Jeff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff 2009-12-12 06:02:37 UTC
* 
 * ERROR: x11-misc/xkeyboard-config-1.7 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 2783:  Called econf '--with-xkb-base=/usr/share/X11/xkb' '--enable-compat-rules' '--disable-xkbcomp-symlink' '--with-xkb-rules-symlink=xorg'
 *               ebuild.sh, line  534:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 *  The die message:
 *   econf failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-misc/xkeyboard-config-1.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/xkeyboard-config-1.7/temp/environment'.
 * 



Reproducible: Always

Steps to Reproduce:
1.[ebuild     U ] x11-misc/xkeyboard-config-1.7 [1.6]
Actual Results:  
failed to emerge

Expected Results:  
emerge should go through

Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.31-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-r6-x86_64-AMD_Athlon-tm-_64_Processor_3700+-with-gentoo-1.12.13
Timestamp of tree: Sat, 12 Dec 2009 05:00:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.4
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.6.3, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi alsa amd64 apache2 apm auctex berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dga divx dri dts dvd dvdr dvdread emacs emboss encode evo fam ffmpeg firefox flac fortran gdbm gif git gmedia gpm graphviz gstreamer gtk hal hfsplus iconv ipod ipv6 java jpeg latex ldap libnotify mad mikmod modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline realmedia reflection sdl session spell spl ssl startup-notification svg symlink sysfs tcpd tetex theora thunar tiff truetype unicode usb vorbis wmp x264 xfce xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeff 2009-12-12 06:05:57 UTC
Created attachment 212763 [details]
/var/tmp/portage/x11-misc/xkeyboard-config-1.7/work/xkeyboard-config-1.7/config.log
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-12-12 07:15:20 UTC
> configure:4144: error: XML::Parser perl module is required for intltool

Try to remerge dev-perl/XML-Parser. If I recall, this is a silly bug with perl.
Comment 3 Jeff 2009-12-13 01:23:55 UTC
(In reply to comment #2)
> > configure:4144: error: XML::Parser perl module is required for intltool
> 
> Try to remerge dev-perl/XML-Parser. If I recall, this is a silly bug with perl.
> 

XML-Parser was already installed, but I remerged it and then everything installed fine. Is this a bug with XML-Parser or with xkeyboard?