Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296407 (CVE-2009-3794) - <www-plugins/adobe-flash-10.0.42.34: APSB09-19 vulnerabilities (CVE-2009-{3794,3796,3797,3798,3799,3800})
Summary: <www-plugins/adobe-flash-10.0.42.34: APSB09-19 vulnerabilities (CVE-2009-{379...
Status: RESOLVED FIXED
Alias: CVE-2009-3794
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Security
URL: http://www.adobe.com/support/security...
Whiteboard: A2 [glsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-10 15:02 UTC by Greg Hasseler
Modified: 2010-01-03 18:24 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Hasseler 2009-12-10 15:02:05 UTC
Adobe has released APSB09-19, which recommends updating to adobe-flash-10.0.42.34 or greater. APSB09-19 contains fixes for several cross-platform critical flaws, as well as a few platform specific ones. All flaws fixed by APSB09-19 are listed below:

From Adobe:
Critical vulnerabilities have been identified in Adobe Flash Player version 10.0.32.18 and earlier.  These vulnerabilities could cause the application to crash and could potentially allow an attacker to take control of the affected system.

Adobe recommends users of Adobe Flash Player 10.0.32.18 and earlier versions update to Adobe Flash Player 10.0.42.34.  Adobe recommends users of Adobe AIR version 1.5.2 and earlier versions update to Adobe AIR 1.5.3.

This update resolves a vulnerability in the parsing of JPEG data that could potentially lead to code execution (CVE-2009-3794).

This update resolves a data injection vulnerability that could potentially lead to code execution (CVE-2009-3796).

This update resolves a memory corruption vulnerability that could potentially lead to code execution (CVE-2009-3797).

This update resolves a memory corruption vulnerability that could potentially lead to code execution (CVE-2009-3798).

This update resolves an integer overflow vulnerability that could potentially lead to code execution (CVE-2009-3799).

This update resolves multiple crash vulnerabilities that could potentially lead to code execution (CVE-2009-3800).

This update resolves a Windows-only local file name access vulnerability in the  Flash Player ActiveX control that could potentially lead to information disclosure (CVE-2009-3951). This updates the previously patched issue, CVE-2008-4820.
Comment 1 Stefan Behte (RETIRED) gentoo-dev Security 2009-12-18 01:08:46 UTC
Lack, can we stabilize 10.0.42.34?
Comment 2 Stefan Behte (RETIRED) gentoo-dev Security 2009-12-18 01:29:06 UTC
CVE-2009-3794 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3794):
  Heap-based buffer overflow in Adobe Flash Player before 10.0.42.34
  and Adobe AIR before 1.5.3 allows remote attackers to execute
  arbitrary code via crafted dimensions of JPEG data in an SWF file.

CVE-2009-3796 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3796):
  Adobe Flash Player before 10.0.42.34 and Adobe AIR before 1.5.3 might
  allow attackers to execute arbitrary code via unspecified vectors,
  related to a "data injection vulnerability."

CVE-2009-3797 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3797):
  Adobe Flash Player 10.x before 10.0.42.34 and Adobe AIR before 1.5.3
  might allow attackers to execute arbitrary code via unspecified
  vectors that trigger memory corruption.

CVE-2009-3798 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3798):
  Adobe Flash Player before 10.0.42.34 and Adobe AIR before 1.5.3 might
  allow attackers to execute arbitrary code via unspecified vectors
  that trigger memory corruption.

CVE-2009-3799 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3799):
  Integer overflow in the Verifier::parseExceptionHandlers function in
  Adobe Flash Player before 10.0.42.34 and Adobe AIR before 1.5.3
  allows remote attackers to execute arbitrary code via an SWF file
  with a large exception_count value that triggers memory corruption,
  related to "generation of ActionScript exception handlers."

CVE-2009-3800 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3800):
  Multiple unspecified vulnerabilities in Adobe Flash Player before
  10.0.42.34 and Adobe AIR before 1.5.3 allow attackers to cause a
  denial of service (application crash) or possibly execute arbitrary
  code via unknown vectors.

Comment 3 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-12-18 12:35:52 UTC
(In reply to comment #1)
> Lack, can we stabilize 10.0.42.34?

Yes, by all means!

I don't think adobe-flash has ever waited a full 30 days since normally their releases plug security holes.  Maybe I should just start stable-bumping when they make their next release ;)
Comment 4 Stefan Behte (RETIRED) gentoo-dev Security 2009-12-18 13:33:46 UTC
Arches, please test and mark stable:
=www-plugins/adobe-flash-10.0.42.34
Target keywords : "amd64 x86"
Comment 5 Pacho Ramos gentoo-dev 2009-12-18 13:52:43 UTC
amd64 stable (it's also much less crashy than current stable in my case ;-))
Comment 6 Christian Faulhammer (RETIRED) gentoo-dev 2009-12-27 22:59:59 UTC
x86 stable
Comment 7 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-12-28 15:34:15 UTC
All arches stable, and I have now removed the vulnerable =www-plugins/adobe-flash/adobe-flash-10.0.32.18 from the tree.
Comment 8 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-12-31 14:10:00 UTC
GLSA request was already filed.
Comment 9 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-01-03 18:24:39 UTC
GLSA 201001-02