Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 29638 - My Realtek RTL 8139 Network Card can connect from within Live CD and Windows XP, but it does not work from the installed Gentoo system
Summary: My Realtek RTL 8139 Network Card can connect from within Live CD and Windows ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: (DEPRECATED)
: 29504 29631 (view as bug list)
Depends on:
Reported: 2003-09-25 23:21 UTC by Andreas Klostermann
Modified: 2009-03-16 06:31 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Klostermann 2003-09-25 23:21:10 UTC
I think the problem lies in the kernel, as I have tried several network
configurations. Normally I use DHCP, which works fine if not booting Gentoo
Linux from hd. In the same network I had setup another Computer with Gentoo
Linux, without this problem. Kernel noapic option does not fix the problem.
Deactivating Ipv6 (as I had once believed) in Kernel does not solve it either.
I tried gs-sources and gentoo-sources, everytimes using genkernel --config,
specifying to use Athlon XP proccessor.
Again: Windows XP and the Live CD can connect to the internet without any trouble!
In the forums I was recommended to buy another network card, which is not really
a valid option, since the RTL8139 Card is absolutely standard.

Reproducible: Always
Steps to Reproduce:
I actually don't know how to reproduce the problem on another computer... I have
reinstalled Gentoo Linux quite a few times with no effect.

I used genkernel to build the kernel. I enabled Athlon XP optimization. I tried
8139too as a module and builtin. The static IP Configuration seems to be correct
from an ifconfig point of view, but proves wrong when trying to ping somebody on
the net, but I can ping my own IP. The network is mostly roamed by windows PCs,
and one other Gentoo Linux Server.
I used "Blocker" severity since I can't really use Linux without net access,
since I am using Linux both mainly as client workstation and as a server.
Comment 1 SpanKY gentoo-dev 2003-09-26 00:16:37 UTC
*** Bug 29631 has been marked as a duplicate of this bug. ***
Comment 2 Brian Jackson (RETIRED) gentoo-dev 2003-09-26 09:41:18 UTC
Try booting with pci=noapic and see it that clears things up. You can also
try the noacpi boot option and see what that does for you.
Comment 3 Andreas Klostermann 2003-09-26 16:01:26 UTC
I have tried this pci=noapic a lot.... (you mean specifying it with grub
don't you?) It won't work.
Comment 4 Brian Jackson (RETIRED) gentoo-dev 2003-09-27 12:07:59 UTC
Which kernel is causing this problem? Have you tried a different kernel?
Comment 5 Andreas Klostermann 2003-09-28 03:24:05 UTC
I have tried gs-sources and gentoo-sources. Redhat sources don't work with
genkernel somehow, maybe I will try to install it manually. tail -f genkernel.log
tells me that there's an error when building the busybox, but that doesn't
cause genkernel to fail (some keymap cannot be found). I have tried the gs-sources
with P3 Optimazation instead of Athlon XP.
The module for my network card (8139too) is correctly loaded. I tried pci=noapic
and a few other options. It's really frustrating. Gentoo Linux without network
simply sucks.
Comment 6 Brian Jackson (RETIRED) gentoo-dev 2003-09-28 07:04:56 UTC
Okay try a vanilla kernel without using genkernel, and just put the bare
minimum in it. Disable acpi and apic. Build the network drivers as modules.
Have you tried not using dhcp and manually setting the settings on the nic.
If you are still having trouble try some physical things moving the nic to
a different slot, a different net cable, etc.
Comment 7 Martin Holzer (RETIRED) gentoo-dev 2003-09-29 13:17:58 UTC
*** Bug 29504 has been marked as a duplicate of this bug. ***
Comment 8 Michael McCabe (RETIRED) gentoo-dev 2003-10-06 21:12:24 UTC
What kernel version are you using after you install gentoo and what version
of the live cd are you using.  
Comment 9 Florian Haskamp 2003-11-11 00:36:08 UTC
I had the same problem - a 'genkernel'-install of the vanilla-kernel worked.
Comment 10 Tim Yamin (RETIRED) gentoo-dev 2004-02-21 15:56:27 UTC
Can you please try out gentoo-sources-2.4.22-r5 as we believe that the network card issues were fixed in that release. Thanks!
Comment 11 Mark Bailey 2004-02-27 09:10:26 UTC
This occurs on a brand new genkernel installation of development-sources.
The following steps as root after booting bring up the network:

# modprobe 8139too
# ifconfig eth0 up
# dhpcd eth0

on a pretty new E-machines box.

So, this looks like an issue with the 2.6 kernel as well.
Comment 12 Jason Cox (RETIRED) gentoo-dev 2004-04-08 19:26:09 UTC
Could you try a bare minimum, non genkernel, compile? Does this happen with the dentoo-dev-sources as well?
Comment 13 Jason Cox (RETIRED) gentoo-dev 2004-04-16 17:14:54 UTC
This bug has gone stale. Closing.
Comment 14 Jeff Connelly 2004-06-27 11:37:29 UTC
Please re-open this bug, I'm having the same issue on a Compaq Presario R3140US notebook with a RTL8101 NIC. Network connectivity in the LiveCD (both 2004.0 x86 and 2004.1 amd64) works great, but on an installed Gentoo system the NIC dies with "NETDEV WATCHDOG: eth0: transmit timed out" after some time requiring a hard reboot to fix. The problem occurs on:

Gentoo 2004.1 amd64 (installed on hard disk), kernel 2.6.7-gentoo-r6
Gentoo 2004.1 x86 (installed on hard disk)
 compiled with a gentoo-sources kernel 2.4.26-gentoo-r2
 compiled with a Red Hat patched vanilla-sources kernel
Debian sid amd64

I've tried:
noapic, pci=noacpi, noacpi options. Either the problem persists or I get a kernel panic. See for an unresolved thread on this very problem, including dmesg's of the panic, the watchdog timeout, and full kernel configuration.

The NIC works fine on:
Windows XP Home Edition
NetBSD 2.0-beta amd64
NetBSD 1.6.2 i386
Gentoo LiveCD 2004.0 x86
Gentoo LiveCD 2004.1 amd64

I tried to compile the driver at, which claims to be better than 8139too, but even when enabling CONFIG_MODVERSIONS in the kernel and removing MOD_{INC,DEC}_REF_COUNT, link errors still occured, so it doesn't look like the rtl8139 module is compatible with current kernel versions, or maybe I'm doing something wrong.

This bug appears to surface exclusively on the R3140US laptops. Successful installations of Linux on similar laptops include (Compaq Presario R3120US) and (Compaq Presario R3190US). Neither of these users mention any problem with the RTL8101 NIC.

I agree with Andreas's classification of this bug as a Blocker. Personally its whats keeping me from running Linux.

Comment 15 Jeff Connelly 2004-06-28 23:54:16 UTC
I guess no one's going to know that this issue really is resolved now, since it already is marked as RESOLVED CANTFIX, but this is the solution: disable SMP. The Compaq AMD64's don't support HyperThreading so nothing is lost, and the network works fine. 

-Jeff Connelly
Comment 16 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-06-30 11:29:17 UTC
Good, I'll mark the bug closed then.
Comment 17 Chris Mylonas 2009-03-16 06:31:09 UTC
The EEPROM needs reseting on the card apparently.
Here is some info: