Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 29635 - virtuals not considered during multi-package installs
Summary: virtuals not considered during multi-package installs
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-09-25 22:53 UTC by Scott Taylor (RETIRED)
Modified: 2011-10-30 22:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Taylor (RETIRED) gentoo-dev 2003-09-25 22:53:31 UTC
It appears that the list of packages to be installed and their dependencies are
being calculated at the beginning of an emerge without taking into account
virtuals that would get applied during the process. I noticed this when trying
to build qmail (which is a virtual/mta therefore eliminating the need to build
the ssmtp package) at the same time as vcrom (which requires a virtual/mta).
I've seen  quirky behavior when installing groups of packages before, but at
least in this case, i knew what i expected to happen during the emerge.

Reproducible: Always
Steps to Reproduce:


Actual Results:  
(one command: "emerge metalog qmail vcron")
1064554086:  >>> emerge (1 of 11) dev-libs/libpcre-4.2-r1 to /
1064554199:  >>> emerge (2 of 11) app-admin/metalog-0.7-r1 to /
1064554292:  >>> emerge (3 of 11) sys-apps/ucspi-tcp-0.88-r7 to /
1064554338:  >>> emerge (4 of 11) net-mail/dot-forward-0.71-r1 to /
1064554365:  >>> emerge (5 of 11) net-mail/checkpassword-0.90-r1 to /
1064554385:  >>> emerge (6 of 11) net-mail/cmd5checkpw-0.22-r1 to /
1064554396:  >>> emerge (7 of 11) sys-apps/daemontools-0.76-r3 to /
1064554431:  >>> emerge (8 of 11) net-mail/qmail-1.03-r10 to /
1064554560:  >>> emerge (9 of 11) net-mail/mailbase-0.00-r6 to /
1064554573:  >>> emerge (10 of 11) net-mail/ssmtp-2.60.4 to /
(at which point i cancel the emerge and issue an "emerge vcron" by itself. This
time the virtual/mta from qmail is acknowledged so ssmtp is not built.)
1064554605:  >>> emerge (1 of 1) sys-apps/vcron-3.0.1-r1 to /
Comment 1 SpanKY gentoo-dev 2003-09-25 23:39:57 UTC

*** This bug has been marked as a duplicate of 1343 ***