Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 295667 - emerge sys-kernel/linux-docs-2.6.16 fails
Summary: emerge sys-kernel/linux-docs-2.6.16 fails
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-04 15:12 UTC by Dragos Stoica
Modified: 2009-12-08 09:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info log (info_sys-kernel_linux-docs.log,4.27 KB, text/plain)
2009-12-05 09:48 UTC, Dragos Stoica
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dragos Stoica 2009-12-04 15:12:37 UTC
emerge sys-kernel/linux-docs-2.6.16 fails
                                                                      ^

Reproducible: Always

Steps to Reproduce:
1. emerge -av sys-kernel/linux-docs

Actual Results:  
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
validity error : Could not load the external subset "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
Document /var/tmp/portage/sys-kernel/linux-docs-2.6.16/work/linux-2.6.16/Documentation/DocBook/mcabook.xml does not validate
gzip: Documentation/DocBook/man/*.9: No such file or directory
make[1]: *** [Documentation/DocBook/mcabook.9] Error 1
make: *** [mandocs] Error 2


Expected Results:  
emerge linux-docs to work
Comment 1 David Abbott gentoo-dev 2009-12-05 02:33:56 UTC
Please post;
emerge --info sys-kernel/linux-docs
Comment 2 Dragos Stoica 2009-12-05 09:48:11 UTC
Created attachment 212115 [details]
emerge --info log

I attached the requested log.
Comment 3 Dragos Stoica 2009-12-05 11:48:00 UTC
Reopening bug
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2009-12-08 02:29:17 UTC
(In reply to comment #2)
> Created an attachment (id=212115) [details]
> emerge --info log
> 
> I attached the requested log.

You actually didn't. dabbott asked you to _post_ `emerge --info sys-kernel/linux-docs' and you _attached_ `emerge --info'. But it should do.

(In reply to comment #0)
> Steps to Reproduce:
> 1. emerge -av sys-kernel/linux-docs

I cannot reproduce that.

> I/O error : Attempt to load network entity
> http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
> warning: failed to load external entity
> "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
> validity error : Could not load the external subset
> "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"

I can reach those fine. Are you sure you had a working Internet connection while you ran emerge?
Comment 5 Dragos Stoica 2009-12-08 09:47:25 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Created an attachment (id=212115) [details] [details]
> > emerge --info log
> > 
> > I attached the requested log.
> 
> You actually didn't. dabbott asked you to _post_ `emerge --info
> sys-kernel/linux-docs' and you _attached_ `emerge --info'. But it should do.
I actually did. The attachment description was misleading.. Although it doesn't make much difference in this case.. 
 
> (In reply to comment #0)
> > Steps to Reproduce:
> > 1. emerge -av sys-kernel/linux-docs
> 
> I cannot reproduce that.
> 
> > I/O error : Attempt to load network entity
> > http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
> > warning: failed to load external entity
> > "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
> > validity error : Could not load the external subset
> > "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
> 
> I can reach those fine. Are you sure you had a working Internet connection
> while you ran emerge?
Now I can reach them, too. However it's unlikely that the problem was with my net access since I tried this emerge with different connections. Emerge also worked for other packages...
I would rather suspect a remote server failure.
Anyways I'm closing the bug since it's not reproducible anymore..