Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 295152 - usb mounting IsCallerPriviliged failed
Summary: usb mounting IsCallerPriviliged failed
Status: RESOLVED DUPLICATE of bug 340337
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-30 07:26 UTC by mikopp
Modified: 2010-12-18 22:52 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikopp 2009-11-30 07:26:21 UTC
I'm running KDE 4 unstable with hal+consolekit+dbus+policykit (stable)

Since my last upgrade usb keys cannot be mounted in kde anymore. The following message appears:

failed with 'org.freedesktop.Hal.Device.Volume.UnknownFailure' 'IsCallerPrivil
eged() failed

One can find this on google quite often: 
- http://bugs.archlinux.org/task/13162
- https://qa.mandriva.com/show_bug.cgi?id=54804

A workaround is to restart hald, after that it works again. 
But! it only works if hald is restarted after the kde session is already running. If I restart hald before starting KDE it has no effect.

I therefore assume that it has something to do with the consolekit session as well.

Reproducible: Always
Comment 1 mikopp 2009-11-30 07:36:39 UTC
I think I can confirm that this must be related to the consolekit session.

1. started kde with user 1
2. access usb key --> failed
3. restarted hald
4. access usb key --> success
5. unmount
6. start second kde session in parallel with user2
7. access usb with session 2 --> failed (same error)
8. access usb with session 1 --> success
9. restart hald
10. 7. access usb with session 2 --> failed but now with permission denied
  here I had to add permission for mount-removable for console, active console was not enough?
  So It seems that the active console feature is not working either.
  after that it works.
Comment 2 mikopp 2009-11-30 07:37:35 UTC
emerge --info

Portage 2.1.6.13 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.31-gentoo-r6 i686)                                                
=================================================================                                                                                  
System uname: Linux-2.6.31-gentoo-r6-i686-Intel-R-_Core-TM-2_CPU_T5600_@_1.83GHz-with-gentoo-1.12.13                                               
Timestamp of tree: Sun, 29 Nov 2009 12:00:01 +0000                                                                                                 
app-shells/bash:     4.0_p28                                                                                                                       
dev-java/java-config: 2.1.9-r1                                                                                                                     
dev-lang/python:     2.6.2-r1                                                                                                                      
dev-util/cmake:      2.6.4-r3                                                                                                                      
sys-apps/baselayout: 1.12.13                                                                                                                       
sys-apps/sandbox:    1.6-r2                                                                                                                        
sys-devel/autoconf:  2.13, 2.63-r1                                                                                                                 
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                                                          
sys-devel/binutils:  2.18-r3                                                                                                                       
sys-devel/gcc-config: 1.4.1                                                                                                                        
sys-devel/libtool:   2.2.6a                                                                                                                        
virtual/os-headers:  2.6.27-r2                                                                                                                     
ACCEPT_KEYWORDS="x86"                                                                                                                              
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer -mfpmath=sse -msse -msse2 -msse3 -mssse3 -mmmx"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer -mfpmath=sse -msse -msse2 -msse3 -mssse3 -mmmx"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en de en_GB"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa berkdb bzip2 cairo cli consolekit cracklib crypt cups dbus dell dhcpcd djvu dri dvd encode ffmpeg flac fortran gdbm gphoto2 gpm hal iconv imagemagick inotify java jpeg kde konqueror lame laptop libnotify lm_sensors lzo mad mjpeg mmx mmx2 mng modules mp3 mpeg mplayer mudflap musicbrainz mysql ncurses networkmanager nls nptl nptlonly nsplugin ntp ogg opengl openmp pam pcre perl policykit ppds pppd pulseaudio python qt3 qt3support qt4 quicktime rdp readline reflection samba sdl semantic-desktop session spl sql sqlite sqlite3 sse sse2 ssl ssse3 startup-notification svg sysfs taglib tcpd theora truetype unicode usb vcd vnc vorbis wav webkit win32codecs x264 x86 xattr xcb xml xorg xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de en_GB" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXT
Comment 3 mikopp 2009-12-04 15:12:44 UTC
still the same after update to kde 4.3.4
Comment 4 PM 2010-04-18 17:31:33 UTC
I just stumbled into something that looks like this problem - everything was working well for quite a long time, and all of a sudden I can't mount any device in kde 4.4.2. Dolphin returns the same error when trying to mount anything. I didn't do any big update, it just stopped working 0_o. For the record, these are the packages I installed/upgraded since yesterday (though it was still working today in the morning):

     Sat Apr 17 21:09:17 2010 >>> media-sound/alsa-headers-1.0.23                                                                                                                                                    
     Sat Apr 17 21:09:28 2010 >>> sys-apps/sdparm-1.05                                                                                                                                                               
     Sat Apr 17 21:09:46 2010 >>> dev-util/strace-4.5.20                                                                                                                                                             
     Sat Apr 17 21:12:32 2010 >>> dev-libs/icu-4.4-r1                                                                                                                                                                
     Sat Apr 17 21:12:48 2010 >>> dev-libs/libassuan-2.0.0                                                                                                                                                           
     Sat Apr 17 21:13:50 2010 >>> net-misc/ntp-4.2.6_p1                                                                                                                                                              
     Sat Apr 17 21:14:39 2010 >>> media-libs/alsa-lib-1.0.23                                                                                                                                                         
     Sat Apr 17 21:15:20 2010 >>> dev-libs/liboil-0.3.17                                                                                                                                                             
     Sat Apr 17 21:15:43 2010 >>> dev-python/sip-4.10.2                                                                                                                                                              
     Sat Apr 17 21:16:03 2010 >>> media-sound/alsa-utils-1.0.23                                                                                                                                                      
     Sat Apr 17 21:16:41 2010 >>> dev-java/sun-jdk-1.6.0.20                                                                                                                                                          
     Sat Apr 17 21:16:58 2010 >>> sys-power/pm-utils-1.3.0-r2                                                                                                                                                        
     Sat Apr 17 21:17:50 2010 >>> net-misc/openssh-5.5_p1                                                                                                                                                            
     Sat Apr 17 21:18:38 2010 >>> app-crypt/gnupg-2.0.15                                                                                                                                                             
     Sat Apr 17 21:19:05 2010 >>> app-crypt/gpgme-1.3.0                                                                                                                                                              
     Sat Apr 17 21:33:13 2010 >>> dev-python/PyQt4-4.7.3                                                                                                                                                             
     Sat Apr 17 21:33:55 2010 >>> xfce-base/xfce4-settings-4.6.4                                                                                                                                                     
     Sun Apr 18 11:18:02 2010 >>> dev-libs/elfutils-0.145                                                                                                                                                            
     Sun Apr 18 11:18:30 2010 >>> sys-devel/prelink-20100106                                                                                                                                                         
     Sun Apr 18 15:30:14 2010 >>> app-emulation/virtualbox-modules-3.1.6                                                                                                                                             
     Sun Apr 18 15:34:17 2010 >>> app-emulation/virtualbox-bin-3.1.6                                                                                                                                                 
     Sun Apr 18 14:17:28 2010 >>> www-client/opera-10.10-r1                                                                                                                                                          
     Sun Apr 18 15:52:00 2010 >>> dev-db/sqlite-3.6.23.1                                                                                                                                                             
     Sun Apr 18 15:52:32 2010 >>> app-text/enchant-1.6.0                                                                                                                                                             
     Sun Apr 18 15:52:50 2010 >>> app-crypt/qca-ossl-2.0.0_beta3-r2     

  # emerge --info
Portage 2.2_rc67 (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11-r1, 2.6.33-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7400_@_2.80GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 18 Apr 2010 16:30:01 +0000
app-shells/bash:     4.1_p5
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.5-r1, 3.1.2-r2
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -msse3 -mssse3 -msse4.1 -pipe -g"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -msse3 -mssse3 -msse4.1 -pipe -g"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-sunset /usr/local/portage/moje"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib acl acpi alsa amd64 amr amrnb amrwb async audiofile automount bash-completion berkdb bineditor branding bzip2 cairo cdda cddb cdio cdparanoia cdr chdir cli consolekit cracklib crypt css cuda cups curl cxx dbus dirac disk-partition divx djvu dri dts dvd dvdr editor emboss emovix encode exchange exif faac faad fam fat ffmpeg fftw firefox firefox3 flac fontconfig fortran gd gdbm geoip gif glitz gmedia gphoto2 gpm gtk hal hddtemp iconv id3 id3tag imagemagick inotify ipod jpeg kde kde4 kdehiddenvisibility kipi kompare kpathsea kqemu ladspa lame laptop lastfm latex lcms libcaca libnotify libsamplerate lm_sensors mad midi mikmod mjpeg mmap mmx mmxext mng modules mp3 mp3tunes mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses nls nptl nptlonly nsplugin ntfs ogg openal opencore-amr opengl openmp optimized-qmake pam pango pch pcre pdf perl plasma png policykit ppds pppd python qt3 qt3support qt4 readline realmedia reflection roe sasl scanner schroedinger sdl secure-delete sensord session slang sndfile solver soundtouch sourceview spell spl sse sse2 sse3 sse4a ssl ssse3 startup-notification suid svg swat symlink sysfs syslog tcpd theora threads tiff truetype unicode upnp usb vamp vcd vdpau vorbis webkit wicd wmf wmp wxwidgets wxwindows x264 xcb xcomposite xine xml xorg xscreensaver xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 PM 2010-05-03 22:54:17 UTC
Ok, in my case it seemed to be caused by consolekit starting before HAL due to parallel boot being turned on. After turning it off or putting consolekit in the boot runlevel everything works fine.
Comment 6 Andreas K. Hüttel gentoo-dev 2010-06-06 18:05:51 UTC
Which kde version are you talking about? Is this still happening with 4.4.4?
Comment 7 Fabio Erculiani (RETIRED) gentoo-dev 2010-07-13 15:08:45 UTC
The solution is simple, make consolekit starting BEFORE hal.
Comment 8 Captain Sifff 2010-08-21 12:15:24 UTC
Most likely this is related to the order of the services which are started.
The configuration that is working for me right now, is to put consolekit and 
dbus into boot runlevel and hald into default runlevel.
Furthermore you should look into /etc/PolicyKit/PolicyKit.conf
and make sure that somebody is allowed to access the hardware.
A catch-all that most likely helps is to allow everybody in the wheel group give root access(this probably has side-effects...). the line would be:

<define_admin_auth group="wheel"/>
        <match user="root">
                <return result="yes"/>
        </match>
Comment 9 Captain Sifff 2010-08-21 12:18:07 UTC
Furthermore you should check with ck-list-sessions that consolekit knows about your session. On a side note: The same issues are at the root if Powerdevil can't suspend to RAM.
Comment 10 Ian Douglas 2010-08-21 15:40:51 UTC
(In reply to comment #9)
> Furthermore you should check with ck-list-sessions that consolekit knows about
> your session. On a side note: The same issues are at the root if Powerdevil
> can't suspend to RAM.
> 

If ck-list-sessions shows nothing, how do I fix it?

thanks, Ian
Comment 11 mikopp 2010-12-07 08:33:48 UTC
I had this again with KDE 4.5 the solution was relatively simple, I compiled hal without policykit as it is the only package using policykit and not polkit. After that everything works fine. consolekit and polkit are enabled.
Comment 12 Samuli Suominen gentoo-dev 2010-12-18 22:52:50 UTC
(In reply to comment #11)
> I had this again with KDE 4.5 the solution was relatively simple, I compiled
> hal without policykit as it is the only package using policykit and not polkit.
> After that everything works fine. consolekit and polkit are enabled.
> 

yep, the old policykit should be removed from tree asap

*** This bug has been marked as a duplicate of bug 340337 ***