Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294876 - sci-biology/arb: fails to build with glibc-2.10
Summary: sci-biology/arb: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Andrey Kislyuk (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-11-27 19:37 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-03-13 19:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (arb-5.1:20091127-150152.log,68.55 KB, text/plain)
2009-11-27 19:38 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-27 19:37:33 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-27 19:38:17 UTC
Created attachment 211352 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2010-03-12 19:05:04 UTC
hmm... this is the last package on glibc-2.10 tracker, would you prefer to lastrite it?
Comment 3 Justin Lecher gentoo-dev 2010-03-13 12:46:29 UTC
Fixed. Also many LDFLAGS disrespectings fixed.
Andrey, you owe me some cookies!
Comment 4 Andrey Kislyuk (RETIRED) gentoo-dev 2010-03-13 19:04:50 UTC
Thanks a lot Justin!! PM me your address for some cookies (or beer, your choice). I'm serious!