Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294831 - Please stabilize =sys-fs/avfs-0.9.8-r1 (was: sys-fs/avfs-0.9.8 doesn't build with gcc 4.3.4)
Summary: Please stabilize =sys-fs/avfs-0.9.8-r1 (was: sys-fs/avfs-0.9.8 doesn't build ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Kernel Miscellaneous
URL:
Whiteboard:
Keywords: STABLEREQ
: 335349 (view as bug list)
Depends on:
Blocks: gcc-4.3-stable 302468
  Show dependency tree
 
Reported: 2009-11-27 12:54 UTC by Robert Kerr
Modified: 2011-01-13 23:39 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Kerr 2009-11-27 12:54:51 UTC
Attempting to emerge sys-fs/avfs-0.9.8 with gcc 4.3.4 results in:

In function 'open',
    inlined from 'do_unrar' at urar.c:590,
    inlined from 'rar_open' at urar.c:631:
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments

sys-fs/avfs-0.9.8-r1 emerges fine and the changelog seems to indicate this is a known issue:

  01 Mar 2009; Patrick Lauer <patrick@gentoo.org>
  +files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch,
  +avfs-0.9.8-r1.ebuild:
  Fix for gcc 4.3.3 / fortify_sources. Patch by Romain Perier.

I guess at the time of the patch gcc 4.3 was not in stable, so the fixed ebuild was left ~arch - but now gcc 4.3 is stable avfs-0.9.8-r1 should be stabilised too.

Reproducible: Always
Comment 1 Nikoli 2010-07-10 15:03:28 UTC
This bug should be blocker for bug 245160 and bug 302468
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-31 09:54:27 UTC
*** Bug 335349 has been marked as a duplicate of this bug. ***
Comment 3 Christian Faulhammer (RETIRED) gentoo-dev 2010-09-08 13:13:25 UTC
x86 stable
Comment 4 Tobias Klausmann gentoo-dev 2010-09-10 12:39:48 UTC
Stable on alpha.
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2010-10-10 10:56:07 UTC
amd64 done
Comment 6 Raúl Porcel (RETIRED) gentoo-dev 2010-10-24 17:29:41 UTC
ia64/sparc stable
Comment 7 Tim Harder gentoo-dev 2011-01-13 23:39:47 UTC
Closing since avfs-0.9.9 has been stabilized.