Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294517 - Getting gnome-shell in Gentoo
Summary: Getting gnome-shell in Gentoo
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://digitizor.com/2009/11/10/get-a...
Whiteboard: [gnome]
Keywords: InOverlay
Depends on:
Blocks: 368855
  Show dependency tree
 
Reported: 2009-11-25 04:38 UTC by michael higgins
Modified: 2011-11-26 14:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michael higgins 2009-11-25 04:38:30 UTC
It would be great if we could get a snapshot that builds well on common architectures into the tree. (See link... )

I cherry-picked some ebuilds from here and there and but for one package was able to build a gnome-shell to replace gnome-panel. 

So far gnome-shell *seems* to be "stable" enough for me... and it is *very* cool. So we should have a subset of ebuilds that all work, and a how-to, no? I don't see a gnome-3 bug, so... no idea what the plans are, if any.

Reproducible: Always

Steps to Reproduce:
1. go to try gnome-shell in Gentoo
2. no ebuilds, get overlay?
3. seems like maybe some bugs in ebuilds, not latest versions?

Actual Results:  
4. have to build some libraries w/o ebuild magic

Expected Results:  
Have some advice from Gentoo community, say, on a general bug report, as to what ebuilds in the tree to unmask such that "emerge gnome-shell" works to install gnome-shell. ;-) Like a guide for the lazy.

Again, check the link. If some Ubuntu users can just install it with some package manager, why can't we? 

I had to grab these:
gnome-shell-9999.ebuild  
gobject-introspection-9999.ebuild 
clutter-1.0.8.ebuild (didn't work for me)
mutter-9999.ebuild  
gjs-0.4.ebuild 
gir-repository-0.6.5.ebuild 

In the gnome overlay, I see there are these packages:
  gnome-shell-2.28.0.ebuild
  gobject-introspection-0.6.5.ebuild
  clutter-1.0.8.ebuild
  mutter-2.28.0.ebuild
  gjs-0.4.ebuild
  gir-repository-0.6.5.ebuild

...can anyone confirm that these will build straight from the overlay and work for them? I grabbed a bunch of live ebuilds from somewhere... so like maybe this was needed, maybe not.

I'll check about clutter, which I had to build directly from source, and file a separate bug for that I guess.

If I'm the only one who thinks this is worth doing, then sorry for the noise! [I'm only become interested in this route since I can't work with a panel across the bottom of my screen and gnome-panel needs patching to work well in a vertical layout.]
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-11-25 16:59:24 UTC
everything is in gnome overlay already, what else do you want ?
Comment 2 michael higgins 2009-11-25 19:35:46 UTC
(In reply to comment #1)
> everything is in gnome overlay already, what else do you want ?
> 

1) "It would be great if we could get a snapshot that builds well on common
architectures into the tree."

"The Tree" != "gnome overlay"

So, first preference is not to need any part of gnome overlay. I use "gnome-light", now want gnome-light+gnome-shell. Why? Because no resolution to http://bugs.gentoo.org/show_bug.cgi?id=262194 -- an upstream gnome-panel bug that's been around for years and apparently will never be fixed, here or there, as we'll probably all be (expected to be) moving to gnome-shell next year.

2) "...confirm that these will build straight from the overlay"

So, second preference would be that we have a central bug reference for gnome-shell with a brief how-to on what, minimally, needs to be done to get it installed and running. I mentioned "Cherry-picking" ebuilds... I needed only six. Or so I think...

Anyway, if you search b.g.o. for gnome-shell, now there is something to find, no? Wouldn't we want more testers for new awesome Gnome feature, without committing to the full bloat? Also, if you look at the link, say, is there a Gentoo equivalent "how-to-get-gnome-shell"?

3) "If I'm the only one who thinks this is worth doing, then sorry for the noise!"

Would like your opinion on this. Me thinks it is worth having a central bug for getting gnome-shell and to encourage folks to test and use it now. If you think this is stupid or insane, please say so (and why). ;-)
Comment 3 RGK 2009-11-25 19:46:26 UTC
I say, leave it in the overlay, its new software that gnome isn't even using yet.
Comment 4 Rémi Cardona gentoo-dev 2009-11-25 20:19:07 UTC
All those suggestions are the very reasons why the gnome overlay exists. It's to test new Gnome software.

As Gilles recently pointed out [1], the Gnome Team is understaffed and we just don't have the time to do what you describe. It's a very noble goal, but we just don't have the time.

So I can only encourage you to help us, either by working directly on the Gnome overlay (a clone) to improve it, or by working on your own overlay and improving the ebuilds in there.

In any case: we need help, lots of it :)

So I'll be closing this bug, not that I don't agree with your goal, but because there's nothing we're going to do within the next few months.

Thanks
Comment 5 michael higgins 2009-11-25 21:06:19 UTC
(In reply to comment #4)

Thanks for the feedback.

> All those suggestions are the very reasons why the gnome overlay exists. It's
> to test new Gnome software.

Granted, this is true. 

> 
> As Gilles recently pointed out [1], the Gnome Team is understaffed and we just
> don't have the time to do what you describe. It's a very noble goal, but we
> just don't have the time.

I appreciate that.

> So I can only encourage you to help us, either by working directly on the Gnome
> overlay (a clone) to improve it, or by working on your own overlay and
> improving the ebuilds in there.

I hear ya. This isn't the place to discuss possible involvement. Before filing this I looked for a #gentoo-gnome or gnome@gentoo. #gentoo-overlays is like a morgue... Where do y'all hang out and work, I wonder? 

Anyway, as a postscript, I just went to update the system and portage cries for gnome-panel still. I'd like to figure out how to fix that, which seems like modding a few more ebuilds that *are* in the tree to remove that dependency. Plus, w/o the gnome-overlay installed, I guess I can't get the clutter.eclass to stick (and none of the clutter ebuilds I found worked for me anyway).

Guess I have enough to do now... and some place to start. Thanks, y'all!
Comment 6 Rémi Cardona gentoo-dev 2009-11-25 23:42:00 UTC
[1] http://blogs.gentoo.org/index.php/2009/11/13/looking-for-a-padawan?blog=86

(In reply to comment #5)
> I hear ya. This isn't the place to discuss possible involvement. Before filing
> this I looked for a #gentoo-gnome or gnome@gentoo. #gentoo-overlays is like a
> morgue... Where do y'all hang out and work, I wonder? 

#gentoo-desktop on FreeNode. See you soon :)

Thanks
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2011-05-27 09:14:23 UTC
Reopening as a blocker for gnome-shell-dependant packages until it is moved to gx86.
Comment 8 Gilles Dartiguelongue gentoo-dev 2011-11-26 14:33:45 UTC
Gnome shell is now in gentoo with gnome 3.2