Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 294173 - dev-lisp/sbcl-1.0.31(?) fails to build cause of inaccessible syslog(/dev/log)
Summary: dev-lisp/sbcl-1.0.31(?) fails to build cause of inaccessible syslog(/dev/log)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Common Lisp Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-23 12:04 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2012-06-07 20:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (bzip2) (sbcl-1.0.31:20091123-020616.log.bz2,288.38 KB, application/x-bzip2)
2009-11-23 12:09 UTC, Diego Elio Pettenò (RETIRED)
Details
build.log (build.log.bz2,275.78 KB, application/x-bzip2 )
2009-12-03 15:38 UTC, Bronsa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-23 12:04:31 UTC
Portage 2.1.7.6 (default/linux/x86/10.0, gcc-4.4.2-asneeded, glibc-2.11-r0, 2.6.32-rc8 i686)
=================================================================
System uname: Linux-2.6.32-rc8-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.1
Timestamp of tree: Sun, 22 Nov 2009 13:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p33
dev-java/java-config: 1.3.7-r1, 2.1.9-r1
dev-lang/python:     2.6.2-r2, 3.1.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r2
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openfire/resources/security/ /opt/openjms/config /usr/lib/ccs/conf /usr/lib/fax /usr/share/bufrtables /usr/share/config /usr/share/qpsmtpd/plugins /var/bind /var/lib/hsqldb /var/phxd /var/qmail/alias /var/qmail/control /var/spool/fax/etc /var/spool/torque /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
INSTALL_MASK="  /usr/share/doc  /usr/share/info"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree-tinderbox"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap ncurses nls nostatic nptl nptlonly openmp pam pcre perl pppd python qt3support readline reflection ruby session spl ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest" ELIBC="glibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-23 12:09:52 UTC
Created attachment 210974 [details]
Build log (bzip2)
Comment 2 Stelian Ionescu 2009-11-23 14:47:40 UTC
One test fails because of ECONNREFUSED when connecting to /dev/log.
I think that the problem lay in the tinderbox configuration, not in SBCL.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-23 15:22:39 UTC
Well, it really shouldn't fail to *build* if the syslog is inaccessible, should it?
Comment 4 Stelian Ionescu 2009-11-23 15:30:10 UTC
Upstream policy is that contrib tests are always run and build fails if they don't all pass
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-11-23 15:46:54 UTC
And Gentoo policy states that tests should be separated and build shouldn't fail if syslog is not working…
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2009-11-30 08:47:48 UTC
As a workaround for this issue I removed /dev/log from the build host. I think since it builds successfully without /dev/log it's safe to drop this exact test, or at least make failure non fatal.
Comment 7 Bronsa 2009-12-03 14:17:46 UTC
(In reply to comment #6)
> As a workaround for this issue I removed /dev/log from the build host. I think
> since it builds successfully without /dev/log it's safe to drop this exact
> test, or at least make failure non fatal.
> 

i got the same problem and i have removed /dev/log but nothing changed

what should i do?
Comment 8 Bronsa 2009-12-03 15:38:07 UTC
Created attachment 211863 [details]
build.log
Comment 9 Stelian Ionescu 2009-12-03 15:50:02 UTC
@Bronsa: Your build fails because of a different error:

unhandled SIMPLE-ERROR in thread #<SB-THREAD:THREAD "initial thread" RUNNING {1002A030A1}>:
  couldn't fork child process: Cannot allocate memory

You seem to be running out of virtual memory and I have the impression that it's because you're using tmpfs on /var/tmp/portage. Try to disable tmpfs and recompile
Comment 10 Samuli Suominen gentoo-dev 2012-06-07 20:07:43 UTC
If you can still reproduce with current stable, 1.0.55-r1, bug 326217, please reopen the bug.