Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 293572 - Rekeyword media-plugins/gst-plugins-meta-0.10-r5
Summary: Rekeyword media-plugins/gst-plugins-meta-0.10-r5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-11-18 04:14 UTC by Yang Zhao
Modified: 2011-06-30 19:42 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yang Zhao 2009-11-18 04:14:41 UTC
totem-2.28 requires gst-plugins-resindvd-0.10.14 for DVD playback.

This dependency is currently not reflected in totem nor gst-plugins-meta. Without resindvd, totem shows no indication as to why DVD playback fails; it simply does nothing when selecting Movie > Play Disc ...
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-11-18 12:42:24 UTC
yes, that's a know common problem with gstreamer based applications. What really needs to happen is bug #241674. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 241674 ***
Comment 2 Mart Raudsepp gentoo-dev 2009-11-18 12:46:28 UTC
I'd suggest a USE=dvd for the time being anyway
Comment 3 Mart Raudsepp gentoo-dev 2009-11-18 12:47:56 UTC
I mean on totem, not gst-plugins-meta. Apps typically need to support using DVD features to be useful, e.g deal with the GstNavigation interface for DVD navigation from some UI, so not a good fit for -meta. Good to have on totem itself.
Comment 4 Rémi Cardona gentoo-dev 2009-11-18 13:06:56 UTC
+1 from me for USE=dvd on totem
Comment 5 Rémi Cardona gentoo-dev 2009-11-18 14:03:51 UTC
I guess we now have a consensus for adding resindvd to the meta's dvd USE flag instead.
Comment 6 Romain Perier (RETIRED) gentoo-dev 2009-11-18 18:46:35 UTC
+1 for USE=dvd on totem too
Comment 7 Yang Zhao 2009-11-20 19:57:02 UTC
The issue is more the exact version dependency rather than lacking the plugin alltogether.  When gst-plugins-resindvd is not installed at all, totem will pop its own "no support" dialog to notify the user. With gst-plugins-resindvd-0.10.11 installed, totem simply fails when attempting to play a DVD.

This was discovered after some testing while experimenting with the gst-install-plugins-helper interface.
Comment 8 Romain Perier (RETIRED) gentoo-dev 2009-11-20 20:28:15 UTC
So you propose "dvd? ( >=gst-plugins-resindvd-0.10.14)" in pure RDEPEND ?
Comment 9 Yang Zhao 2009-11-20 20:31:52 UTC
(In reply to comment #8)
> So you propose "dvd? ( >=gst-plugins-resindvd-0.10.14)" in pure RDEPEND ?

Yes.

Comment 10 Mart Raudsepp gentoo-dev 2009-11-20 23:58:22 UTC
A newer gst-plugins-resindvd got unmasked recently thanks to libdvdnav-4 getting unmasked. It will be bumped to 0.10.17 later today or so, so things should be working good. I'll try to fast-track resindvd-0.10.14 to stable, but that depends on the libdvdnav maintainers. I'm fine with the bigger version requirement, but we actually agreed it would be on gst-plugins-meta, not totem, as -meta already depends on the other plugins that are needed for standard DVD video support (the standard codecs, container, etc).
There we can only add it to the ~arch -meta, probably a revbump might be in order too. And we can stabilize it after >=gst-plugins-resindvd-0.10.14 is stable
Comment 11 Daniel Gryniewicz (RETIRED) gentoo-dev 2010-02-02 14:00:29 UTC
Arch teams: I've dropped your keyword from the new media-plugins/gst-plugins-meta-0.10-r4 due to the gst-plugins-resindvd dep.  Please keyword or USE mask.

Arm: you also need to do the pulseaudio flag.
Comment 12 Raúl Porcel (RETIRED) gentoo-dev 2010-02-07 19:32:53 UTC
~arm/~ia64/~sh/~sparc done
Comment 13 Mart Raudsepp gentoo-dev 2010-04-04 13:28:24 UTC
Now I have some concerns about it. It might have to be behind a USE=bindist too, along quite some others that get enabled by simple USE flags right now. Such as almost all coming through gst-plugins-ugly or its splits, and also some from -bad
Comment 14 Peter Volkov (RETIRED) gentoo-dev 2010-05-24 06:03:04 UTC
@BSD: looks you were forgotten here:

RDEPEND.badindev
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r4.ebuild: ~x86-fbsd(default/bsd/fbsd/x86/7.2) ['>=media-plugins/gst-plugins-resindvd-0.10.14']

Please, keyword required plugin. Thanks.
Comment 15 Tobias Klausmann gentoo-dev 2010-07-17 14:22:41 UTC
Keyworded both -resindvd and -meta on alpha.
Comment 16 Pacho Ramos gentoo-dev 2011-03-18 16:46:50 UTC
bsd done (use masking needed)

sh looks to need more work:

$ repoman full -d

RepoMan scours the neighborhood...
  RDEPEND.badindev              12
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r4.ebuild: sh(default/linux/sh/10.0/server) ['>=media-plugins/gst-plugins-pulse-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r4.ebuild: sh(default/linux/sh/10.0/developer) ['>=media-plugins/gst-plugins-pulse-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r4.ebuild: sh(default/linux/sh/10.0/desktop/kde) ['>=media-plugins/gst-plugins-pulse-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r4.ebuild: sh(default/linux/sh/10.0/desktop/gnome) ['>=media-plugins/gst-plugins-pulse-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r4.ebuild: sh(default/linux/sh/10.0/desktop) ['>=media-plugins/gst-plugins-pulse-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r4.ebuild: sh(default/linux/sh/10.0) ['>=media-plugins/gst-plugins-pulse-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r5.ebuild: ~sh(default/linux/sh/10.0/server) ['>=media-plugins/gst-plugins-faad-0.10', '>=media-plugins/gst-plugins-dv-0.10', '>=media-plugins/gst-plugins-wavpack-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r5.ebuild: ~sh(default/linux/sh/10.0/developer) ['>=media-plugins/gst-plugins-faad-0.10', '>=media-plugins/gst-plugins-dv-0.10', '>=media-plugins/gst-plugins-wavpack-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r5.ebuild: ~sh(default/linux/sh/10.0/desktop/kde) ['>=media-plugins/gst-plugins-faad-0.10', '>=media-plugins/gst-plugins-dv-0.10', '>=media-plugins/gst-plugins-wavpack-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r5.ebuild: ~sh(default/linux/sh/10.0/desktop/gnome) ['>=media-plugins/gst-plugins-faad-0.10', '>=media-plugins/gst-plugins-dv-0.10', '>=media-plugins/gst-plugins-wavpack-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r5.ebuild: ~sh(default/linux/sh/10.0/desktop) ['>=media-plugins/gst-plugins-faad-0.10', '>=media-plugins/gst-plugins-dv-0.10', '>=media-plugins/gst-plugins-wavpack-0.10']
   media-plugins/gst-plugins-meta/gst-plugins-meta-0.10-r5.ebuild: ~sh(default/linux/sh/10.0) ['>=media-plugins/gst-plugins-faad-0.10', '>=media-plugins/gst-plugins-dv-0.10', '>=media-plugins/gst-plugins-wavpack-0.10']
RepoMan sez: "You're only giving me a partial QA payment?
              I'll take it this time, but I'm not happy."
Comment 17 Pacho Ramos gentoo-dev 2011-06-19 10:36:12 UTC
sh team?
Comment 18 Pacho Ramos gentoo-dev 2011-06-30 19:42:01 UTC
I have corrected the use.mask for sh and will leave it as-is due that profiles are considered as "dev" ones