Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 293501 - unresolvable dependencies between msynctool, libopensync and libopensync-plugins
Summary: unresolvable dependencies between msynctool, libopensync and libopensync-plugins
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Ryan Hill (RETIRED)
URL:
Whiteboard:
Keywords:
: 311073 327205 (view as bug list)
Depends on:
Blocks: 354423
  Show dependency tree
 
Reported: 2009-11-17 15:15 UTC by Markus Wernig
Modified: 2011-03-13 19:09 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Wernig 2009-11-17 15:15:57 UTC
Hi all

I was (again) trying to set up msync between my phone and my ~x86 gentoo, albeit unsuccessfully. The reason seems to be that msynctool and the required libopensync and libopensync-plugins are totally out of sync in portage.

Here's the situation that I see, but can't resolve.

- msynctool is at version 0.36.
  requires libopensync-0.36

- libopensync-plugin-vformat, libopensync-plugin-file and libopensync-plugin-evolution2 are at 0.39
  require libopensync-0.39

- libopensync-plugin-synce and libopensync-plugin-sunbird are at 0.22
  require libopensync-0.22

- all other libopensync-plugins are at 0.36
  require libopensync-0.36


Now, the easiest way would seem to downgrade (package.mask) everything to 0.36 and forget synce and sunbird, which I tried.
This requires libopensync-plugin-syncml to also be downgraded to 0.36, but the libopensync-plugin-syncml-0.36 ebuild has been removed, because it required libsyncml-0.4, which is now at 0.5.4, and there is no ebuild for libsyncml-0.4.x

So, to all my seeming, it is not possible to use msynctool at all.

Leaving all settings at their defaults results in the following btw:
msynctool --listplugins
Available plugins:
msynctool: symbol lookup error: msynctool: undefined symbol: osync_plugin_env_num_plugins

Just can't figure it out.

krgds /markus
Comment 1 Markus Wernig 2009-11-18 21:52:44 UTC
(In reply to comment #0)

> Leaving all settings at their defaults results in the following btw:
> msynctool --listplugins
> Available plugins:
> msynctool: symbol lookup error: msynctool: undefined symbol:
> osync_plugin_env_num_plugins

More precisely: msynctool-0.36 and libopensync-0.39. The situation is easily reached by first installing msynctool, then libopensync without masking.
Comment 2 Just18 2009-12-14 15:56:56 UTC
Can confirm this bug.
Seems no one is using gentoo to sync his mobile device ?
Any ideas how to solve this issue ?
Comment 3 Markus Wernig 2009-12-14 17:53:18 UTC
(In reply to comment #2)
> Can confirm this bug.
> Seems no one is using gentoo to sync his mobile device ?
> Any ideas how to solve this issue ?

Not with current portage and bugs like this getting no response ;-)
What I did (and use it since without any issues): Instead of downgrading the whole app-pda plethora, I deinstalled the packages in question (opensync*, syncml* etc.) and downloaded, compiled and installed the original source code, vesion 0.22 from opensync.org (actually, one big warning on the site says "0.3x releases introduce major architecture and API changes and are targeted for developers and testers only and may not even compile or are likely to contain severe bugs.

0.3x releases are not recommended for end users or distribution packaging.")

But I suppose this is what being on ~x86 is all about :-) 

All of those install (very straightforwardly) into /usr/local, so there is no conflict with the gentoo packages. I even reinstalled some of the gentoo pkgs later, and they happily coexisted.

krgds /markus
Comment 4 Samuli Suominen gentoo-dev 2010-03-24 10:55:21 UTC
*** Bug 311073 has been marked as a duplicate of this bug. ***
Comment 5 Samuli Suominen gentoo-dev 2010-07-17 06:38:45 UTC
*** Bug 327205 has been marked as a duplicate of this bug. ***
Comment 6 Lubomir Krajcovic 2010-11-03 17:08:12 UTC
(In reply to comment #1)
> 
> More precisely: msynctool-0.36 and libopensync-0.39. The situation is easily
> reached by first installing msynctool, then libopensync without masking.
> 

Do not use msynctool for libopensync >= 0.39, use osynctool instead.
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2011-02-14 06:10:59 UTC
Mine.
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2011-03-13 19:09:26 UTC
There's really nothing we can do here.  We can't add plugins that don't exist.  We can SLOT libopensync but the tools can't be installed together because the configuration files are incompatible between versions and all overwrite one another.  All we can do is provide a plugin for every version we support if one exists and hope some combination works.