Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 292324 - mail-client/evolution-2.28.1 doesn't empty wastebasket
Summary: mail-client/evolution-2.28.1 doesn't empty wastebasket
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-11-07 23:02 UTC by Stephan Friedrichs
Modified: 2010-08-15 21:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
paludis --info evolution (evolution-info,15.02 KB, text/plain)
2009-11-07 23:04 UTC, Stephan Friedrichs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Friedrichs 2009-11-07 23:02:33 UTC
I have configured several mail accounts in evolution. The pop3 accounts are in the 'On This Computer' section and share one 'Trash' folder. There is also one local unix mailspool account listed in a separate 'user@localhost' section with a 'Trash' folder of its own.

When I want to empty one wastebasket I right-click a 'Trash' folger and select 'Empty wastebasket'. This works fine for the pop3 wastebasket, but when I do it for the local mailspool wastebasket, the *other* (the pop3) wastebasket is emptied, while the local mailspool trash remains undeleted.

Reproducible: Always

Steps to Reproduce:
1. Select 'Empty Wastebasket' from the 2nd 'Trash' folder's context menu
Actual Results:  
The 1st wastebasket gets emptied, not the 2nd.

Expected Results:  
The appropriate wastebasket should be emptied, not always the 1st one.
Comment 1 Stephan Friedrichs 2009-11-07 23:04:16 UTC
Created attachment 209583 [details]
paludis --info evolution
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-11-07 23:12:56 UTC
Is there any message in ~/.xsession-errors that would make you think evolution is failing at doing the right thing ? Did it ever work ?
Comment 3 Stephan Friedrichs 2009-11-08 12:23:25 UTC
(In reply to comment #2)
> Is there any message in ~/.xsession-errors that would make you think evolution
> is failing at doing the right thing ? Did it ever work ?
> 

There are just a couple of these lines:

** (evolution:14927): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (evolution:14927): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (evolution:14927): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

But they are also there, when I empty the wastebasket wich works.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-11-08 15:39:04 UTC
did it ever worked ?
Comment 5 Stephan Friedrichs 2009-11-08 18:23:07 UTC
(In reply to comment #4)
> did it ever worked ?
> 

I don't know, because I recently switched to evolution. But I can reproduce the bug after downgrading to evolution-2.26.3!
Comment 6 Pacho Ramos gentoo-dev 2009-11-26 14:08:11 UTC
Maybe this is https://bugzilla.gnome.org/show_bug.cgi?id=550414
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-12-13 23:24:32 UTC
looks like it.
Comment 8 Stephan Friedrichs 2010-01-10 20:35:05 UTC
(In reply to comment #6)
> Maybe this is https://bugzilla.gnome.org/show_bug.cgi?id=550414
> 

I don't think so. I don't get weird error messages when emptying the trash, evolution simply empties the wrong trash folder.

BTW: still reproducable on mail-client/evolution-2.28.2
Comment 9 Alex Buell 2010-05-14 18:50:49 UTC
I had a very weird experience with Evolution 2.28 lately where it couldn't empty the wastebin nor remove deleted messages properly. 

I tracked it down to a corrupt folders.db and *.ibex.index files. Deleting these files cured the problem completely. First issue the command 'evolution --force-shutdown' and then delete the files as above. Restart Evolution and the problem should disappear. 

Perhaps this is the problem the reporter was having?
Comment 10 Stephan Friedrichs 2010-05-14 19:01:31 UTC
I can't test it, because I switched back to thunderbird quite a while ago.
Comment 11 Pacho Ramos gentoo-dev 2010-06-13 20:15:08 UTC
Fixed in 2.30 committed to the main tree (it includes upstream patches)
Comment 12 Dragan Radakovic 2010-08-15 21:13:24 UTC
(In reply to comment #9)
> I had a very weird experience with Evolution 2.28 lately where it couldn't
> empty the wastebin nor remove deleted messages properly. 
> 
> I tracked it down to a corrupt folders.db and *.ibex.index files. Deleting
> these files cured the problem completely. First issue the command 'evolution
> --force-shutdown' and then delete the files as above. Restart Evolution and the
> problem should disappear. 
> 
> Perhaps this is the problem the reporter was having?
> 

Solution is working fine on Evolution 2.28.1 - just close Evolution rename or delete following files:

folders.db
Drafts.ibex.index
Inbox.ibex.index
Outbox.ibex.index
Sent.ibex.index
Templates.ibex.index

and restart Evolution. After that action even some messages that where received without the date where fixed.