Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 292038 - media-libs/liblastfm: missing deps x11-libs/qt-sql and dev-ruby/rubygems, needs rubification
Summary: media-libs/liblastfm: missing deps x11-libs/qt-sql and dev-ruby/rubygems, nee...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard: [kde testing]
Keywords: EBUILD, InOverlay
: 292036 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-06 00:36 UTC by David Carlos Manuelda
Modified: 2010-04-05 07:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
liblastfm without rubygems (media-libs:liblastfm-0.3.0:20091111-144410.log,1.36 KB, text/plain)
2009-11-11 14:52 UTC, David Carlos Manuelda
Details
liblastfm without having qt-sql installed (media-libs:liblastfm-0.3.0:20091111-145333.log,29.93 KB, text/plain)
2009-11-11 14:54 UTC, David Carlos Manuelda
Details
emerge --info (emerge_info.txt,10.42 KB, text/plain)
2009-11-11 14:56 UTC, David Carlos Manuelda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Carlos Manuelda 2009-11-06 00:36:18 UTC
I tried to compile liblastfm in a clean system, and it failed.
First of all, I had to install rubygems in order to make it to work.

Afterwards, it complained about some things not declared (pertaining to qt-sql package), so I installed it manually.
Now it compiled fine, so definitely it should have

dev-ruby/rubygems
x11-libs/qt-sql

As dependencies too.

To reproduce it, try to install liblastfm from a clean stage3 gentoo

P.D. I don't know anything of ruby, so I don't know what rubygems is, nor if it should be added as a PDEPEND for ruby instead.. (this is the error liblastfm gives without rubygems: /usr/bin/ruby: no such file to load -- auto_gem (LoadError) )

Reproducible: Always
Comment 1 David Carlos Manuelda 2009-11-06 00:37:33 UTC
*** Bug 292036 has been marked as a duplicate of this bug. ***
Comment 2 白川間瀬流 2009-11-06 02:23:59 UTC
Same thing here. its defenetly missing qt-sql as dependency
Comment 3 Romain Perier (RETIRED) gentoo-dev 2009-11-11 14:35:04 UTC
- Please attach the full build.log
- Please also attach the output of emerge --info

thanks
Comment 4 David Carlos Manuelda 2009-11-11 14:52:57 UTC
Created attachment 209913 [details]
liblastfm without rubygems

Rubygems was not installed in latest amd64 stage3 I downloaded from mirror when I re-installed gentoo.
Comment 5 David Carlos Manuelda 2009-11-11 14:54:58 UTC
Created attachment 209914 [details]
liblastfm without having qt-sql installed

Since it does not have it as a dep, this demonstrates it fails without it
Comment 6 David Carlos Manuelda 2009-11-11 14:56:26 UTC
Created attachment 209915 [details]
emerge --info

My emerge --info output
Comment 7 Andreas K. Hüttel gentoo-dev 2010-04-03 16:54:32 UTC
Both issues confirmed exactly as reported. 
Please add x11-libs/qt-sql and dev-ruby/rubygems to dependencies. 

In addition the ebuild will need rubification... :(
Comment 8 Andreas K. Hüttel gentoo-dev 2010-04-03 17:51:05 UTC
Fixed and rubyfied ebuild in overlay as -r1 (since the original is stable). 

Emerges fine here. Please test... :)
Comment 9 Maciej Mrozowski gentoo-dev 2010-04-05 07:04:25 UTC
I've reverted rubyfication (reason in bug 287906) and applied dependency fixes. Thanks