Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 291916 - sys-apps/baselayout-1.12.13: boot fails because /dev isnt created (because /proc and /sys arent mounted)
Summary: sys-apps/baselayout-1.12.13: boot fails because /dev isnt created (because /p...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 292291 301131 (view as bug list)
Depends on:
Blocks: 336723
  Show dependency tree
 
Reported: 2009-11-04 21:24 UTC by Mark Lewandowski
Modified: 2010-09-11 12:31 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lewandowski 2009-11-04 21:24:56 UTC
I upgraded from sys-apps/baselayout-1.12.11.1 to sys-apps/baselayout-1.12.13, ran etc-update, and rebooted.  When the machine tried rebooted it could no longer mount an ext4 partition as /.  The error message said something about not being able to find my device '/dev/hda3', and also said that the ext2 partition had a bad superblock.  I will try to reproduce this, and post more later when I have a chance.

Reproducible: Always
Comment 1 Jakob Ameres 2009-11-05 17:04:59 UTC
Same Problem. After updating baselayout AND doing etc-update there seems to be an udev problem. It looks like /dev is not properly mounted. Also mount udev /dev doesn't work. But when doing "mount --bind / /mnt/test" I can see my whole /dev filesystem under /mnt/test/dev/
So hardware/drivers are working, and it's not an ext3 or ext4 problem, because all device nodes appear in /mnt/test/dev but not in /dev...
Also i reemerged baselayouts and udev by chrooting from a livecd. But this helped nothing, i still can't boot properly!
Comment 2 Jonathan Heaney 2009-11-05 17:27:05 UTC
I'm seeing this on my hardened server since baselayout upgrade last night, using ext3.  As this is my firewall/router/fileserver, it's a major issue (maybe this bug should be marked severe or otherwise, as it appears to be a system-breaker).  Everything is stable x86.
Comment 3 Ville Aakko 2009-11-05 17:59:41 UTC
Hi!

I'm having (probably) this same problem. It started after an emerge -uDNvat world, where a lot of packages, including baselayout, was upgraded to the said version. The system was quite up-to-date before the upgrade, so I believe there were no other critical system packages upgraded, to cause this.

In the boot process, udev seems to start (there is [ ok ] at the line), but right after it, there is an error: "Assuming udev failed somewhere, as /dev/zero does not exist.". Then, the boot process stops, because the root can't be mounted -- well, actually, in my case, I don't have a separate boot partition, so the root is mounted, but read only, and by the kernel. I can log in in maintanance mode to check around.

But, the /dev is crippled, as is the whole system is crippled because of this. No network, no PTY's to start a screen session (but I can mount the root rw with mount -o remount,rw /). So it is difficult to get a make.conf or emerge --info out of the system. But, for short, this is a x86 system (on an amd64), currently on 2.6.25 kernel.

By running dmesg, I noticed this: "udev: deprecated sysfs layout; update the kernel or disable CONFIG_SYSFS_DEPRECATED; some udev features will not work correctly".

I have been on 2.6.25 for ages, and haven't changes the kernel config or installed a new one. I checked in /var/log/dmesg, and there has not been this error before in the logs.

Any suggestions?

I agree the severity should be changed.
Comment 4 Mark Lewandowski 2009-11-05 18:11:09 UTC
(In reply to comment #0)
> I upgraded from sys-apps/baselayout-1.12.11.1 to sys-apps/baselayout-1.12.13,
> ran etc-update, and rebooted.  When the machine tried rebooted it could no
> longer mount an ext4 partition as /.  The error message said something about
> not being able to find my device '/dev/hda3', and also said that the ext2
> partition had a bad superblock.  I will try to reproduce this, and post more
> later when I have a chance.
> 
> Reproducible: Always
> 
I reverted back to sys-apps/baselayout-1.12.11.1 and everything works fine.  

I agree with the other commenters that this actually seems to be a problem mounting /dev.  At bootup time, when / failed to mount I entered maintenance mode I was unable to access /dev.
Comment 5 Jakob Ameres 2009-11-05 18:57:34 UTC
> By running dmesg, I noticed this: "udev: deprecated sysfs layout; update the
> kernel or disable CONFIG_SYSFS_DEPRECATED; some udev features will not work
> correctly".

Same message, so i set up a new kernel linux-2.6.30-gentoo-r8, but no effect.
Now i try to revert back to sys-apps/baselayout-1.12.11.1
I also agree the severity should be changed.
Comment 6 Ville Aakko 2009-11-05 19:12:53 UTC
I downgraded the baselayout 1.12.11.1 and everything seems to work again.

My emerge --info:
Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.25-gentoo-r9-VillenVDRdevil-r3 i686)
=================================================================                                                            
System uname: Linux-2.6.25-gentoo-r9-VillenVDRdevil-r3-i686-AMD_Athlon-tm-_Dual_Core_Processor_4850e-with-gentoo-1.12.11.1   
Timestamp of tree: Wed, 04 Nov 2009 15:30:01 +0000                                                                           
distcc 3.1 i686-pc-linux-gnu [disabled]                                                                                      
ccache version 2.4 [disabled]                                                                                                
app-shells/bash:     4.0_p28                                                                                                 
dev-java/java-config: 2.1.9-r1                                                                                               
dev-lang/python:     2.5.4-r3, 2.6.2-r1                                                                                      
dev-python/pycrypto: 2.0.1-r8                                                                                                
dev-util/ccache:     2.4-r7                                                                                                  
dev-util/cmake:      2.6.4-r3                                                                                                
sys-apps/baselayout: 1.12.11.1                                                                                               
sys-apps/sandbox:    1.6-r2                                                                                                  
sys-devel/autoconf:  2.13, 2.63-r1                                                                                           
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                               
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ ftp://trumpetti.atm.tut.fi/gentoo/"
LANG="fi_FI.UTF-8"
LC_ALL="fi_FI.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fi en_GB en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/vdr-testing /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac aalib ace acl acpi aio alsa amr ao aotuv audacious audio bash-completion bigpatch bittorrent bluetooth branding bzip2 cairo cdaudio cdda cddb cdinstall cdparanoia cdr cdrom cdsound chardet cli cmdsubmenu consolekit cpufreq cracklib crypt css cups curl daap daemon dbus dga direct_blit divx djvu dri dts dv dvb dvbplayer dvd dvdarchive dvdnav dvdr dvdread emboss enca encode evo exif fam fame fbcon ffmpeg fi firefox flac fortran ftp gcj gd geoip gif git google google-gadgets gpm gstreamer gtk gzip hal hddtemp iconv id3 id3tag ieee1394 imagemagick imon ipod ipv6 irssi joystick jpeg jpeg2k jumpplay kde kdecards kdepim kdm lame latin1 lcd ldap libcaca libnotify libvisual lirc live lm_sensors logrotate lzo mad md5sum mikmod mixer mjpeg mmx mmxext mng modplug modules mp2 mp3 mp4 mp4live mpeg mpeg2 mplayer mtp mudflap musepack music musicbrainz mysql mythtv ncurses nfs nls nodrm nptl nptlonly nsplugin nvram ogg oggvorbis openal opengl openmp pam pcntl pcre pdf perl phonon plugin plugins png poppler-data portage ppds pppd projectx ps pvr python qt3 qt3support qt4 quicktime rar raw readline realmedia reflection remix rtc samba sdl sdl-image sdl-sound sdlaudio session sid slp sound speech speex spell srt sse sse2 ssl startup-notification stream subtitles subversion svg sysfs systray taglib tagwriting tga theora threads thunar tiff timidity transcode trash-plugin trayicon truetype ttxtsubs type1 unicode unzip usb userlocales v4l v4l2 vcd vcdimager vdr video videos vidix vim vim-syntax vim-with-x visualization voice volctrl vorbis wavpack webkit win32codecs wma wmf wmp wxwindows x264 x86 xanim xfce xine xinerama xml xorg xrandr xscreensaver xterm xulrunner xv xvid xvmc yaepg zip zlib" ALSA_CARDS="hda-intel virmidi" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fi en_GB en" LIRC_DEVICES="serial" USERLAND="GNU" VIDEO_CARDS="vesa fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Jakob Ameres 2009-11-05 19:51:52 UTC
After adding =sys-apps/baselayout-1.12.13 to /etc/portage/package.mask system works again:

Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r8-i686-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-1.12.11.1
Timestamp of tree: Thu, 05 Nov 2009 18:20:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch prelink protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ "
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa arts battery berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dri dts dv dvd dvdr dvdread eds emboss encode evo ffmpeg firefox flac fortran gcj gdbm gif glut gnome gpm gstreamer gtk hal ibam iconv ipv6 java jpeg jpeg2k kde ldap libnotify mad mikmod mmx modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg openal opengl openmp oss pam pcre pdf perl pm_utils png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sasl scanner sdl session spell spl sql sse sse2 sse3 ssl ssse3 startup-notification svg symlink sysfs tcpd theora thunar tiff truetype unicode usb v4l v4l2 vcd vorbis wavpack webkit win32codecs x264 x86 xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="fuji ptp2 ricoh samsung spca50x" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="radeonhd vga radeon fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Jonathan Heaney 2009-11-05 19:59:25 UTC
http://img687.imageshack.us/img687/5991/dsc00030o.jpg

Screenshot of what the failure looks like here.  About to attempt baselayout downgrade.
Comment 9 Jonathan Heaney 2009-11-05 20:29:42 UTC
Downgrading to 1.12.11.1 fixed it here also.  1.12.13 should be masked asap until this is fixed.
Comment 10 maker 2009-11-06 19:22:38 UTC
Same here. Reverting back to baselayout 1.12.11.1 also solved the issue. I agree that baselayout 1.12.13 should be masked.
Comment 11 SpanKY gentoo-dev 2009-11-06 22:53:08 UTC
if you read the error output, it's probably telling you the problem already.  your system has crap in the rootfs:
einfo "Skipping mount of /proc as /proc/uptime exists"
einfo "Skipping mount of /sys as /sys/kernel exists"

if you `rm -rf /proc/* /sys/*`, doesnt it boot ?
Comment 12 Jonathan Heaney 2009-11-07 00:19:56 UTC
(In reply to comment #11)
> if you read the error output, it's probably telling you the problem already. 
> your system has crap in the rootfs:
> einfo "Skipping mount of /proc as /proc/uptime exists"
> einfo "Skipping mount of /sys as /sys/kernel exists"
> 
> if you `rm -rf /proc/* /sys/*`, doesnt it boot ?
> 

Updating baselayout, booting off systemrescuecd, mounting /, and emptying /proc and /sys works here.
Comment 13 SpanKY gentoo-dev 2009-11-07 00:33:41 UTC
you dont really need a rescue cd.  simply modify your kernel command line in grub like so:
..... rw init=/bin/sh

that'll give you a shell with a read/write root fs
Comment 14 Jonathan Heaney 2009-11-07 13:45:02 UTC
(In reply to comment #13)
> you dont really need a rescue cd.  simply modify your kernel command line in
> grub like so:
> ..... rw init=/bin/sh
> 
> that'll give you a shell with a read/write root fs
> 

Didn't know that, it's done now anyway.  Maybe there should be a post-emerge advisory on the possible need to clear out /proc and /sys.
Comment 15 SpanKY gentoo-dev 2009-11-07 14:10:10 UTC
if we can confirm this is indeed the source of everyone's (most?) problems, i can look at how to address the issue more naturally.  perhaps automatically bind mount root and delete the files for the user ...
Comment 16 maker 2009-11-07 17:48:07 UTC
I reinstalled 1.12.13. Cleaning /proc and /sys helps. Thanks!
Comment 17 SpanKY gentoo-dev 2009-11-07 21:07:50 UTC
*** Bug 292291 has been marked as a duplicate of this bug. ***
Comment 18 thomas 2009-11-07 22:17:17 UTC
Exactly the same here. The ebuild should at least display a warning about cleaning /proc.
Comment 19 Matthias Schwarzott gentoo-dev 2009-11-13 12:32:41 UTC
baselayout-2 uses this code to find out if /proc should be mounted. It tests if /proc/uptime is static or does change.

Another possible test is to check with some way if /proc/ and / are on the same filesystem.

code from openrc:
mountproc=true
if [ -e /proc/uptime ]; then
        up="$(cat /proc/uptime)"
        sleep 1
        if [ "$up" = "$(cat /proc/uptime)" ]; then
                eerror "You have cruft in /proc that should be deleted"
        else
                einfo "/proc is already mounted, skipping"
                mountproc=false
        fi
fi

if $mountproc; then
        procfs="proc"
        [ "$RC_UNAME" = "GNU/kFreeBSD" ] && proc="linprocfs"
        ebegin "Mounting /proc"
        if ! fstabinfo --mount /proc; then
                mount -n -t "$procfs" -o noexec,nosuid,nodev proc /proc
        fi
        eend $?
fi
Comment 20 Francisco Ares 2009-11-14 00:52:16 UTC
Same here, cleared /sys and it worked with still an issue: genkernel didn't disable CONFIG_SYSFS_DEPRECATED as noted on an still failing boot.
With this enabled, udevd didn't work as expected.
Rebuild the kernel, now it works ok.
Comment 21 SpanKY gentoo-dev 2009-11-14 03:38:19 UTC
i know openrc scans, but i didnt think it was really necessary.  the fstab/mount info programs arent also usable since those are part of openrc.

checking dev number via stat should be usable

http://sources.gentoo.org/baselayout/branches/baselayout-1_12/sbin/rc?r1=3160&r2=3161
Comment 22 Matthias Schwarzott gentoo-dev 2009-11-14 12:59:25 UTC
On my system, stat is only in /usr/bin/stat.

The code I meant was the first part - reading uptime a second later and comparing.
Comment 23 Ville Aakko 2009-11-14 17:55:37 UTC
Clearing /sys worked for me (/proc had nothing static in my case). Then I was hit by bug #281312, as I'm forced to stay on 2.6.25 currently, but that's another issue.

Thanks!
Comment 24 Thomas Seifert 2009-11-21 12:32:45 UTC
Just a me too: after 3 hours of debugging I found this bug report.
Cleaning out /sys solved the mystery for me too.
Comment 25 Juan Manuel Santos 2009-12-04 04:56:49 UTC
Why is this marked as resolved & fixed? I updated two days ago and hit the bug anyway. Can't something be done in order to avoid this?

I mean, the regular user (as "regular" as it could get when using gentoo) will face this bug and won't know what to do. And I believe that many will agree with me that, even while the solution is quite simple, it is a showstopper bug (I've had less showstopper bugs with E17 ;p).

I think I'm still angry because this could have been softened by something as simple as an ewarn (if this ebuild was extensively tested). Still, I don't think this is a solution, more of a workaround.
Comment 26 Andreas Vindal 2009-12-07 19:14:56 UTC
(In reply to comment #12)
> Updating baselayout, booting off systemrescuecd, mounting /, and emptying /proc
> and /sys works here.

when mounting / from a CD and trying to remove the mounted/proc i just get error messages - Operation not permitted - for every file in /proc

what am i doing wrong? 
Comment 27 Doug Conyers 2009-12-08 00:05:19 UTC
> when mounting / from a CD and trying to remove the mounted/proc i just get
> error messages - Operation not permitted - for every file in /proc
> what am i doing wrong? 

Great, at least I'm not the only one!  I, too, am not able to delete the contents of /proc.  I was able to downgrade baselayout in order to get an operational system, but I'd really like to get this fixed completely!

Thank You in advance - doug.
Comment 28 Ville Aakko 2009-12-09 16:07:03 UTC
For comment #26 and #27:

You must not have permissions to write to the root. Two thing come into my mind: Have you mounted root as rw (not ro)? Also, are you root? You need to be (even if mounting from a liveCD).

Also, you do not need a CD (or anthing external to boot from) to do fix this. Just pass "init=/bin/sh" for the kernel as a parameter (so that the init scripts don't try to mount anything in to /proc, since then you might not be able to delete the files). You can mount the root as rw by running 'mount -o remount,rw /' (or, replace / with the mount point of root, if you're running from a CD and have mounted it elsewhere).
 
 - Ville

p.s. This is not a point for discussions about troubleshooting - it doesn't bother me but I've seen some admins have sometimes noted about it. So open a thread in the forums if you still need help =)
Comment 29 SpanKY gentoo-dev 2010-01-24 01:50:12 UTC
*** Bug 301131 has been marked as a duplicate of this bug. ***
Comment 30 Kir Kolyshkin 2010-07-21 17:38:59 UTC
Guys,

I know this was fixed but still.

For /sys, if it is mounted after /proc, a proper check can be done way easier, something like egrep -q '^/sys[[:space:]]' should suffice.

Current checks (that /sys/kernel directory exists and its device number differs from one of /) can still produce false positive if someone ugly would mount /sys as a separate partition and then do mkdir /sys/kernel. Probably not worth fixing that, just FYI.