Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291273 - gnome-extra/gnome-power-manager-2.28.1 no hibernate/suspend support
Summary: gnome-extra/gnome-power-manager-2.28.1 no hibernate/suspend support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
Depends on: 222551
Blocks: gnome2.28
  Show dependency tree
 
Reported: 2009-10-31 09:38 UTC by Fabiano Francesconi
Modified: 2009-12-13 23:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (einfo,3.40 KB, text/plain)
2009-10-31 09:39 UTC, Fabiano Francesconi
Details
$HOME/.xsession-errors (xsession,6.85 KB, text/plain)
2009-11-01 11:00 UTC, Fabiano Francesconi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiano Francesconi 2009-10-31 09:38:56 UTC
Suspend/Hibernate buttons does not appear clicking on gpm traybar icon.
Furthermore even "Shutdown" dialog doesn't provide these buttons.

- pm-suspend works like a charm
- in gconf suspend/hibernate options are enabled

/apps/gnome-power-manager/general/can_suspend true
/apps/gnome-power-manager/general/can_hibernate true

gnome-extra/gnome-power-manager (-debug -doc -policykit -test)
Comment 1 Fabiano Francesconi 2009-10-31 09:39:26 UTC
Created attachment 208836 [details]
emerge --info
Comment 2 water 2009-10-31 10:37:36 UTC
I have the same problem.
I can not see gnome-power-manager icon in gnome-panel.
I can not see `restart' and `shutdown' icon even.

Comment 3 water 2009-10-31 10:50:13 UTC
(In reply to comment #2)
> I have the same problem.
> I can not see gnome-power-manager icon in gnome-panel.
> I can not see `restart' and `shutdown' icon even.
> 

after I re-emerge dbus. I can see restart and shut_down.
But I still can not see gnome-power-manager2.28 icon in gnome-panel.
Now my gnome-panel is still 2.26.
Comment 4 Fabiano Francesconi 2009-10-31 10:59:27 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > I have the same problem.
> > I can not see gnome-power-manager icon in gnome-panel.
> > I can not see `restart' and `shutdown' icon even.
> > 
> 
> after I re-emerge dbus. I can see restart and shut_down.
> But I still can not see gnome-power-manager2.28 icon in gnome-panel.
> Now my gnome-panel is still 2.26.
> 

Try to adjust the settings. Now there seems to not be present anymore the old behavior (show icon only if a battery is attached).

You should be able to restore the tray icon by selecting "show always" option.
Comment 5 water 2009-10-31 12:24:07 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > I have the same problem.
> > > I can not see gnome-power-manager icon in gnome-panel.
> > > I can not see `restart' and `shutdown' icon even.
> > > 
> > 
> > after I re-emerge dbus. I can see restart and shut_down.
> > But I still can not see gnome-power-manager2.28 icon in gnome-panel.
> > Now my gnome-panel is still 2.26.
> > 
> 
> Try to adjust the settings. Now there seems to not be present anymore the old
> behavior (show icon only if a battery is attached).
> 
> You should be able to restore the tray icon by selecting "show always" option.
> 

Yes, I can see the icon now.
But in the setting , I can not see `On battery' tab.
And I can not see `suspend' and `hibernate' menu items when right pointing the icon.
Comment 6 Fabiano Francesconi 2009-10-31 13:00:27 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > (In reply to comment #2)
> > > > I have the same problem.
> > > > I can not see gnome-power-manager icon in gnome-panel.
> > > > I can not see `restart' and `shutdown' icon even.
> > > > 
> > > 
> > > after I re-emerge dbus. I can see restart and shut_down.
> > > But I still can not see gnome-power-manager2.28 icon in gnome-panel.
> > > Now my gnome-panel is still 2.26.
> > > 
> > 
> > Try to adjust the settings. Now there seems to not be present anymore the old
> > behavior (show icon only if a battery is attached).
> > 
> > You should be able to restore the tray icon by selecting "show always" option.
> > 
> 
> Yes, I can see the icon now.
> But in the setting , I can not see `On battery' tab.
> And I can not see `suspend' and `hibernate' menu items when right pointing the
> icon.
> 
That's why I've opened this bug report ;)
Comment 7 Romain Perier (RETIRED) gentoo-dev 2009-10-31 17:58:39 UTC
apps/gnome-power-manager/ui/show_actions_in_menu ;)

it's not a bug, see https://bugzilla.gnome.org/show_bug.cgi?id=597490
Comment 8 Fabiano Francesconi 2009-10-31 18:11:18 UTC
(In reply to comment #7)
> apps/gnome-power-manager/ui/show_actions_in_menu ;)
> 
> it's not a bug, see https://bugzilla.gnome.org/show_bug.cgi?id=597490
> 

gconftool-2 -g /apps/gnome-power-manager/ui/show_actions_in_menu
true

No buttons here
Comment 9 Romain Perier (RETIRED) gentoo-dev 2009-10-31 19:18:00 UTC
mhhh... you're on a stable system.
- well, what are your version of devicekit-power ?
- Any messages in .xsession-errors ?
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-10-31 22:17:59 UTC
did you reload dbus or restarted computer since update ?
Comment 11 water 2009-11-01 03:46:58 UTC
(In reply to comment #9)
> mhhh... you're on a stable system.
> - well, what are your version of devicekit-power ?
> - Any messages in .xsession-errors ?
> 
I set apps/gnome-power-manager/ui/show_actions_in_menu , but still can not see action menu.
my devicekit-power is 011.
I find `(gnome-power-manager:4946): devkit-power-gobject-WARNING **: No 'DaemonVersion' property ' in .xsession-errors.

I have restart many times.
Comment 12 Fabiano Francesconi 2009-11-01 10:59:32 UTC
This is my actual configuration:

dev-libs/glib-2.22.2
sys-auth/consolekit-0.4.1
sys-apps/devicekit-003
sys-apps/devicekit-power-009
x11-libs/gtk+-2.18.3
gnome-extra/gnome-power-manager-2.28.1

I didn't want to unmask devicekit-power-011 since I don't want to unmask too many packages right now, especially udev's ones :P

I attach my .xsession-errors logfile

And, of course, I've restarted the machine more than once.
Comment 13 Fabiano Francesconi 2009-11-01 11:00:05 UTC
Created attachment 208928 [details]
$HOME/.xsession-errors
Comment 14 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-11-01 11:20:48 UTC
This is most likely related to your /not/ using a newer devicekit-power. Please verify that that is the case so we can update the dependencies if required.

See http://www.faulhammer.org/archiv-mainmenu-31/35-gentoo/307-testers-wanted-for-x86 for details on how to keyword udev and friends.
Comment 15 Romain Perier (RETIRED) gentoo-dev 2009-11-01 11:25:28 UTC
Could you try the following command :
dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call --print-reply=yes /org/freedesktop/DeviceKit/Power org.freedesktop.DeviceKit.Power.Suspend

==> if it works, it will suspend your system (gnome-power-manager uses devkit-power for suspend and hibernate stuffs)
Comment 16 Fabiano Francesconi 2009-11-01 11:41:54 UTC
(In reply to comment #15)
> Could you try the following command :
> dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call
> --print-reply=yes /org/freedesktop/DeviceKit/Power
> org.freedesktop.DeviceKit.Power.Suspend
> 
> ==> if it works, it will suspend your system (gnome-power-manager uses
> devkit-power for suspend and hibernate stuffs)
> 

dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call --print-reply=yes /org/freedesktop/DeviceKit/Power org.freedesktop.DeviceKit.Power.Suspend

Error org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success
Comment 17 water 2009-11-01 13:41:46 UTC
(In reply to comment #15)
> Could you try the following command :
> dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call
> --print-reply=yes /org/freedesktop/DeviceKit/Power
> org.freedesktop.DeviceKit.Power.Suspend
> 
> ==> if it works, it will suspend your system (gnome-power-manager uses
> devkit-power for suspend and hibernate stuffs)
> 
I use sys-apps/devicekit-power 011.
Using your command , I can suspend. but after resume , color maybe does not have enough bits.
Comment 18 water 2009-11-01 13:45:03 UTC
I find there comes devicekit-power 012 
Comment 19 Romain Perier (RETIRED) gentoo-dev 2009-11-01 14:00:53 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > Could you try the following command :
> > dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call
> > --print-reply=yes /org/freedesktop/DeviceKit/Power
> > org.freedesktop.DeviceKit.Power.Suspend
> > 
> > ==> if it works, it will suspend your system (gnome-power-manager uses
> > devkit-power for suspend and hibernate stuffs)
> > 
> 
> dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call
> --print-reply=yes /org/freedesktop/DeviceKit/Power
> org.freedesktop.DeviceKit.Power.Suspend
> 
> Error org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program
> /usr/libexec/dbus-daemon-launch-helper: Success
> 

Apparently you've a problem with dbus...
@dang: no ideas ?
Comment 20 Fabiano Francesconi 2009-11-01 17:12:53 UTC
(In reply to comment #19)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > Could you try the following command :
> > > dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call
> > > --print-reply=yes /org/freedesktop/DeviceKit/Power
> > > org.freedesktop.DeviceKit.Power.Suspend
> > > 
> > > ==> if it works, it will suspend your system (gnome-power-manager uses
> > > devkit-power for suspend and hibernate stuffs)
> > > 
> > 
> > dbus-send --system --dest=org.freedesktop.DeviceKit.Power --type=method_call
> > --print-reply=yes /org/freedesktop/DeviceKit/Power
> > org.freedesktop.DeviceKit.Power.Suspend
> > 
> > Error org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program
> > /usr/libexec/dbus-daemon-launch-helper: Success
> > 
> 
> Apparently you've a problem with dbus...
> @dang: no ideas ?
> 

or maybe some policies?
Comment 21 Gilles Dartiguelongue gentoo-dev 2009-11-01 21:23:36 UTC
could you paste the output of:
$ ls -l /usr/libexec/dbus-daemon-launch-helper
Comment 22 Fabiano Francesconi 2009-11-02 00:07:21 UTC
(In reply to comment #21)
> could you paste the output of:
> $ ls -l /usr/libexec/dbus-daemon-launch-helper
> 

-rws--x--- 1 root root 100840  1 set 22:44 /usr/libexec/dbus-daemon-launch-helper
Comment 23 Gilles Dartiguelongue gentoo-dev 2009-11-02 00:19:18 UTC
Ok, that might relate to bug #222551. Could you run:
# chgrp messagebus /usr/libexec/dbus-daemon-launch-helper

as root, and try again the dbus command as your user ?
Comment 24 Fabiano Francesconi 2009-11-02 00:20:56 UTC
I ran into bug #281640 and I've re-emerged dbus.
Then I've restarted dbus and now everything seems to be working just fine.

I think isn't necessary to issue the command above.
Comment 25 Fabiano Francesconi 2009-11-02 00:23:19 UTC
(In reply to comment #24)
> I ran into bug #281640 and I've re-emerged dbus.
> Then I've restarted dbus and now everything seems to be working just fine.
> 
> I think isn't necessary to issue the command above.
> 

For the record, power chronology (don't know if it's the right translation of that command) wasn't showing up correctly.
Now that seems to work as well.
Comment 26 Gilles Dartiguelongue gentoo-dev 2009-11-02 00:32:04 UTC
Ok I guess that's really bug #222551 after all. Thanks for reporting.
Comment 27 water 2009-11-02 02:59:53 UTC
(In reply to comment #21)
> could you paste the output of:
> $ ls -l /usr/libexec/dbus-daemon-launch-helper
> 
My problem still exists.
-rws--x--- 1 root messagebus 100576 2009-11-02 10:50 /usr/libexec/dbus-daemon-launch-helper (this is my origional setting)
And I re-emerge dbus, restart.
I still can not see suspend and hibernate menu items.

Thanks
Comment 28 Fabiano Francesconi 2009-11-02 09:07:02 UTC
(In reply to comment #27)
> (In reply to comment #21)
> > could you paste the output of:
> > $ ls -l /usr/libexec/dbus-daemon-launch-helper
> > 
> My problem still exists.
> -rws--x--- 1 root messagebus 100576 2009-11-02 10:50
> /usr/libexec/dbus-daemon-launch-helper (this is my origional setting)
> And I re-emerge dbus, restart.
> I still can not see suspend and hibernate menu items.
> 
> Thanks
> 

could you run "devkit-power"?
It should give you no output but, before re-emering dbus, it gave me some errors.
Comment 29 water 2009-11-02 10:16:41 UTC
(In reply to comment #28)
> (In reply to comment #27)
> > (In reply to comment #21)
> > > could you paste the output of:
> > > $ ls -l /usr/libexec/dbus-daemon-launch-helper
> > > 
> > My problem still exists.
> > -rws--x--- 1 root messagebus 100576 2009-11-02 10:50
> > /usr/libexec/dbus-daemon-launch-helper (this is my origional setting)
> > And I re-emerge dbus, restart.
> > I still can not see suspend and hibernate menu items.
> > 
> > Thanks
> > 
> 
> could you run "devkit-power"?
> It should give you no output but, before re-emering dbus, it gave me some
> errors.
> 

I run devkit-power, it gives nothing.
Comment 30 Fabiano Francesconi 2009-11-02 10:28:11 UTC
(In reply to comment #29)
> (In reply to comment #28)
> > (In reply to comment #27)
> > > (In reply to comment #21)
> > > > could you paste the output of:
> > > > $ ls -l /usr/libexec/dbus-daemon-launch-helper
> > > > 
> > > My problem still exists.
> > > -rws--x--- 1 root messagebus 100576 2009-11-02 10:50
> > > /usr/libexec/dbus-daemon-launch-helper (this is my origional setting)
> > > And I re-emerge dbus, restart.
> > > I still can not see suspend and hibernate menu items.
> > > 
> > > Thanks
> > > 
> > 
> > could you run "devkit-power"?
> > It should give you no output but, before re-emering dbus, it gave me some
> > errors.
> > 
> 
> I run devkit-power, it gives nothing.
> 

Then, could you issue:
gconftool-2 -g /apps/gnome-power-manager/ui/show_actions_in_menu
Comment 31 water 2009-11-02 13:26:30 UTC
(In reply to comment #30)
> (In reply to comment #29)
> > (In reply to comment #28)
> > > (In reply to comment #27)
> > > > (In reply to comment #21)
> > > > > could you paste the output of:
> > > > > $ ls -l /usr/libexec/dbus-daemon-launch-helper
> > > > > 
> > > > My problem still exists.
> > > > -rws--x--- 1 root messagebus 100576 2009-11-02 10:50
> > > > /usr/libexec/dbus-daemon-launch-helper (this is my origional setting)
> > > > And I re-emerge dbus, restart.
> > > > I still can not see suspend and hibernate menu items.
> > > > 
> > > > Thanks
> > > > 
> > > 
> > > could you run "devkit-power"?
> > > It should give you no output but, before re-emering dbus, it gave me some
> > > errors.
> > > 
> > 
> > I run devkit-power, it gives nothing.
> > 
> 
> Then, could you issue:
> gconftool-2 -g /apps/gnome-power-manager/ui/show_actions_in_menu
> 

when I run that , i get true.
Comment 32 Robert Coffree 2009-11-03 15:59:42 UTC
Whats going on here? I just tried out ubuntu and behold there is a new power button applet that contains the suspend and hibernate functionality, which the default on the power-manager is crippled.


(In reply to comment #31)
> (In reply to comment #30)
> > (In reply to comment #29)
> > > (In reply to comment #28)
> > > > (In reply to comment #27)
> > > > > (In reply to comment #21)
> > > > > > could you paste the output of:
> > > > > > $ ls -l /usr/libexec/dbus-daemon-launch-helper
> > > > > > 
> > > > > My problem still exists.
> > > > > -rws--x--- 1 root messagebus 100576 2009-11-02 10:50
> > > > > /usr/libexec/dbus-daemon-launch-helper (this is my origional setting)
> > > > > And I re-emerge dbus, restart.
> > > > > I still can not see suspend and hibernate menu items.
> > > > > 
> > > > > Thanks
> > > > > 
> > > > 
> > > > could you run "devkit-power"?
> > > > It should give you no output but, before re-emering dbus, it gave me some
> > > > errors.
> > > > 
> > > 
> > > I run devkit-power, it gives nothing.
> > > 
> > 
> > Then, could you issue:
> > gconftool-2 -g /apps/gnome-power-manager/ui/show_actions_in_menu
> > 
> 
> when I run that , i get true.
> 

Comment 33 Carl Michal 2009-11-20 22:11:47 UTC
I've seen very similar problems to those described here - after upgrading to g-p-m 2.28 (from 2.22) its mostly non-functional.  

After trying everything described, and not getting too far, I finally discovered this post: 
http://www.mail-archive.com/networkmanager-list@gnome.org/msg14117.html

The relevant piece of which is:

>  what version of dbus-glib?  Earlier versions had problems
> with GetAll specifically.  You may need these dbus-glib commits:

I upgraded from dbus-glib-0.76 to 0.80, restarted devicekit-power-daemon and my problem went away.

The obvious symptom here was that devkit-power -v would complain:
(devkit-power:1628): devkit-power-gobject-WARNING **: No 'DaemonVersion' property
DeviceKit-power client version 012
DeviceKit-power daemon version (null)

perhaps devicekit-power should depend on >=dbus-glib-0.80
Comment 34 water 2009-11-22 03:40:52 UTC
(In reply to comment #33)
> I've seen very similar problems to those described here - after upgrading to
> g-p-m 2.28 (from 2.22) its mostly non-functional.  
> 
> After trying everything described, and not getting too far, I finally
> discovered this post: 
> http://www.mail-archive.com/networkmanager-list@gnome.org/msg14117.html
> 
> The relevant piece of which is:
> 
> >  what version of dbus-glib?  Earlier versions had problems
> > with GetAll specifically.  You may need these dbus-glib commits:
> 
> I upgraded from dbus-glib-0.76 to 0.80, restarted devicekit-power-daemon and my
> problem went away.
> 
> The obvious symptom here was that devkit-power -v would complain:
> (devkit-power:1628): devkit-power-gobject-WARNING **: No 'DaemonVersion'
> property
> DeviceKit-power client version 012
> DeviceKit-power daemon version (null)
> 
> perhaps devicekit-power should depend on >=dbus-glib-0.80
> 

I update dbus-glib to 0.82 . 
Now I can see `On Battery power' tab in Preferences of gnome-power-manager.
But I still can not see `hibernate' and `suspend' when right click the icon of gnome-power-manager.
Thanks
Comment 35 water 2009-11-22 03:47:55 UTC
(In reply to comment #33)
> I've seen very similar problems to those described here - after upgrading to
> g-p-m 2.28 (from 2.22) its mostly non-functional.  
> 
> After trying everything described, and not getting too far, I finally
> discovered this post: 
> http://www.mail-archive.com/networkmanager-list@gnome.org/msg14117.html
> 
> The relevant piece of which is:
> 
> >  what version of dbus-glib?  Earlier versions had problems
> > with GetAll specifically.  You may need these dbus-glib commits:
> 
> I upgraded from dbus-glib-0.76 to 0.80, restarted devicekit-power-daemon and my
> problem went away.
> 
> The obvious symptom here was that devkit-power -v would complain:
> (devkit-power:1628): devkit-power-gobject-WARNING **: No 'DaemonVersion'
> property
> DeviceKit-power client version 012
> DeviceKit-power daemon version (null)
> 
> perhaps devicekit-power should depend on >=dbus-glib-0.80
> 

I update dbus-glib to 0.82 . 
Now I can see `On Battery power' tab in Preferences of gnome-power-manager.
But I still can not see `hibernate' and `suspend' when right click the icon of
gnome-power-manager.
I can see `hibernate' and `suspend' in the `shut down' window.
Thanks
Comment 36 water 2009-11-22 05:32:15 UTC
sorry, I now can see `suspend' and `hibernate' in left clicking icon of gnome-power-manager.