Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 291236 - app-emulation/open-vm-tools 20091015 vmtoolsd fails to start
Summary: app-emulation/open-vm-tools 20091015 vmtoolsd fails to start
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major with 2 votes (vote)
Assignee: Vadim Kuznetsov (RETIRED)
: 283654 (view as bug list)
Depends on:
Reported: 2009-10-30 23:16 UTC by Brandon Holbrook
Modified: 2009-12-20 14:10 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Brandon Holbrook 2009-10-30 23:16:13 UTC
The /etc/init.d/vmware-tools script fails to start.

When attempting to execute vmtoolsd manually in the forground, I get:
[   error] [vmsvc] Trying to overwrite existing RPC registration for f!

See the Debian bugreport at:

Supposedly the problem is caused because /etc/vmware-tools/plugins/common/ contains both .so files and .la files.  I tried removing the .la files as the report suggests, and it did indeed fix the problem for me.  The Debian bugreport also includes a patch to to avoid installing the files.

Reproducible: Always
Comment 1 Troy Bowman 2009-11-01 20:08:12 UTC
Yup, removing the .la files worked for me!  :)
Comment 2 Wormo (RETIRED) gentoo-dev 2009-11-12 06:42:09 UTC
Thanks for reporting this .la file problem -- assigning to maintainers.
Comment 3 James Gagnon 2009-11-19 21:26:27 UTC
Removed all .la files resolved the issue for me.

P.S. Hi Troy
Comment 4 Vadim Kuznetsov (RETIRED) gentoo-dev 2009-12-20 14:08:50 UTC
*** Bug 283654 has been marked as a duplicate of this bug. ***
Comment 5 Vadim Kuznetsov (RETIRED) gentoo-dev 2009-12-20 14:10:40 UTC
fixed in open-vm-tools-0.0.20091216.217847.ebuild