Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289987 - [patch] net-misc/knutclient-0.9.3 fails to compile on gcc-4.3.4
Summary: [patch] net-misc/knutclient-0.9.3 fails to compile on gcc-4.3.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: Inclusion
: 289989 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2009-10-21 11:47 UTC by Israel G. Lugo
Modified: 2009-10-26 17:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to fix paintNumbers function prototype and make it compile (knutclient-0.9.3-fix-proto.diff,406 bytes, patch)
2009-10-21 11:55 UTC, Israel G. Lugo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Israel G. Lugo 2009-10-21 11:47:11 UTC
While emerging net-misc/knutclient-0.9.3:

...
In file included from knutclient.h:29,
                 from main.cpp:25:
knutdock.h: At global scope:
knutdock.h:325: error: multiple parameters named ‘x’
make[2]: *** [main.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-misc/knutclient-0.9.3/work/knutclient-0.9.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-misc/knutclient-0.9.3/work/knutclient-0.9.3'
make: *** [all] Error 2

Looking at the relevant file (src/knutdock.h:325), the problem is evident:
    void paintNumbers (int numbers, int x, int x, QPainter* p ); //x,y levy horni roh cisla 1

There are two parameters called "x", which is now an error both in gcc and g++.

The actual function definition is ok (from file src/knutdock.cpp:1018):
void KNutDock::paintNumbers (int numbers, int x, int y, QPainter* p ) {

I am including a patch to fix the problem.
Comment 1 Israel G. Lugo 2009-10-21 11:55:43 UTC
Created attachment 207809 [details, diff]
Patch to fix paintNumbers function prototype and make it compile

2009-10-21  Israel G. Lugo <israel.lugo@lugosys.com>

	* src/knutdock.h (paintNumbers): Fix prototype, was causing a
	compiler error.
Comment 2 Samuli Suominen gentoo-dev 2009-10-21 12:00:40 UTC
*** Bug 289989 has been marked as a duplicate of this bug. ***
Comment 3 Samuli Suominen gentoo-dev 2009-10-25 12:39:02 UTC
I think you just wasted your time, since 0.9.4 builds fine.
Comment 4 Israel G. Lugo 2009-10-25 12:52:38 UTC
(In reply to comment #3)
> I think you just wasted your time, since 0.9.4 builds fine.
> 

Yes, however 0.9.4 is ~ on all arches.

knutclient-0.9.3, however, is marked stable, as is gcc-4.3.4. We should not have two stable ebuilds that break each other.
Comment 5 Samuli Suominen gentoo-dev 2009-10-25 12:55:27 UTC
Please don't reopen this again. Sync in a hour and watch it all fixed.
Comment 6 Israel G. Lugo 2009-10-26 02:56:10 UTC
(In reply to comment #5)
> Please don't reopen this again. Sync in a hour and watch it all fixed.
> 

My apologies for reopening without discussing first.

I see net-misc/knutclient-0.9.3 is gone from the tree, and knutclient-0.9.4 has been marked stable on all arches now. I can verify that it builds properly, so this bug is fixed.

I am surprised to see 0.9.4 fast-tracked to stable without testing from the arches, though? Especially when there was a patch to trivially fix the existing 0.9.3...
Comment 7 Samuli Suominen gentoo-dev 2009-10-26 09:53:25 UTC
(In reply to comment #6)
> I am surprised to see 0.9.4 fast-tracked to stable without testing from the
> arches, though? Especially when there was a patch to trivially fix the existing
> 0.9.3...

There's no point in bothering the arch's for a package that will be removed soon. There will be a news item about KDE3's removal from tree, and knutclient is unfortunately on that list. 

If you find a alternative for it, please open a new bug for it (and add me to CC list).

Also being removed from other distributions, see ref. http://wiki.debian.org/kdelibs4c2aRemoval
Comment 8 Israel G. Lugo 2009-10-26 17:42:09 UTC
(In reply to comment #7)
> There's no point in bothering the arch's for a package that will be removed
> soon. There will be a news item about KDE3's removal from tree, and knutclient
> is unfortunately on that list. 
Oh, I see. I was not aware that KDE3 was being dropped.

> If you find a alternative for it, please open a new bug for it (and add me to
> CC list).
Actually, upstream says knutclient-0.9.5 runs on KDE4 -- from http://www.knut.noveradsl.cz/knutclient :

"Changed: KNC is running on KDE 4 /on distribution which uses KDE4 a has support for aplication from KDE3 / a little better."

Unfortunately I don't yet have KDE4 myself to test this, but perhaps we could create the ebuild for 0.9.5 and see if it works for others?