Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 289957 - move x11-base/xorg-x11 from world to system
Summary: move x11-base/xorg-x11 from world to system
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-21 05:50 UTC by Emery Hemingway
Modified: 2009-10-24 00:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emery Hemingway 2009-10-21 05:50:46 UTC
I was thinking it might be nice if xorg-x11 was in the scope of system packages. I think that very few people concern themselves with the dependencies of xorg, as changes aren't really tangible to the end user. I use emerge -uD system when I want a system up to date, but don't waste energy on packages I barely use. I regard updating the xorg-x11 meta package the same way.

(Please note I wouldn't bring this up if I didn't think it relative simple to implement.)

Reproducible: Always
Comment 1 proDOOMman 2009-10-21 06:43:19 UTC
Many people haven't X11 on their systems. May be you should add xorg-x11 to system independently?
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-21 08:05:23 UTC
No way. The system set defines a minimal set of packages which are needed to get a linux system booted and working.
Consider a user setting up a gentoo-server being forced to install xorg-x11 just because it's in the system set. 
This kind of changes will never happen.
Comment 3 Emery Hemingway 2009-10-24 00:35:25 UTC
Ok, I guess I didn't understand how the system set worked.
Sorry